aboutsummaryrefslogtreecommitdiffstats
path: root/net-im
diff options
context:
space:
mode:
authornivit <nivit@FreeBSD.org>2014-03-31 06:55:15 +0800
committernivit <nivit@FreeBSD.org>2014-03-31 06:55:15 +0800
commit28b4ba24cf8fdfd1924d948dbd452063163bc675 (patch)
tree26d7597412f8b261980d062cbfeb8ef27035c9bc /net-im
parent5549a6fe05484be97a522626be2c651d560f352e (diff)
downloadfreebsd-ports-gnome-28b4ba24cf8fdfd1924d948dbd452063163bc675.tar.gz
freebsd-ports-gnome-28b4ba24cf8fdfd1924d948dbd452063163bc675.tar.zst
freebsd-ports-gnome-28b4ba24cf8fdfd1924d948dbd452063163bc675.zip
- Convert to USES, that handles tar archives
- Add support for stage dir [1] - Remove post-install-target PR: ports/187887 [1] Submitted by: Johannes Jost Meixner <xmj@chaot.net>
Diffstat (limited to 'net-im')
-rw-r--r--net-im/yoono/Makefile16
1 files changed, 6 insertions, 10 deletions
diff --git a/net-im/yoono/Makefile b/net-im/yoono/Makefile
index 592b01623f1d..0f0cea88b2bc 100644
--- a/net-im/yoono/Makefile
+++ b/net-im/yoono/Makefile
@@ -30,22 +30,18 @@ ONLY_FOR_ARCHS_REASON= binary distribution
SUB_FILES= ${PORTNAME} pkg-message
SUB_LIST= LINUXBASE=${LINUXBASE}
-USE_BZIP2= yes
USE_LDCONFIG= yes
USE_LINUX= yes
USE_LINUX_APPS= alsalib dbuslibs gtk2 xorglibs
+USES= tar:bzip2
WRKSRC= ${WRKDIR}/${PORTNAME}-desktop
-NO_STAGE= yes
do-install:
- ${MKDIR} ${DATADIR}
- cd ${WRKSRC} && \
- ${COPYTREE_SHARE} . ${DATADIR}
- ${CHMOD} ${BINMODE} ${DATADIR}/${PORTNAME}-desktop
- ${INSTALL_SCRIPT} ${WRKDIR}/${PORTNAME} ${PREFIX}/bin/${PORTNAME}
-
-post-install:
- @${CAT} ${PKGMESSAGE}
+ ${MKDIR} ${STAGEDIR}${DATADIR}
+ (cd ${WRKSRC} && \
+ ${COPYTREE_SHARE} . ${STAGEDIR}${DATADIR})
+ ${CHMOD} ${BINMODE} ${STAGEDIR}${DATADIR}/${PORTNAME}-desktop
+ ${INSTALL_SCRIPT} ${WRKDIR}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin/${PORTNAME}
.include <bsd.port.mk>