aboutsummaryrefslogtreecommitdiffstats
path: root/net-im
diff options
context:
space:
mode:
authortijl <tijl@FreeBSD.org>2014-05-21 03:41:32 +0800
committertijl <tijl@FreeBSD.org>2014-05-21 03:41:32 +0800
commit933a5087b637838a392676d552cb6927a9b45eab (patch)
tree38267014aa8a50552ea5eac7447bc11087bc354c /net-im
parent786df3a3f0bbd59039b8cfe7b6c7132d7f325a3b (diff)
downloadfreebsd-ports-gnome-933a5087b637838a392676d552cb6927a9b45eab.tar.gz
freebsd-ports-gnome-933a5087b637838a392676d552cb6927a9b45eab.tar.zst
freebsd-ports-gnome-933a5087b637838a392676d552cb6927a9b45eab.zip
- Remove "${FIND} ${WRKSRC} -type f | ${XARGS} ${TOUCH}" from post-patch.
It was added to prevent running autotools in a previous version of the port but is no longer needed and may actually cause autotools to run because not all files get the same timestamp. - Remove some other things from older versions. Reported by: many PR: ports/189938
Diffstat (limited to 'net-im')
-rw-r--r--net-im/libpurple/Makefile19
1 files changed, 1 insertions, 18 deletions
diff --git a/net-im/libpurple/Makefile b/net-im/libpurple/Makefile
index 9c671c0e20ba..8354a0cf3407 100644
--- a/net-im/libpurple/Makefile
+++ b/net-im/libpurple/Makefile
@@ -20,10 +20,6 @@ CONFIGURE_ARGS?=--disable-gtkui \
--with-dynamic-prpls=${PRPL_MODULES:S/,$//} \
--enable-static \
--disable-nm
-CONFIGURE_ENV= LIBS="-L${LOCALBASE}/lib ${PTHREAD_LIBS}" \
- PTHREAD_LIB="${PTHREAD_LIBS}"
-CFLAGS+= -D_XOPEN_SOURCE_EXTENDED
-CPPFLAGS+= -I${LOCALBASE}/include ${PTHREAD_CFLAGS}
.if !defined(PIDGIN_SLAVE)
# Pidgin slave ports that require the following functionality, must explicitly
@@ -83,8 +79,6 @@ PLIST_SUB+= CONSOLEUI=""
PLIST_SUB+= CONSOLEUI="@comment not installed: "
.endif
-OPTIONSFILE= ${PORT_DBDIR}/${UNIQUENAME}/options
-
CONFIGURE_ARGS+=--disable-doxygen
.include <bsd.port.options.mk>
@@ -319,24 +313,13 @@ pre-everything::
.endif
post-patch:
- @${REINPLACE_CMD} -e 's|-lpthreads|${PTHREAD_LIBS:S/"//g}|g' \
- -e 's|%%LOCALBASE%%|${LOCALBASE}|g' \
- -e 's|-lpanel |-lpanel -lncurses|g' \
+ @${REINPLACE_CMD} \
-e 's|-lpthread|${PTHREAD_LIBS:S/"//g}|g' \
-e 's|-lsilc -lsilcclient ${PTHREAD_LIBS} $$LIBDL|-lsilc -lsilcclient ${PTHREAD_LIBS} ${ICONV_LIB}|' \
- -e 's|TCL_VERSION found but 8.3 required|TCL_VERSION found but ${TCL_VER} required|g' \
- -e 's|TCL_MINOR_VERSION" -ne 3|TCL_MINOR_VERSION" -ne ${TCL_VER:E}|' \
${WRKSRC}/configure
- @${REINPLACE_CMD} -e 's|/bin/bash|${SH}|' \
- ${WRKSRC}/libpurple/purple-send \
- ${WRKSRC}/libpurple/purple-send-async
- @${REINPLACE_CMD} -e 's|/python|/env python|' \
- ${WRKSRC}/libpurple/purple-remote \
- ${WRKSRC}/libpurple/purple-url-handler
.if defined(PIDGIN_SLAVE)
@${FIND} ${BUILD_WRKSRC} -name Makefile.in | ${XARGS} ${REINPLACE_CMD} -e \
's|$$(top_builddir)/libpurple/libpurple.la|-lpurple|'
.endif
- @${FIND} ${WRKSRC} -type f | ${XARGS} ${TOUCH}
.include <bsd.port.post.mk>