aboutsummaryrefslogtreecommitdiffstats
path: root/net-mgmt/argus3/Makefile
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2008-08-01 20:00:41 +0800
committerpav <pav@FreeBSD.org>2008-08-01 20:00:41 +0800
commit3f5910ce46cc4f3692b688a829ae3a39698e0cc8 (patch)
tree9e0240d64de474a7705bf6e745173db19a7f7486 /net-mgmt/argus3/Makefile
parent461c4a4eaac381f50e7cc743436d269221f82334 (diff)
downloadfreebsd-ports-gnome-3f5910ce46cc4f3692b688a829ae3a39698e0cc8.tar.gz
freebsd-ports-gnome-3f5910ce46cc4f3692b688a829ae3a39698e0cc8.tar.zst
freebsd-ports-gnome-3f5910ce46cc4f3692b688a829ae3a39698e0cc8.zip
- Fix SASL2 support (argus[37157]: looking for plugins in '/usr/lib/sasl2',
failed to open directory, error: No such file or directory) - Look for sasl in LOCALBASE, not in PREFIX PR: ports/123880 Submitted by: Tomoyuki Sakurai <cherry@trombik.org> Approved by: maintainer timeout (se; 2 months)
Diffstat (limited to 'net-mgmt/argus3/Makefile')
-rw-r--r--net-mgmt/argus3/Makefile6
1 files changed, 5 insertions, 1 deletions
diff --git a/net-mgmt/argus3/Makefile b/net-mgmt/argus3/Makefile
index bb56cac5bfa1..8b74fbe5a9f5 100644
--- a/net-mgmt/argus3/Makefile
+++ b/net-mgmt/argus3/Makefile
@@ -7,6 +7,7 @@
PORTNAME= argus
PORTVERSION= 3.0.0
+PORTREVISION= 1
CATEGORIES= net-mgmt security
MASTER_SITES= http://qosient.com/argus/src/ \
ftp://qosient.com/pub/argus/src/
@@ -28,12 +29,15 @@ LIB_DEPENDS+= sasl2.2:${PORTSDIR}/security/cyrus-sasl2
USE_BISON= build
GNU_CONFIGURE= true
.if defined(WITH_SASL)
-CONFIGURE_ARGS+= --with-sasl=${PREFIX}
+CONFIGURE_ARGS+= --with-sasl=${LOCALBASE}
.endif
MAN5= argus.conf.5
MAN8= argus.8
+post-patch:
+ @${REINPLACE_CMD} -e 's#/usr/lib/sasl2#${LOCALBASE}/lib/sasl2#' ${WRKSRC}/argus/ArgusOutput.c
+
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/bin/argus ${PREFIX}/sbin/argus
# ${INSTALL_SCRIPT} ${WRKSRC}/bin/argusbug ${PREFIX}/bin/argusbug