aboutsummaryrefslogtreecommitdiffstats
path: root/net-mgmt/bpft/Makefile
diff options
context:
space:
mode:
authorgarga <garga@FreeBSD.org>2009-05-07 02:45:34 +0800
committergarga <garga@FreeBSD.org>2009-05-07 02:45:34 +0800
commita8f5d0ca662c7c924d920d8199575840ec8a3da4 (patch)
tree8a3d3278ab117b02a13018dd05901e2c43a9544c /net-mgmt/bpft/Makefile
parent3c6eb702a46ed9050b63a88121ced172dc23de96 (diff)
downloadfreebsd-ports-gnome-a8f5d0ca662c7c924d920d8199575840ec8a3da4.tar.gz
freebsd-ports-gnome-a8f5d0ca662c7c924d920d8199575840ec8a3da4.tar.zst
freebsd-ports-gnome-a8f5d0ca662c7c924d920d8199575840ec8a3da4.zip
- Fix build on -CURRENT
- Use PORTDOCS facility
Diffstat (limited to 'net-mgmt/bpft/Makefile')
-rw-r--r--net-mgmt/bpft/Makefile8
1 files changed, 6 insertions, 2 deletions
diff --git a/net-mgmt/bpft/Makefile b/net-mgmt/bpft/Makefile
index 1a5e0a941877..80c47ed9f208 100644
--- a/net-mgmt/bpft/Makefile
+++ b/net-mgmt/bpft/Makefile
@@ -21,17 +21,21 @@ CONFLICTS= trafd-3.0.*
WRKSRC= ${WRKDIR}/bpft
MAN1= traflog.1 trafstat.1
MAN8= trafstatd.8 trafd.8
+PORTDOCS= README WhatsNew
MANCOMPRESSED= yes
post-patch:
@${REINPLACE_CMD} -e 's|/usr/local|${PREFIX}|g' ${WRKSRC}/include/pathnames.h
@${REINPLACE_CMD} -e 's|/usr/local/|${PREFIX}/|g' ${WRKSRC}/Makefile
+ @${REINPLACE_CMD} -e 's|<net/slip.h>|"../linux-include/net/slip.h"|' \
+ ${WRKSRC}/lib/interfaces.c
post-install:
.if !defined(NOPORTDOCS)
${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/WhatsNew ${DOCSDIR}
+. for file in ${PORTDOCS}
+ ${INSTALL_DATA} ${WRKSRC}/${file} ${DOCSDIR}
+. endfor
.endif
.include <bsd.port.mk>