aboutsummaryrefslogtreecommitdiffstats
path: root/net-mgmt/bsnmp-regex
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2010-06-06 03:43:07 +0800
committermiwi <miwi@FreeBSD.org>2010-06-06 03:43:07 +0800
commit98445dda6dc37da5108f16e2b222ed6213a07db7 (patch)
tree69be84d4bbe1e5a35bae0a2598a644c0f96fcb1b /net-mgmt/bsnmp-regex
parent88bb121fe16c90259b63bbd4f6089988f39da60a (diff)
downloadfreebsd-ports-gnome-98445dda6dc37da5108f16e2b222ed6213a07db7.tar.gz
freebsd-ports-gnome-98445dda6dc37da5108f16e2b222ed6213a07db7.tar.zst
freebsd-ports-gnome-98445dda6dc37da5108f16e2b222ed6213a07db7.zip
- Add option to use PCRE regex library
PR: 144832 Submitted by: Marko Njezic <mrmax063@maxempire.com> Approved by: maintainer timeout
Diffstat (limited to 'net-mgmt/bsnmp-regex')
-rw-r--r--net-mgmt/bsnmp-regex/Makefile11
1 files changed, 11 insertions, 0 deletions
diff --git a/net-mgmt/bsnmp-regex/Makefile b/net-mgmt/bsnmp-regex/Makefile
index 160865c57a4f..951fefbdb4d1 100644
--- a/net-mgmt/bsnmp-regex/Makefile
+++ b/net-mgmt/bsnmp-regex/Makefile
@@ -15,6 +15,17 @@ COMMENT= A bsnmpd module allowing creation of counters from log files
GNU_CONFIGURE= yes
+OPTIONS= PCRE "Use PCRE instead of the default regex library" Off
+
+.include <bsd.port.options.mk>
+
+.if defined(WITH_PCRE)
+LIB_DEPENDS+= pcre.0:${PORTSDIR}/devel/pcre
+CONFIGURE_ARGS+= --enable-pcre
+.else
+CONFIGURE_ARGS+= --disable-pcre
+.endif
+
MAN1= sockin.1
MAN5= bsnmp-regex.conf.5
MAN8= bsnmp-regex.8