aboutsummaryrefslogtreecommitdiffstats
path: root/net-mgmt/cacti
diff options
context:
space:
mode:
authorzi <zi@FreeBSD.org>2011-10-28 23:47:08 +0800
committerzi <zi@FreeBSD.org>2011-10-28 23:47:08 +0800
commit42e54ccae2bfd0007da07f46ff583f26b852dafe (patch)
treea6b56263ba9872e0fae2adee674a6f4a35b6aadc /net-mgmt/cacti
parent35806bf02c7567e3df8aa68635df55351fbff958 (diff)
downloadfreebsd-ports-gnome-42e54ccae2bfd0007da07f46ff583f26b852dafe.tar.gz
freebsd-ports-gnome-42e54ccae2bfd0007da07f46ff583f26b852dafe.tar.zst
freebsd-ports-gnome-42e54ccae2bfd0007da07f46ff583f26b852dafe.zip
- Update to 0.8.7h.
Software changes include: - Fix SQL injection issue with user login - Fix Cross-site scripting issues - Make one minute polling work properly PR: ports/162044 Submitted by: moggie <moggie@elasticmind.net> Approved by: sem Obtained from: zi
Diffstat (limited to 'net-mgmt/cacti')
-rw-r--r--net-mgmt/cacti/Makefile10
-rw-r--r--net-mgmt/cacti/distinfo4
-rw-r--r--net-mgmt/cacti/files/patch-scripts-ping.pl14
-rw-r--r--net-mgmt/cacti/pkg-plist3
4 files changed, 18 insertions, 13 deletions
diff --git a/net-mgmt/cacti/Makefile b/net-mgmt/cacti/Makefile
index 8367e701a14a..b19a4ffce845 100644
--- a/net-mgmt/cacti/Makefile
+++ b/net-mgmt/cacti/Makefile
@@ -6,21 +6,23 @@
#
PORTNAME= cacti
-PORTVERSION= 0.8.7g${PATCHLEVEL}
+PORTVERSION= 0.8.7h${PATCHLEVEL}
CATEGORIES= net-mgmt www
MASTER_SITES= http://www.cacti.net/downloads/
DISTFILES= ${PORTNAME}-${SITEDISTVERSION}${EXTRACT_SUFX}
# Vendor's patches
PATCH_SITES= http://www.cacti.net/downloads/patches/${SITEDISTVERSION}/
-PATCHFILES=
-PATCHLEVEL=
-
+#PATCHFILES=
PATCH_DIST_STRIP= -p1
+#PATCHLEVEL=
MAINTAINER= sem@FreeBSD.org
COMMENT= Web-driven graphing interface for RRDTool
+LICENSE= GPLv2
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
RUN_DEPENDS= rrdtool:${PORTSDIR}/databases/rrdtool
PATCH_STRIP= -p1
diff --git a/net-mgmt/cacti/distinfo b/net-mgmt/cacti/distinfo
index 07be5c796fe2..bce667ac2c3b 100644
--- a/net-mgmt/cacti/distinfo
+++ b/net-mgmt/cacti/distinfo
@@ -1,2 +1,2 @@
-SHA256 (cacti-0.8.7g.tar.gz) = d09b3bf54f51bd42b2db0a62521cf6e408716978f75d6509ec56027c49c44585
-SIZE (cacti-0.8.7g.tar.gz) = 2236916
+SHA256 (cacti-0.8.7h.tar.gz) = 2e3dc330b5b3ee374b2e553650d032441c25831b39ddcf123ef102492f20603c
+SIZE (cacti-0.8.7h.tar.gz) = 2249323
diff --git a/net-mgmt/cacti/files/patch-scripts-ping.pl b/net-mgmt/cacti/files/patch-scripts-ping.pl
index f1a257f64976..394c2526768a 100644
--- a/net-mgmt/cacti/files/patch-scripts-ping.pl
+++ b/net-mgmt/cacti/files/patch-scripts-ping.pl
@@ -1,11 +1,11 @@
---- cacti-0.8.7d/scripts/ping.pl.orig 2009-02-12 05:55:50.000000000 +0300
-+++ cacti-0.8.7d/scripts/ping.pl 2009-02-16 17:01:59.000000000 +0300
-@@ -4,7 +4,7 @@
- $host = $ARGV[0];
- $host =~ s/tcp:/$1/gis;
+--- ./scripts/ping.pl.orig 2011-10-26 09:31:56.000000000 -0400
++++ ./scripts/ping.pl 2011-10-26 09:32:02.000000000 -0400
+@@ -6,7 +6,7 @@
--open(PROCESS, "ping -c 1 $host | grep icmp_seq | grep time |");
-+open(PROCESS, "/sbin/ping -c 1 $host | grep icmp_seq | grep time |");
+ # old linux version use "icmp_seq"
+ # newer use "icmp_req" instead
+-open(PROCESS, "ping -c 1 $host | grep 'icmp_[s|r]eq' | grep time |");
++open(PROCESS, "/sbin/ping -c 1 $host | grep 'icmp_[s|r]eq' | grep time |");
$ping = <PROCESS>;
close(PROCESS);
$ping =~ m/(.*time=)(.*) (ms|usec)/;
diff --git a/net-mgmt/cacti/pkg-plist b/net-mgmt/cacti/pkg-plist
index 7f0883f90c7f..6922dce6c40c 100644
--- a/net-mgmt/cacti/pkg-plist
+++ b/net-mgmt/cacti/pkg-plist
@@ -12,8 +12,10 @@
%%CACTIDIR%%/cli/add_graphs.php
%%CACTIDIR%%/cli/add_perms.php
%%CACTIDIR%%/cli/add_tree.php
+%%CACTIDIR%%/cli/analyze_database.php
%%CACTIDIR%%/cli/convert_innodb.php
%%CACTIDIR%%/cli/copy_user.php
+%%CACTIDIR%%/cli/data_template_associate_rra.php
%%CACTIDIR%%/cli/host_update_template.php
%%CACTIDIR%%/cli/import_template.php
%%CACTIDIR%%/cli/poller_data_sources_reapply_names.php
@@ -302,6 +304,7 @@
%%CACTIDIR%%/install/0_8_7d_to_0_8_7e.php
%%CACTIDIR%%/install/0_8_7e_to_0_8_7f.php
%%CACTIDIR%%/install/0_8_7f_to_0_8_7g.php
+%%CACTIDIR%%/install/0_8_7g_to_0_8_7h.php
%%CACTIDIR%%/install/0_8_to_0_8_1.php
%%CACTIDIR%%/install/index.php
%%CACTIDIR%%/install/install_finish.gif