aboutsummaryrefslogtreecommitdiffstats
path: root/net-mgmt/cacti
diff options
context:
space:
mode:
authorsem <sem@FreeBSD.org>2006-04-16 02:41:33 +0800
committersem <sem@FreeBSD.org>2006-04-16 02:41:33 +0800
commita876c24d164bcce9991a3e9035c8489605a74d7c (patch)
treecc171a8d21ae590c42bbfa11103cd50685506365 /net-mgmt/cacti
parenta502f45f22ec1e42042424bff88f6ec2eec1d7b8 (diff)
downloadfreebsd-ports-gnome-a876c24d164bcce9991a3e9035c8489605a74d7c.tar.gz
freebsd-ports-gnome-a876c24d164bcce9991a3e9035c8489605a74d7c.tar.zst
freebsd-ports-gnome-a876c24d164bcce9991a3e9035c8489605a74d7c.zip
- Fix df(1) output in query_unix_partitions.pl
- Fix path for ping in ping.pl - Rename a patch to a common scheme - Bump PORTREVISION Submitted by: Giraudet Olivier <giraudeo@altern.org>
Diffstat (limited to 'net-mgmt/cacti')
-rw-r--r--net-mgmt/cacti/Makefile2
-rw-r--r--net-mgmt/cacti/files/patch-scripts-diskfree.pl (renamed from net-mgmt/cacti/files/patch-fix_df_output)0
-rw-r--r--net-mgmt/cacti/files/patch-scripts-ping.pl10
-rw-r--r--net-mgmt/cacti/files/patch-scripts-query_unix_partitions.pl11
4 files changed, 22 insertions, 1 deletions
diff --git a/net-mgmt/cacti/Makefile b/net-mgmt/cacti/Makefile
index 7ded291099d6..816c7ea314eb 100644
--- a/net-mgmt/cacti/Makefile
+++ b/net-mgmt/cacti/Makefile
@@ -7,7 +7,7 @@
PORTNAME= cacti
PORTVERSION= 0.8.6h
-PORTREVISION= 41
+PORTREVISION= 42
CATEGORIES= net www
MASTER_SITES= http://www.cacti.net/downloads/
diff --git a/net-mgmt/cacti/files/patch-fix_df_output b/net-mgmt/cacti/files/patch-scripts-diskfree.pl
index 8df567b2255f..8df567b2255f 100644
--- a/net-mgmt/cacti/files/patch-fix_df_output
+++ b/net-mgmt/cacti/files/patch-scripts-diskfree.pl
diff --git a/net-mgmt/cacti/files/patch-scripts-ping.pl b/net-mgmt/cacti/files/patch-scripts-ping.pl
new file mode 100644
index 000000000000..9b42be1fc4e5
--- /dev/null
+++ b/net-mgmt/cacti/files/patch-scripts-ping.pl
@@ -0,0 +1,10 @@
+--- scripts/ping.pl.orig Sat Apr 15 22:26:44 2006
++++ scripts/ping.pl Sat Apr 15 22:27:16 2006
+@@ -1,6 +1,6 @@
+ #!/usr/bin/perl
+
+-open(PROCESS, "ping -c 1 $ARGV[0] | grep icmp_seq |");
++open(PROCESS, "/sbin/ping -c 1 $ARGV[0] | grep icmp_seq |");
+ $ping = <PROCESS>;
+ close(PROCESS);
+ $ping =~ m/(.*time=)(.*) (ms|usec)/;
diff --git a/net-mgmt/cacti/files/patch-scripts-query_unix_partitions.pl b/net-mgmt/cacti/files/patch-scripts-query_unix_partitions.pl
new file mode 100644
index 000000000000..9af889b0dae4
--- /dev/null
+++ b/net-mgmt/cacti/files/patch-scripts-query_unix_partitions.pl
@@ -0,0 +1,11 @@
+--- scripts/query_unix_partitions.pl.orig Sat Apr 15 22:25:55 2006
++++ scripts/query_unix_partitions.pl Sat Apr 15 22:26:14 2006
+@@ -5,7 +5,7 @@
+ exit;
+ }
+
+-open(DF, "/bin/df -P|");
++open(DF, "/bin/df -k|");
+
+ while (<DF>) {
+ #/dev/hda2 20157744 18553884 579860 97% /var