aboutsummaryrefslogtreecommitdiffstats
path: root/net-mgmt/disco
diff options
context:
space:
mode:
authoradamw <adamw@FreeBSD.org>2014-08-09 11:58:37 +0800
committeradamw <adamw@FreeBSD.org>2014-08-09 11:58:37 +0800
commit32a968337633d834299d01f35de5c13f8a74b9d4 (patch)
treee604d8ed3ced7b1afc07ca9a2fa88f7317c3b295 /net-mgmt/disco
parent0fb7e44d44ef63dc8d6a61b026e01ba6e4655e4c (diff)
downloadfreebsd-ports-gnome-32a968337633d834299d01f35de5c13f8a74b9d4.tar.gz
freebsd-ports-gnome-32a968337633d834299d01f35de5c13f8a74b9d4.tar.zst
freebsd-ports-gnome-32a968337633d834299d01f35de5c13f8a74b9d4.zip
Fix build with clang.
While here, avoid unnecessary bsd.port.options.mk inclusion.
Diffstat (limited to 'net-mgmt/disco')
-rw-r--r--net-mgmt/disco/Makefile4
-rw-r--r--net-mgmt/disco/files/patch-disco.c11
2 files changed, 11 insertions, 4 deletions
diff --git a/net-mgmt/disco/Makefile b/net-mgmt/disco/Makefile
index 68f5804a98bb..0c0ab5a8bfc5 100644
--- a/net-mgmt/disco/Makefile
+++ b/net-mgmt/disco/Makefile
@@ -20,14 +20,10 @@ PLIST_FILES= bin/disco bin/disco.fp
OPTIONS_DEFINE= DOCS
-.include <bsd.port.options.mk>
-
post-install:
-.if ! ${PORT_OPTIONS:MDOCS}
${MKDIR} ${STAGEDIR}${DOCSDIR}
.for i in README
${INSTALL_DATA} ${WRKSRC}/${i} ${STAGEDIR}${DOCSDIR}
.endfor
-.endif
.include <bsd.port.mk>
diff --git a/net-mgmt/disco/files/patch-disco.c b/net-mgmt/disco/files/patch-disco.c
new file mode 100644
index 000000000000..e6d44f4ed1ac
--- /dev/null
+++ b/net-mgmt/disco/files/patch-disco.c
@@ -0,0 +1,11 @@
+--- disco.c.orig 2014-08-08 23:55:22.000000000 -0400
++++ disco.c 2014-08-08 23:56:40.000000000 -0400
+@@ -1031,7 +1031,7 @@
+ if (!fp_file)
+ {
+ fprintf(stderr, "No fingerprint file found\n");
+- return;
++ return -1;
+ }
+
+ while (fgets(infile, 1500, fp_file) != NULL && infile[0] != '\n')