aboutsummaryrefslogtreecommitdiffstats
path: root/net-mgmt/etherape
diff options
context:
space:
mode:
authormnag <mnag@FreeBSD.org>2006-04-30 01:24:34 +0800
committermnag <mnag@FreeBSD.org>2006-04-30 01:24:34 +0800
commitee7cf423e98405efeb1ce042e14c4aad5df9cb7c (patch)
treed1831de4fd1175e67888e9c23fd77ee151cba788 /net-mgmt/etherape
parentfb1bbd0c6c95f966808222dc2c1d1601a6e6856f (diff)
downloadfreebsd-ports-gnome-ee7cf423e98405efeb1ce042e14c4aad5df9cb7c.tar.gz
freebsd-ports-gnome-ee7cf423e98405efeb1ce042e14c4aad5df9cb7c.tar.zst
freebsd-ports-gnome-ee7cf423e98405efeb1ce042e14c4aad5df9cb7c.zip
- Add --zero-delay option
- Bump PORTREVISION PR: 94777 Submitted by: Ben Allen <benjamin___umn.edu> Approved by: maintainer timeout (39 days)
Diffstat (limited to 'net-mgmt/etherape')
-rw-r--r--net-mgmt/etherape/Makefile2
-rw-r--r--net-mgmt/etherape/files/patch-src__capture.c20
-rw-r--r--net-mgmt/etherape/files/patch-src__globals.h11
-rw-r--r--net-mgmt/etherape/files/patch-src__main.c12
-rw-r--r--net-mgmt/etherape/pkg-plist14
5 files changed, 51 insertions, 8 deletions
diff --git a/net-mgmt/etherape/Makefile b/net-mgmt/etherape/Makefile
index 9294ed9d0981..5df3fab2fa69 100644
--- a/net-mgmt/etherape/Makefile
+++ b/net-mgmt/etherape/Makefile
@@ -7,7 +7,7 @@
PORTNAME= etherape
PORTVERSION= 0.9.1
-PORTREVISION= 7
+PORTREVISION= 8
CATEGORIES= net-mgmt gnome
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
diff --git a/net-mgmt/etherape/files/patch-src__capture.c b/net-mgmt/etherape/files/patch-src__capture.c
new file mode 100644
index 000000000000..6fb7bcd6ac45
--- /dev/null
+++ b/net-mgmt/etherape/files/patch-src__capture.c
@@ -0,0 +1,20 @@
+--- ./src/capture.c.orig Sun Apr 6 10:45:41 2003
++++ ./src/capture.c Sat Apr 29 11:48:08 2006
+@@ -527,7 +527,16 @@
+ this_time.tv_usec = phdr.ts.tv_usec;
+
+ diff = substract_times (this_time, last_time);
+- ms_to_next = diff.tv_sec * 1000 + diff.tv_usec / 1000;
++
++ if (pref.zero_delay)
++ {
++ ms_to_next = 0;
++ }
++ else
++ {
++ ms_to_next = diff.tv_sec * 1000 + diff.tv_usec / 1000;
++ }
++
+
+ last_time = this_time;
+
diff --git a/net-mgmt/etherape/files/patch-src__globals.h b/net-mgmt/etherape/files/patch-src__globals.h
new file mode 100644
index 000000000000..0c67aebdcf13
--- /dev/null
+++ b/net-mgmt/etherape/files/patch-src__globals.h
@@ -0,0 +1,11 @@
+--- ./src/globals.h.orig Sun Apr 6 10:45:41 2003
++++ ./src/globals.h Sat Apr 29 11:48:08 2006
+@@ -342,6 +342,8 @@
+ gchar *interface; /* Network interface to listen to */
+ gchar *filter; /* Pcap filter to be used */
+
++ gboolean zero_delay; /* no delay processing tcpdump files */
++
+ }
+ pref;
+
diff --git a/net-mgmt/etherape/files/patch-src__main.c b/net-mgmt/etherape/files/patch-src__main.c
new file mode 100644
index 000000000000..06898039f77d
--- /dev/null
+++ b/net-mgmt/etherape/files/patch-src__main.c
@@ -0,0 +1,12 @@
+--- ./src/main.c.orig Sun Apr 6 10:45:42 2003
++++ ./src/main.c Sat Apr 29 11:48:08 2006
+@@ -60,6 +60,9 @@
+ N_("set the node color"), N_("color")},
+ {"text-color", 'T', POPT_ARG_STRING, &(pref.text_color), 0,
+ N_("set the text color"), N_("color")},
++ {"zero-delay", 'z', POPT_ARG_NONE, &(pref.zero_delay), 0,
++ N_("zero delay for reading capture files [cli only]"), NULL},
++
+
+ POPT_AUTOHELP {NULL, 0, 0, NULL, 0}
+ };
diff --git a/net-mgmt/etherape/pkg-plist b/net-mgmt/etherape/pkg-plist
index b9f6d97e02a8..abcac2c47158 100644
--- a/net-mgmt/etherape/pkg-plist
+++ b/net-mgmt/etherape/pkg-plist
@@ -1,10 +1,10 @@
bin/etherape
etc/etherape/services
-share/etherape/glade/etherape.glade2
-share/etherape/glade/etherape.png
-share/etherape/glade/pause.xpm
-share/etherape/glade/play.xpm
-share/etherape/glade/stop.xpm
+%%DATADIR%%/glade/etherape.glade2
+%%DATADIR%%/glade/etherape.png
+%%DATADIR%%/glade/pause.xpm
+%%DATADIR%%/glade/play.xpm
+%%DATADIR%%/glade/stop.xpm
share/gnome/apps/Applications/etherape.desktop
share/gnome/help/etherape/C/topic.dat
share/locale/es/LC_MESSAGES/etherape.mo
@@ -13,8 +13,8 @@ share/locale/nl/LC_MESSAGES/etherape.mo
share/locale/tr/LC_MESSAGES/etherape.mo
share/pixmaps/etherape.png
@dirrm etc/etherape
-@dirrm share/etherape/glade
-@dirrm share/etherape
+@dirrm %%DATADIR%%/glade
+@dirrm %%DATADIR%%
@dirrm share/gnome/help/etherape/C/stylesheet-images
@dirrm share/gnome/help/etherape/C
@dirrm share/gnome/help/etherape