aboutsummaryrefslogtreecommitdiffstats
path: root/net-mgmt/ettercap/Makefile
diff options
context:
space:
mode:
authornetchild <netchild@FreeBSD.org>2003-10-15 00:01:11 +0800
committernetchild <netchild@FreeBSD.org>2003-10-15 00:01:11 +0800
commitf8091dc3231843b8dbdb1d5b024bcab3687dc8f6 (patch)
treecf008ebd1d0e765be8a6505e13026cc7a33e8cf1 /net-mgmt/ettercap/Makefile
parent31e9ea96819f40595b47d34d631e16c070c55c24 (diff)
downloadfreebsd-ports-gnome-f8091dc3231843b8dbdb1d5b024bcab3687dc8f6.tar.gz
freebsd-ports-gnome-f8091dc3231843b8dbdb1d5b024bcab3687dc8f6.tar.zst
freebsd-ports-gnome-f8091dc3231843b8dbdb1d5b024bcab3687dc8f6.zip
Update to 0.6.b.
- gtk2 support - new sniffing method was added as a plugin - three new plugins - bumb PORTEPOCH, otherwise 0.6.b (they mean hex B) wouldn't be recognised as newer by pkg_version etc. - add 'security' as a second category (as nmap and friends are mainly there) - respect CFLAGS, PTHREAD_CFLAGS and PTHREAD_LIBS - make SSL-support optional - base compilation of gnome frontend on autodetection of installed gtk20, use gnome-PKGNAMESUFFIX - disable auto-download of new version via wget (saves dependency on wget, FreeBSD-users should update via the ports-collection anyway) - enable compilation and installation of the plug-ins - compile lc-converter (an application port IMO should not install sources) - don't install ettercap.fr.8.in Submitted by: Marius Strobl <marius@alchemy.franken.de> PR: 51898 Approved by: maintainer timeout (~5 months)
Diffstat (limited to 'net-mgmt/ettercap/Makefile')
-rw-r--r--net-mgmt/ettercap/Makefile49
1 files changed, 43 insertions, 6 deletions
diff --git a/net-mgmt/ettercap/Makefile b/net-mgmt/ettercap/Makefile
index 5e3bd97529be..23a4bd9a46df 100644
--- a/net-mgmt/ettercap/Makefile
+++ b/net-mgmt/ettercap/Makefile
@@ -6,8 +6,9 @@
#
PORTNAME= ettercap
-PORTVERSION= 0.6.7
-CATEGORIES= net
+PORTVERSION= 0.6.b
+PORTEPOCH= 1
+CATEGORIES= net security
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE} \
${MASTER_SITE_PACKETSTORM:S:%SUBDIR%:sniffers/ettercap:}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -15,14 +16,50 @@ MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= greid@FreeBSD.org
COMMENT= A network sniffer/interceptor/injector/logger for switched LANs
+USE_REINPLACE= yes
+.if !defined(WITHOUT_SSL)
+USE_OPENSSL= yes
+.endif
GNU_CONFIGURE= yes
+WANT_GNOME= yes
+
+MAN8= ettercap.8
+.include <bsd.port.pre.mk>
+
+CFLAGS+= ${PTHREAD_CFLAGS}
+
+CONFIGURE_TARGET= -build=${ARCH}-portbld-freebsd${OSREL}
+.if defined(WITHOUT_SSL)
+CONFIGURE_ARGS= --without-openssl
+PLIST_SUB+= SSL="@comment "
+.else
+CONFIGURE_ARGS= --with-openssl=${OPENSSLBASE}
+PLIST_SUB+= SSL=""
+.endif
+.if ${HAVE_GNOME:Mgtk20}!=""
+USE_GNOME+= gtk20
+PKGNAMESUFFIX= -gnome
+.else
+CONFIGURE_ARGS+= --disable-gtk
+.endif
+CONFIGURE_ENV= WGET_PATH=""
+
+ALL_TARGET= all plug-ins
+
+INSTALL_TARGET= install plug-ins_install
.if !defined(NOPORTDOCS)
-INSTALL_TARGET= install install-doc
+INSTALL_TARGET+= install-doc
.endif
-PLIST_SUB+= PORTVERSION=${PORTVERSION}
+post-patch:
+ @${REINPLACE_CMD} -e 's|-pthread|${PTHREAD_LIBS}|g' ${WRKSRC}/configure
+ @${MV} -f ${WRKSRC}/share/lc-converter.c ${WRKSRC}
-MAN8= ettercap.8
+post-build:
+ ${CC} ${CFLAGS} -o ${WRKSRC}/lc-converter ${WRKSRC}/lc-converter.c
+
+post-install::
+ ${INSTALL_PROGRAM} ${WRKSRC}/lc-converter ${PREFIX}/bin
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
* py-RO is a collection of utilities including general algorithms,wen2010-12-275-0/+583 * - Update to 0.034wen2010-12-232-4/+3 * - Update to 1.0.1wen2010-12-222-5/+3 * Update my daylight location.osa2010-12-211-1/+1 * Add back PORTEPOCH. (that for some reason I misread as PORTREVISIONnox2010-12-181-0/+1 * Update to 6.0.1.2032 (which is the current version again, looks like thenox2010-12-184-491/+105 * Update to 1.0.2makc2010-12-163-4/+5 * Provide an OPTION to install additional 1.19 gigs worth of star catalogs.danfe2010-12-163-0/+37 * - Update to version 0.10.6danfe2010-12-153-20/+50 * - Update to 3701amdmi32010-12-082-3/+3 * - Update to 0.38pav2010-12-083-29/+26 * - Update to 1.0.1sunpoet2010-12-062-3/+3 * - Update to 3695amdmi32010-12-062-6/+4 * Sync to new bsd.autotools.mkade2010-12-049-9/+9 * - Passed maintainership to submitterglarkin2010-12-044-8/+58 * - Updated to 0.13 (http://spiff.rit.edu/match/match-0.13/NEWS)glarkin2010-12-022-4/+5 * Update to 0.20.2makc2010-11-232-4/+3 * - Update to 1.0sunpoet2010-11-192-4/+3 * Fix mtree errorkevlo2010-11-122-4/+10 * - Update to 0.17sunpoet2010-11-032-4/+5 * - Update MASTER_SITES and WWW which have an IPv4 addresssunpoet2010-10-313-3/+2 * Deprecate md5 in favour of sha256 checksums. md5 checksums will no longererwin2010-10-291-1/+1 * - Update to 0.37amdmi32010-10-284-80/+132 * - Update to 3592amdmi32010-10-252-4/+4 * - Try to fix build on ia64 by explicitly including sys/types.h beforerene2010-10-234-2/+59 * Add my coordinates to freebsd.committers.markers.culot2010-10-181-0/+1 * Update to 0.16.3makc2010-10-162-6/+5 * Punt autoconf267->autoconf268ade2010-10-163-3/+3 * Fix typo in option comment.glebius2010-10-151-1/+1 * - Update to 0.050wen2010-10-152-4/+4 * - Update rc.d script: remove duplicated inclusion of gpxloggerd_flagssunpoet2010-10-152-3/+2 * - Add rc.d scriptsunpoet2010-10-132-0/+47 * Add myself.brucec2010-10-131-0/+1 * - Update to 0.9.96sunpoet2010-10-132-4/+4 * Fix build on 6.xmakc2010-10-102-3/+6 * - Add gpxloggerd 0.1sunpoet2010-10-094-0/+31 * Round one migration of ports from automake{19,110} to automake111ade2010-10-062-2/+2 * KDE FreeBSD team presents KDE SC 4.5.2.makc2010-10-063-62/+0 * - Use LOCAL/sunpoet as backup MASTER_SITESsunpoet2010-10-012-2/+2 * Add my coordinates to freebsd.committers.markers.romain2010-10-011-0/+1 * - Update my coordinates, moved now complete to Kuala Lumpur, Malaysiamiwi2010-09-301-1/+1 * Sadly jmz passed away in May, 2009.roberto2010-09-301-1/+0 * Update my location.roberto2010-09-301-1/+1 * Add myself to the list of committersbapt2010-09-291-0/+1 * Add myself to the committers' listmartymac2010-09-291-0/+1 * - Update to 0.049wen2010-09-292-5/+4 * Remove BROKEN, the Makefile revision which triggered the addition wasnetchild2010-09-271-4/+0 * Update to 0.033az2010-09-242-6/+5 * - only 13% of the p5- ports embed @comment $FreeBSD$:pgollucci2010-09-243-3/+0 * - %%SITE_PERL%%/auto and %%SITE_PERL%%/%%PERL_ARCH%%/autopgollucci2010-09-242-1/+1 * Purge 3 outdated, old-and-busted, versions of automake as part ofade2010-09-231-1/+1 * - Update MAINTAINER to my FreeBSD.org addresssunpoet2010-09-232-2/+2 * Add myself as a ports committersunpoet2010-09-231-1/+1 * Update to 0.34makc2010-09-214-11/+193 * Update to 0.19.2makc2010-09-212-4/+4 * Change dependency on old p5-Compress-Zlib, p5-IO-Compress-Base,mm2010-09-211-1/+2 * - Update to 0.048wen2010-09-213-6/+9 * Update libtcd to version 2.2.5makc2010-09-182-25/+23 * Mark as broken on sparc64: does not compile.linimon2010-09-171-0/+4 * - Update to 2.11decke2010-09-175-37/+21 * Autotools update. Read ports/UPDATING 20100915 for details.ade2010-09-163-5/+6 * - Fix build when alternate LOCALBASE used.tdb2010-09-151-1/+2 * Add @dirrmtry share/applicationskevlo2010-09-131-0/+1 * - Update to 0.73wen2010-09-122-5/+5 * - Update to 0.9.95pav2010-09-093-5/+16 * Populate some *FLAGS when compiling with devel/libusb. No revision bump.netchild2010-09-091-0/+3 * Update to 0.7.5.0kevlo2010-09-086-280/+301 * - Update to 3514amdmi32010-09-082-4/+4 * - MAKE_JOBS_UNSAFEpav2010-09-071-1/+1 * Add myself to freebsd.committers.markersswills2010-09-051-0/+1 * Fix the port on systems where libusb does not come with the basesystem.netchild2010-09-031-1/+7 * KDE FreeBSD team presents KDE SC 4.5.1.makc2010-09-033-31/+29 * - Fix install when astro/xearth is not there.avilla2010-09-021-0/+2 * Fine Offset Weather Station Readernetchild2010-09-015-0/+107 * Add my coordinates to freebsd.committers.markers.dim2010-08-311-0/+1 * - Extend USE_PYTHON range (connect Python 2.7)lwhsu2010-08-251-1/+1 * - Extend USE_PYTHON range (connect Python 2.7)lwhsu2010-08-252-5/+4 * I moved. Huzzah.ade2010-08-251-1/+1 * I moved a few years ago, fix (hopefully) my coordinates.joel2010-08-241-1/+1 * - Move back to Taipei, there's no place like home. :)lwhsu2010-08-241-2/+2 * Re-add myself, this time in scenic Kingston, Ontario.adamw2010-08-241-0/+1 * Chase exiv2 shlib bump.kwm2010-08-202-1/+2 * - Update to 0.16.1amdmi32010-08-194-12/+17 * - Add PORTSCOUT to ignore 1.31 (should have been 1.3.1)decke2010-08-191-0/+2 * Go back to 5.1.3535.3218 for the time being, the new version, 5.2.1.1547,nox2010-08-173-53/+137 * - Update to 11amdmi32010-08-112-4/+4 * - Update to 0.18.5lwhsu2010-08-042-4/+4 * Fix and sort plistmakc2010-07-303-33/+27 * Fix last commit.glebius2010-07-291-1/+1 * Assign maintainer to glebius:tobez2010-07-281-1/+1 * Update to 2.95.tobez2010-07-283-32/+4 * - Update to 3376amdmi32010-07-242-4/+4 * Nervously welcoming myself to the family.jsa2010-07-161-0/+1 * - Update to 0.34.1tabthorpe2010-07-154-31/+38 * Update to 0.7.0.1kevlo2010-07-145-17/+22 * - Update to 0.032wen2010-07-052-4/+4 * - Update to 10amdmi32010-07-032-5/+13 * - Update to 0.11wen2010-06-302-6/+9 * Mark MAKE_JOBS_UNSAFEmakc2010-06-241-1/+1 * - Update to version 0.10.5danfe2010-06-223-208/+193 * Fix "pkg_delete" problem after LICENSE knob issue found.osa2010-06-202-1/+3 * Chase updated distfile, at 5.2.1.1329 now.nox2010-06-203-135/+52 * Reset david@trucs.org, who currently does not have time to work onlinimon2010-06-181-1/+1 * Correct my locationbrian2010-06-181-1/+1 * - Update to 3329amdmi32010-06-162-4/+4 * These ports are GPLv2-licensedrene2010-06-141-0/+3 * Update my locationxride2010-06-141-1/+1 * Update my location.trasz2010-06-121-1/+1 * Add my coordinates to the astro/xearth port.ashish2010-06-111-0/+1 * - Fix installation of gpsfake, gpscat, gpsprof and their manual pages. [1]wen2010-06-103-12/+58 * Bump PORTREVISION for ports that depend on libogg, directly or indirectlynaddy2010-06-071-1/+1 * Update to 0.9.93makc2010-06-052-5/+4 * LICENSE GPLv2dinoex2010-06-041-0/+2 * GPS::OID maps GPS PRN number to Satellite OID and vice versa.wen2010-06-035-0/+33 * This command-line utility is intended to provide quick access to currentwen2010-06-025-0/+55 * Present KDE SC 4.4.4 for FreeBSD.makc2010-06-028-0/+916 * Bounce PORTREVISION for gettext-related ports. Have fun, ya'll.ade2010-05-31