aboutsummaryrefslogtreecommitdiffstats
path: root/net-mgmt/gps
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2007-01-31 22:09:55 +0800
committerpav <pav@FreeBSD.org>2007-01-31 22:09:55 +0800
commitccd12ccd577604add511aad4ea4e71c32b3e2f06 (patch)
tree25b833c135dd7f2323045f819dc7121e621103fc /net-mgmt/gps
parente2f15954f8960a944e8d5b2c28982257d8c6e91f (diff)
downloadfreebsd-ports-gnome-ccd12ccd577604add511aad4ea4e71c32b3e2f06.tar.gz
freebsd-ports-gnome-ccd12ccd577604add511aad4ea4e71c32b3e2f06.tar.zst
freebsd-ports-gnome-ccd12ccd577604add511aad4ea4e71c32b3e2f06.zip
- Patch net/libnet* to versioned libraries and header files, so they can
coexist PR: ports/103861 Submitted by: alepulver Tested by: pointyhat With hat: portmgr
Diffstat (limited to 'net-mgmt/gps')
-rw-r--r--net-mgmt/gps/Makefile20
1 files changed, 15 insertions, 5 deletions
diff --git a/net-mgmt/gps/Makefile b/net-mgmt/gps/Makefile
index 20b231758f0d..3f268c97d6db 100644
--- a/net-mgmt/gps/Makefile
+++ b/net-mgmt/gps/Makefile
@@ -8,7 +8,7 @@
PORTNAME= gps
PORTVERSION= 0.9.3
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= net-mgmt
MASTER_SITES= http://www.bsd-geek.de/FreeBSD/distfiles/
DISTNAME= ${PORTNAME}-${PORTVERSION}-FRC
@@ -16,14 +16,24 @@ DISTNAME= ${PORTNAME}-${PORTVERSION}-FRC
MAINTAINER= lars.engels@0x20.net
COMMENT= Ghost Port Scan
-BUILD_DEPENDS= libnet*<=1.1.0,1:${PORTSDIR}/net/libnet10
+BUILD_DEPENDS= ${LIBNET_CONFIG}:${PORTSDIR}/net/libnet10
GNU_CONFIGURE= yes
-CONFIGURE_ENV= LIBS="-L${LOCALBASE}/lib"
USE_GMAKE= yes
+LIBNET_CONFIG?= ${LOCALBASE}/bin/libnet10-config
+
+.include <bsd.port.pre.mk>
+
post-patch:
- @${REINPLACE_CMD} -e "s,-Wall -O3,${CFLAGS},g" ${WRKSRC}/configure
+ @${REINPLACE_CMD} -e \
+ 's|-Wall -O3|${CFLAGS}|; \
+ s|-lnet|`${LIBNET_CONFIG} --libs`|' \
+ ${CONFIGURE_WRKSRC}/${CONFIGURE_SCRIPT}
+ @${REINPLACE_CMD} -e \
+ 's|libnet-config|${LIBNET_CONFIG}|; \
+ s|--defines|& --cflags|' \
+ ${WRKSRC}/Makefile.in
.if !defined(NOPORTDOCS)
post-install:
@@ -31,4 +41,4 @@ post-install:
${CP} ${WRKSRC}/docs/* ${DOCSDIR}
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>