aboutsummaryrefslogtreecommitdiffstats
path: root/net-mgmt/grepcidr/Makefile
diff options
context:
space:
mode:
authoredwin <edwin@FreeBSD.org>2005-04-25 13:03:43 +0800
committeredwin <edwin@FreeBSD.org>2005-04-25 13:03:43 +0800
commit20335314cd9425929d3d4fbcf52aee832ee58e6c (patch)
tree803aa3fb637f0e4ba57e21e20dc930f93229b421 /net-mgmt/grepcidr/Makefile
parente2a8395580c60f8d9766946cca7fb8c687c2ed19 (diff)
downloadfreebsd-ports-gnome-20335314cd9425929d3d4fbcf52aee832ee58e6c.tar.gz
freebsd-ports-gnome-20335314cd9425929d3d4fbcf52aee832ee58e6c.tar.zst
freebsd-ports-gnome-20335314cd9425929d3d4fbcf52aee832ee58e6c.zip
net-mgmt/grepcidr: Filter IP addresses matching IPv4 CIDR/network specification
grepcidr can be used to filter a list of IP addresses against one or more Classless Inter-Domain Routing (CIDR) specifications, or arbitrary networks specified by an address range. As with grep, there are options to invert matching and load patterns from a file. grepcidr is capable of comparing thousands or even millions of IPs to networks with little memory usage and in reasonable computation time. grepcidr has endless uses in network software, including: mail filtering and processing, network security, log analysis, and many custom applications. PR: ports/80315 Submitted by: Douglas Fraser <doug+ports@idmf.net>
Diffstat (limited to 'net-mgmt/grepcidr/Makefile')
-rw-r--r--net-mgmt/grepcidr/Makefile27
1 files changed, 27 insertions, 0 deletions
diff --git a/net-mgmt/grepcidr/Makefile b/net-mgmt/grepcidr/Makefile
new file mode 100644
index 000000000000..7a786f837266
--- /dev/null
+++ b/net-mgmt/grepcidr/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: grepcidr
+# Date created: 2005-04-24
+# Whom: Douglas Fraser <doug@idmf.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= grepcidr
+PORTVERSION= 1.3
+CATEGORIES= net-mgmt textproc
+MASTER_SITES= http://www.pc-tools.net/files/unix/
+
+MAINTAINER= doug+ports@idmf.net
+COMMENT= Filter IP addresses matching IPv4 CIDR/network specification
+
+PLIST_FILES= bin/grepcidr
+
+USE_REINPLACE= yes
+
+do-configure:
+ @${REINPLACE_CMD} \
+ -e 's|/usr/local/bin|${PREFIX}/bin|' \
+ -e 's|-s -O3 -Wall -pedantic|${CFLAGS}|' \
+ -e 's|gcc|${CC}|' \
+ ${WRKSRC}/Makefile
+
+.include <bsd.port.mk>