aboutsummaryrefslogtreecommitdiffstats
path: root/net-mgmt/icinga2
diff options
context:
space:
mode:
authorlme <lme@FreeBSD.org>2015-07-15 02:42:54 +0800
committerlme <lme@FreeBSD.org>2015-07-15 02:42:54 +0800
commitb94b744243b447af76852a7ba544b468a6853f34 (patch)
treeb34cd0bb3066c5e7ce17337e061fd1815cefd7e6 /net-mgmt/icinga2
parentb9ce43d4580bdffe928b66e9c2daf83ea06c5f7e (diff)
downloadfreebsd-ports-gnome-b94b744243b447af76852a7ba544b468a6853f34.tar.gz
freebsd-ports-gnome-b94b744243b447af76852a7ba544b468a6853f34.tar.zst
freebsd-ports-gnome-b94b744243b447af76852a7ba544b468a6853f34.zip
- Update to 2.3.6
- Install more config files as sample config - Fix directory permissions under /var - Change database backend options to GROUP, so one can de-select both [1] PR: 201114 [1] Submitted by: Niels Kristensen MFH: 2015Q3
Diffstat (limited to 'net-mgmt/icinga2')
-rw-r--r--net-mgmt/icinga2/Makefile12
-rw-r--r--net-mgmt/icinga2/distinfo4
-rw-r--r--net-mgmt/icinga2/files/icinga2.in28
-rw-r--r--net-mgmt/icinga2/files/patch-etc_CMakeLists.txt33
-rw-r--r--net-mgmt/icinga2/files/patch-itl_CMakeLists.txt10
-rw-r--r--net-mgmt/icinga2/files/patch-itl_plugins-contrib.d_CMakeLists.txt10
-rw-r--r--net-mgmt/icinga2/pkg-plist68
7 files changed, 100 insertions, 65 deletions
diff --git a/net-mgmt/icinga2/Makefile b/net-mgmt/icinga2/Makefile
index 36829be3b2b1..eb47496c5fd7 100644
--- a/net-mgmt/icinga2/Makefile
+++ b/net-mgmt/icinga2/Makefile
@@ -2,7 +2,7 @@
PORTNAME= icinga2
DISTVERSIONPREFIX= v
-DISTVERSION= 2.3.4
+DISTVERSION= 2.3.6
CATEGORIES= net-mgmt
MAINTAINER= lme@FreeBSD.org
@@ -24,8 +24,8 @@ USE_LDCONFIG= yes
USE_RC_SUBR= ${PORTNAME}
OPTIONS_DEFINE= DOCS
-OPTIONS_MULTI= BACKEND
-OPTIONS_MULTI_BACKEND= MYSQL PGSQL
+OPTIONS_GROUP= BACKEND
+OPTIONS_GROUP_BACKEND= MYSQL PGSQL
OPTIONS_RADIO= PLUGINS
OPTIONS_RADIO_PLUGINS= MONPLUGINS NAGPLUGINS
@@ -50,6 +50,7 @@ CMAKE_ARGS+= -DICINGA2_USER=${ICINGA2USER} \
-DICINGA2_COMMAND_USER=${ICINGA2USER} \
-DICINGA2_COMMAND_GROUP=${ICINGA2USER} \
-DICINGA2_PLUGINDIR=${LOCALBASE}/libexec/nagios \
+ -DICINGA2_RUNDIR=/var/run \
-DCMAKE_INSTALL_SYSCONFDIR=${PREFIX}/etc \
-DCMAKE_INSTALL_LOCALSTATEDIR=${LOCALSTATEDIR} \
-DCMAKE_INSTALL_MANDIR=${MANPREFIX}/man \
@@ -59,6 +60,10 @@ SUB_LIST= ICINGA2LOGDIR=${ICINGA2LOGDIR} \
ICINGA2GROUP=${ICINGA2GROUP} \
WWWGRP=${WWWGRP}
+PLIST_SUB= ICINGA2USER=${ICINGA2USER} \
+ ICINGA2GROUP=${ICINGA2GROUP} \
+ WWWGRP=${WWWGRP}
+
# Config files with references to "Linux"
LINUX_CONFIG= groups.conf services.conf hosts.conf
@@ -81,6 +86,7 @@ post-patch:
pre-install:
${FIND} ${WRKSRC}/etc -type f -name "*.conf" -exec ${MV} {} {}.sample \;
+ ${FIND} ${WRKSRC}/itl -type f -name "*.conf" -exec ${MV} {} {}.sample \;
${FIND} ${WRKSRC}/etc/icinga2/scripts -type f -name "*.sh" \
-exec ${MV} {} {}.sample \;
diff --git a/net-mgmt/icinga2/distinfo b/net-mgmt/icinga2/distinfo
index 501c2b941b4c..7faa53c1fbec 100644
--- a/net-mgmt/icinga2/distinfo
+++ b/net-mgmt/icinga2/distinfo
@@ -1,2 +1,2 @@
-SHA256 (icinga-icinga2-v2.3.4_GH0.tar.gz) = 3a6d23214c90c1e308df784254659c51962f4c49b13093aff2095e1dfa06cdaa
-SIZE (icinga-icinga2-v2.3.4_GH0.tar.gz) = 782506
+SHA256 (icinga-icinga2-v2.3.6_GH0.tar.gz) = 96453fbfa418329b74d45bd2a202302add03d907fac28644e1228d869c478093
+SIZE (icinga-icinga2-v2.3.6_GH0.tar.gz) = 816718
diff --git a/net-mgmt/icinga2/files/icinga2.in b/net-mgmt/icinga2/files/icinga2.in
index 6aad8c28e7bd..b2f74fe607f3 100644
--- a/net-mgmt/icinga2/files/icinga2.in
+++ b/net-mgmt/icinga2/files/icinga2.in
@@ -78,18 +78,22 @@ reload_precmd() {
}
start_precmd() {
- # Create necessary directories / change ownership
- for d in "${icinga2_logdir}" "${icinga2_logdir}/compat" \
- "${icinga2_logdir}/compat/archives" "${icinga2_libdir}" \
- "${icinga2_spooldir}" "${icinga2_spooldir}/tmp" \
- "${icinga2_rundir}" "${icinga2_cachedir}"; do
- install -d -o ${icinga2_user} -g ${icinga2_group} "${d}"
- done
-
- install -d -o ${icinga2_user} -g %%WWWGRP%% "${icinga2_rundir}/cmd"
-
- chown -R ${icinga2_user}:${icinga2_user} "${icinga2_libdir}"
- chown -R ${icinga2_user}:${icinga2_user} "${icinga2_spooldir}"
+# # Create necessary directories / change ownership
+# for d in "${icinga2_logdir}" "${icinga2_logdir}/compat" \
+# "${icinga2_logdir}/compat/archives" "${icinga2_libdir}" \
+# "${icinga2_spooldir}" "${icinga2_spooldir}/tmp" \
+# "${icinga2_rundir}" "${icinga2_cachedir}"; do
+# if [ ! -d "${d}" ]; then
+# install -d -o ${icinga2_user} -g ${icinga2_group} "${d}"
+# else
+# chown ${icinga2_user}:${icinga2_group} "${d}"
+# fi
+# done
+#
+# install -d -o ${icinga2_user} -g %%WWWGRP%% "${icinga2_rundir}/cmd"
+#
+# chown -R ${icinga2_user}:${icinga2_user} "${icinga2_libdir}"
+# chown -R ${icinga2_user}:${icinga2_user} "${icinga2_spooldir}"
if ! icinga2_checkconfig; then
return 1
diff --git a/net-mgmt/icinga2/files/patch-etc_CMakeLists.txt b/net-mgmt/icinga2/files/patch-etc_CMakeLists.txt
index ecf63c53a5fd..942fcede3cd9 100644
--- a/net-mgmt/icinga2/files/patch-etc_CMakeLists.txt
+++ b/net-mgmt/icinga2/files/patch-etc_CMakeLists.txt
@@ -1,20 +1,20 @@
---- etc/CMakeLists.txt.orig 2015-03-26 09:50:40.000000000 +0100
-+++ etc/CMakeLists.txt 2015-03-26 20:46:49.751242000 +0100
-@@ -26,39 +26,39 @@ if(${CMAKE_SYSTEM_NAME} STREQUAL "Linux"
+--- etc/CMakeLists.txt.orig 2015-07-08 10:17:44.000000000 +0200
++++ etc/CMakeLists.txt 2015-07-13 22:06:31.230363000 +0200
+@@ -26,43 +26,43 @@ if(${CMAKE_SYSTEM_NAME} STREQUAL "Linux"
configure_file(logrotate.d/icinga2.cmake ${CMAKE_CURRENT_BINARY_DIR}/logrotate.d/icinga2 @ONLY)
endif()
-install_if_not_exists(${CMAKE_CURRENT_BINARY_DIR}/icinga2/init.conf ${CMAKE_INSTALL_SYSCONFDIR}/icinga2)
--install_if_not_exists(icinga2/icinga2.conf ${CMAKE_INSTALL_SYSCONFDIR}/icinga2)
+install_if_not_exists(${CMAKE_CURRENT_BINARY_DIR}/icinga2/init.conf.sample ${CMAKE_INSTALL_SYSCONFDIR}/icinga2)
-+install_if_not_exists(icinga2/icinga2.conf.sample ${CMAKE_INSTALL_SYSCONFDIR}/icinga2)
if(NOT WIN32)
- install_if_not_exists(${CMAKE_CURRENT_BINARY_DIR}/icinga2/constants.conf ${CMAKE_INSTALL_SYSCONFDIR}/icinga2)
+- install_if_not_exists(icinga2/icinga2.conf ${CMAKE_INSTALL_SYSCONFDIR}/icinga2)
+ install_if_not_exists(${CMAKE_CURRENT_BINARY_DIR}/icinga2/constants.conf.sample ${CMAKE_INSTALL_SYSCONFDIR}/icinga2)
++ install_if_not_exists(icinga2/icinga2.conf.sample ${CMAKE_INSTALL_SYSCONFDIR}/icinga2)
else()
-- install_if_not_exists(${CMAKE_CURRENT_SOURCE_DIR}/icinga2/win32/constants.conf ${CMAKE_INSTALL_SYSCONFDIR}/icinga2)
-+ install_if_not_exists(${CMAKE_CURRENT_SOURCE_DIR}/icinga2/win32/constants.conf.sample ${CMAKE_INSTALL_SYSCONFDIR}/icinga2)
+ install_if_not_exists(${CMAKE_CURRENT_SOURCE_DIR}/icinga2/win32/constants.conf ${CMAKE_INSTALL_SYSCONFDIR}/icinga2)
+ install_if_not_exists(icinga2/win32/icinga2.conf ${CMAKE_INSTALL_SYSCONFDIR}/icinga2)
endif()
-install_if_not_exists(icinga2/zones.conf ${CMAKE_INSTALL_SYSCONFDIR}/icinga2)
@@ -28,14 +28,16 @@
if(NOT WIN32)
- install_if_not_exists(icinga2/conf.d/hosts.conf ${CMAKE_INSTALL_SYSCONFDIR}/icinga2/conf.d)
+- install_if_not_exists(icinga2/conf.d/services.conf ${CMAKE_INSTALL_SYSCONFDIR}/icinga2/conf.d)
+ install_if_not_exists(icinga2/conf.d/hosts.conf.sample ${CMAKE_INSTALL_SYSCONFDIR}/icinga2/conf.d)
++ install_if_not_exists(icinga2/conf.d/services.conf.sample ${CMAKE_INSTALL_SYSCONFDIR}/icinga2/conf.d)
else()
install_if_not_exists(icinga2/conf.d/win32/hosts.conf ${CMAKE_INSTALL_SYSCONFDIR}/icinga2/conf.d)
+ install_if_not_exists(icinga2/conf.d/win32/services.conf ${CMAKE_INSTALL_SYSCONFDIR}/icinga2/conf.d)
endif()
-install_if_not_exists(icinga2/conf.d/notifications.conf ${CMAKE_INSTALL_SYSCONFDIR}/icinga2/conf.d)
-install_if_not_exists(icinga2/conf.d/satellite.conf ${CMAKE_INSTALL_SYSCONFDIR}/icinga2/conf.d)
--install_if_not_exists(icinga2/conf.d/services.conf ${CMAKE_INSTALL_SYSCONFDIR}/icinga2/conf.d)
-install_if_not_exists(icinga2/conf.d/templates.conf ${CMAKE_INSTALL_SYSCONFDIR}/icinga2/conf.d)
-install_if_not_exists(icinga2/conf.d/timeperiods.conf ${CMAKE_INSTALL_SYSCONFDIR}/icinga2/conf.d)
-install_if_not_exists(icinga2/conf.d/users.conf ${CMAKE_INSTALL_SYSCONFDIR}/icinga2/conf.d)
@@ -43,12 +45,8 @@
-install_if_not_exists(icinga2/features-available/debuglog.conf ${CMAKE_INSTALL_SYSCONFDIR}/icinga2/features-available)
-install_if_not_exists(icinga2/features-available/icingastatus.conf ${CMAKE_INSTALL_SYSCONFDIR}/icinga2/features-available)
-install_if_not_exists(icinga2/features-available/mainlog.conf ${CMAKE_INSTALL_SYSCONFDIR}/icinga2/features-available)
--install_if_not_exists(icinga2/features-available/syslog.conf ${CMAKE_INSTALL_SYSCONFDIR}/icinga2/features-available)
--install_if_not_exists(icinga2/scripts/mail-host-notification.sh ${CMAKE_INSTALL_SYSCONFDIR}/icinga2/scripts)
--install_if_not_exists(icinga2/scripts/mail-service-notification.sh ${CMAKE_INSTALL_SYSCONFDIR}/icinga2/scripts)
+install_if_not_exists(icinga2/conf.d/notifications.conf.sample ${CMAKE_INSTALL_SYSCONFDIR}/icinga2/conf.d)
+install_if_not_exists(icinga2/conf.d/satellite.conf.sample ${CMAKE_INSTALL_SYSCONFDIR}/icinga2/conf.d)
-+install_if_not_exists(icinga2/conf.d/services.conf.sample ${CMAKE_INSTALL_SYSCONFDIR}/icinga2/conf.d)
+install_if_not_exists(icinga2/conf.d/templates.conf.sample ${CMAKE_INSTALL_SYSCONFDIR}/icinga2/conf.d)
+install_if_not_exists(icinga2/conf.d/timeperiods.conf.sample ${CMAKE_INSTALL_SYSCONFDIR}/icinga2/conf.d)
+install_if_not_exists(icinga2/conf.d/users.conf.sample ${CMAKE_INSTALL_SYSCONFDIR}/icinga2/conf.d)
@@ -56,9 +54,14 @@
+install_if_not_exists(icinga2/features-available/debuglog.conf.sample ${CMAKE_INSTALL_SYSCONFDIR}/icinga2/features-available)
+install_if_not_exists(icinga2/features-available/icingastatus.conf.sample ${CMAKE_INSTALL_SYSCONFDIR}/icinga2/features-available)
+install_if_not_exists(icinga2/features-available/mainlog.conf.sample ${CMAKE_INSTALL_SYSCONFDIR}/icinga2/features-available)
-+install_if_not_exists(icinga2/features-available/syslog.conf.sample ${CMAKE_INSTALL_SYSCONFDIR}/icinga2/features-available)
-+install_if_not_exists(icinga2/scripts/mail-host-notification.sh.sample ${CMAKE_INSTALL_SYSCONFDIR}/icinga2/scripts)
-+install_if_not_exists(icinga2/scripts/mail-service-notification.sh.sample ${CMAKE_INSTALL_SYSCONFDIR}/icinga2/scripts)
+ if(NOT WIN32)
+- install_if_not_exists(icinga2/features-available/syslog.conf ${CMAKE_INSTALL_SYSCONFDIR}/icinga2/features-available)
++ install_if_not_exists(icinga2/features-available/syslog.conf.sample ${CMAKE_INSTALL_SYSCONFDIR}/icinga2/features-available)
+ endif()
+-install_if_not_exists(icinga2/scripts/mail-host-notification.sh ${CMAKE_INSTALL_SYSCONFDIR}/icinga2/scripts)
+-install_if_not_exists(icinga2/scripts/mail-service-notification.sh ${CMAKE_INSTALL_SYSCONFDIR}/icinga2/scripts)
++ install_if_not_exists(icinga2/scripts/mail-host-notification.sh.sample ${CMAKE_INSTALL_SYSCONFDIR}/icinga2/scripts)
++ install_if_not_exists(icinga2/scripts/mail-service-notification.sh.sample ${CMAKE_INSTALL_SYSCONFDIR}/icinga2/scripts)
install_if_not_exists(icinga2/zones.d/README ${CMAKE_INSTALL_SYSCONFDIR}/icinga2/zones.d)
install_if_not_exists(icinga2/repository.d/README ${CMAKE_INSTALL_SYSCONFDIR}/icinga2/repository.d)
diff --git a/net-mgmt/icinga2/files/patch-itl_CMakeLists.txt b/net-mgmt/icinga2/files/patch-itl_CMakeLists.txt
new file mode 100644
index 000000000000..6d5b29b362ba
--- /dev/null
+++ b/net-mgmt/icinga2/files/patch-itl_CMakeLists.txt
@@ -0,0 +1,10 @@
+--- itl/CMakeLists.txt.orig 2015-07-13 22:14:51.872881000 +0200
++++ itl/CMakeLists.txt 2015-07-13 22:15:19.702183000 +0200
+@@ -18,6 +18,6 @@
+ add_subdirectory(plugins-contrib.d)
+
+ install(
+- FILES itl command.conf command-icinga.conf hangman timeperiod.conf plugins command-plugins.conf manubulon command-plugins-manubulon.conf windows-plugins command-plugins-windows.conf nscp command-nscp-local.conf plugins-contrib
++ FILES itl command.conf.sample command-icinga.conf.sample hangman timeperiod.conf.sample plugins command-plugins.conf.sample manubulon command-plugins-manubulon.conf.sample windows-plugins command-plugins-windows.conf.sample nscp command-nscp-local.conf.sample plugins-contrib
+ DESTINATION ${CMAKE_INSTALL_DATADIR}/icinga2/include
+ )
diff --git a/net-mgmt/icinga2/files/patch-itl_plugins-contrib.d_CMakeLists.txt b/net-mgmt/icinga2/files/patch-itl_plugins-contrib.d_CMakeLists.txt
new file mode 100644
index 000000000000..451d61b87581
--- /dev/null
+++ b/net-mgmt/icinga2/files/patch-itl_plugins-contrib.d_CMakeLists.txt
@@ -0,0 +1,10 @@
+--- itl/plugins-contrib.d/CMakeLists.txt.orig 2015-07-13 22:15:59.084514000 +0200
++++ itl/plugins-contrib.d/CMakeLists.txt 2015-07-13 22:16:44.501021000 +0200
+@@ -16,6 +16,6 @@
+ # Inc., 51 Franklin St, Fifth Floor, Boston, MA 02110-1301, USA.
+
+ install(
+- FILES databases.conf ipmi.conf network-components.conf operating-system.conf virtualization.conf vmware.conf web.conf
++ FILES databases.conf.sample ipmi.conf.sample network-components.conf.sample operating-system.conf.sample virtualization.conf.sample vmware.conf.sample web.conf.sample
+ DESTINATION ${CMAKE_INSTALL_DATADIR}/icinga2/include/plugins-contrib.d
+ )
diff --git a/net-mgmt/icinga2/pkg-plist b/net-mgmt/icinga2/pkg-plist
index 4d5800f530e1..05214ed2767a 100644
--- a/net-mgmt/icinga2/pkg-plist
+++ b/net-mgmt/icinga2/pkg-plist
@@ -18,8 +18,8 @@ etc/bash_completion.d/icinga2
@sample %%ETCDIR%%/features-available/gelf.conf.sample
@sample %%ETCDIR%%/features-available/graphite.conf.sample
@sample %%ETCDIR%%/features-available/icingastatus.conf.sample
-%%MYSQL%%@sample(icinga,icinga,0640) %%ETCDIR%%/features-available/ido-mysql.conf.sample
-%%PGSQL%%@sample(icinga,icinga,0640) %%ETCDIR%%/features-available/ido-pgsql.conf.sample
+%%MYSQL%%@sample(%%ICINGA2USER%%,%%ICINGA2GROUP%%,0640) %%ETCDIR%%/features-available/ido-mysql.conf.sample
+%%PGSQL%%@sample(%%ICINGA2USER%%,%%ICINGA2GROUP%%,0640) %%ETCDIR%%/features-available/ido-pgsql.conf.sample
@sample %%ETCDIR%%/features-available/livestatus.conf.sample
@sample %%ETCDIR%%/features-available/mainlog.conf.sample
@sample %%ETCDIR%%/features-available/notification.conf.sample
@@ -42,7 +42,7 @@ lib/icinga2/libchecker.so
lib/icinga2/libcli.so
lib/icinga2/libcompat.so
lib/icinga2/libconfig.so
-lib/icinga2/libdb_ido.so
+%%MYSQL%%%%PGSQL%%llib/icinga2/libdb_ido.so
%%MYSQL%%lib/icinga2/libdb_ido_mysql.so
%%PGSQL%%lib/icinga2/libdb_ido_pgsql.so
lib/icinga2/libexecvpe.so
@@ -78,8 +78,8 @@ sbin/icinga2
%%PORTDOCS%%%%DOCSDIR%%/markdown/21-debug.md
%%PORTDOCS%%%%DOCSDIR%%/markdown/22-appendix.md
%%PORTDOCS%%%%DOCSDIR%%/markdown/3-monitoring-basics.md
-%%PORTDOCS%%%%DOCSDIR%%/markdown/4-advanced-topics.md
-%%PORTDOCS%%%%DOCSDIR%%/markdown/5-configuring-icinga-2.md
+%%PORTDOCS%%%%DOCSDIR%%/markdown/4-configuring-icinga-2.md
+%%PORTDOCS%%%%DOCSDIR%%/markdown/5-advanced-topics.md
%%PORTDOCS%%%%DOCSDIR%%/markdown/6-object-types.md
%%PORTDOCS%%%%DOCSDIR%%/markdown/7-icinga-template-library.md
%%PORTDOCS%%%%DOCSDIR%%/markdown/8-cli-commands.md
@@ -94,39 +94,41 @@ sbin/icinga2
%%PGSQL%%%%DATADIR%%-ido-pgsql/schema/upgrade/2.1.0.sql
%%PGSQL%%%%DATADIR%%-ido-pgsql/schema/upgrade/2.2.0.sql
%%PGSQL%%%%DATADIR%%-ido-pgsql/schema/upgrade/2.3.0.sql
-%%DATADIR%%/include/command-icinga.conf
-%%DATADIR%%/include/command-nscp-local.conf
-%%DATADIR%%/include/command-plugins-manubulon.conf
-%%DATADIR%%/include/command-plugins.conf
-%%DATADIR%%/include/command.conf
+@sample %%DATADIR%%/include/command-icinga.conf.sample
+@sample %%DATADIR%%/include/command-nscp-local.conf.sample
+@sample %%DATADIR%%/include/command-plugins-manubulon.conf.sample
+@sample %%DATADIR%%/include/command-plugins.conf.sample
+@sample %%DATADIR%%/include/command.conf.sample
%%DATADIR%%/include/hangman
%%DATADIR%%/include/itl
%%DATADIR%%/include/manubulon
%%DATADIR%%/include/nscp
%%DATADIR%%/include/plugins
%%DATADIR%%/include/plugins-contrib
-%%DATADIR%%/include/plugins-contrib.d/databases.conf
-%%DATADIR%%/include/plugins-contrib.d/ipmi.conf
-%%DATADIR%%/include/plugins-contrib.d/network-components.conf
-%%DATADIR%%/include/plugins-contrib.d/operating-system.conf
-%%DATADIR%%/include/plugins-contrib.d/virtualization.conf
-%%DATADIR%%/include/plugins-contrib.d/vmware.conf
-%%DATADIR%%/include/plugins-contrib.d/web.conf
-%%DATADIR%%/include/timeperiod.conf
+@sample %%DATADIR%%/include/plugins-contrib.d/databases.conf.sample
+@sample %%DATADIR%%/include/plugins-contrib.d/ipmi.conf.sample
+@sample %%DATADIR%%/include/plugins-contrib.d/network-components.conf.sample
+@sample %%DATADIR%%/include/plugins-contrib.d/operating-system.conf.sample
+@sample %%DATADIR%%/include/plugins-contrib.d/virtualization.conf.sample
+@sample %%DATADIR%%/include/plugins-contrib.d/vmware.conf.sample
+@sample %%DATADIR%%/include/plugins-contrib.d/web.conf.sample
+@sample %%DATADIR%%/include/timeperiod.conf.sample
+@sample %%DATADIR%%/include/command-plugins-windows.conf.sample
+%%DATADIR%%/include/windows-plugins
@dir %%ETCDIR%%/pki
-@dir /var/cache/icinga2
-@dir /var/lib/icinga2/api/log
-@dir /var/lib/icinga2/api/repository
-@dir /var/lib/icinga2/api/zones
-@dir /var/lib/icinga2/api
-@dir /var/lib/icinga2
+@dir(%%ICINGA2USER%%,%%ICINGA2GROUP%%) /var/cache/icinga2
+@dir(%%ICINGA2USER%%,%%ICINGA2GROUP%%) /var/lib/icinga2/api/log
+@dir(%%ICINGA2USER%%,%%ICINGA2GROUP%%) /var/lib/icinga2/api/repository
+@dir(%%ICINGA2USER%%,%%ICINGA2GROUP%%) /var/lib/icinga2/api/zones
+@dir(%%ICINGA2USER%%,%%ICINGA2GROUP%%) /var/lib/icinga2/api
+@dir(%%ICINGA2USER%%,%%ICINGA2GROUP%%) /var/lib/icinga2
@dir /var/lib
-@dir /var/log/icinga2/compat/archives
-@dir /var/log/icinga2/compat
-@dir /var/log/icinga2/crash
-@dir /var/log/icinga2
-@dir /var/run/icinga2/cmd
-@dir /var/run/icinga2
-@dir /var/spool/icinga2/perfdata
-@dir /var/spool/icinga2/tmp
-@dir /var/spool/icinga2
+@dir(%%ICINGA2USER%%,%%ICINGA2GROUP%%) /var/log/icinga2/compat/archives
+@dir(%%ICINGA2USER%%,%%ICINGA2GROUP%%) /var/log/icinga2/compat
+@dir(%%ICINGA2USER%%,%%ICINGA2GROUP%%) /var/log/icinga2/crash
+@dir(%%ICINGA2USER%%,%%ICINGA2GROUP%%) /var/log/icinga2
+@dir(%%ICINGA2USER%%,%%WWWGRP%%,2750) /var/run/icinga2/cmd
+@dir(%%ICINGA2USER%%,%%ICINGA2GROUP%%) /var/run/icinga2
+@dir(%%ICINGA2USER%%,%%ICINGA2GROUP%%) /var/spool/icinga2/perfdata
+@dir(%%ICINGA2USER%%,%%ICINGA2GROUP%%) /var/spool/icinga2/tmp
+@dir(%%ICINGA2USER%%,%%ICINGA2GROUP%%) /var/spool/icinga2