aboutsummaryrefslogtreecommitdiffstats
path: root/net-mgmt/icingaweb2-module-cube
diff options
context:
space:
mode:
authorlme <lme@FreeBSD.org>2017-03-08 19:53:04 +0800
committerlme <lme@FreeBSD.org>2017-03-08 19:53:04 +0800
commitdc2f791e7cbf7d5922e9201c9a4bd56c8e793e77 (patch)
treeb5ed11dc05c8000f0e5503d5d90707b4dc03ad9f /net-mgmt/icingaweb2-module-cube
parentae3d941a4b67e7a7ef83b0988d0cb6b81eaf4524 (diff)
downloadfreebsd-ports-gnome-dc2f791e7cbf7d5922e9201c9a4bd56c8e793e77.tar.gz
freebsd-ports-gnome-dc2f791e7cbf7d5922e9201c9a4bd56c8e793e77.tar.zst
freebsd-ports-gnome-dc2f791e7cbf7d5922e9201c9a4bd56c8e793e77.zip
Add net-mgmt/icingaweb2-module-cube
The Cube is a tiny but useful Icinga Web 2 module. It currently shows host statistics (total count, health) grouped by various custom variables in multiple dimensions. It will be your new best friend in case you are running a large environment and want to get a quick answers to questions like: - Which project uses how many servers per environment at which location/site? - Who occupies most servers? - How many of those are used in production? - Which project has only development and test boxes? - Which operating system is used for which project and in which environment? - Do we still have Debian Lenny? - Which projects are to blame for this? - Do we have applications where the operating systems used differ in staging and production? - Which project uses which operating system version for which application - Which projects have homogeneous environments? - Which projects are at a consistent patch level? - How many RHEL 6 variants (6.1, 6.2, 6.3...) do we use? - Who is running the oldest ones? In production? - Which projects are still using physical servers in which environment? WWW: https://github.com/Icinga/icingaweb2-module-cube
Diffstat (limited to 'net-mgmt/icingaweb2-module-cube')
-rw-r--r--net-mgmt/icingaweb2-module-cube/Makefile29
-rw-r--r--net-mgmt/icingaweb2-module-cube/distinfo3
-rw-r--r--net-mgmt/icingaweb2-module-cube/pkg-descr24
-rw-r--r--net-mgmt/icingaweb2-module-cube/pkg-plist38
4 files changed, 94 insertions, 0 deletions
diff --git a/net-mgmt/icingaweb2-module-cube/Makefile b/net-mgmt/icingaweb2-module-cube/Makefile
new file mode 100644
index 000000000000..8bca9414b283
--- /dev/null
+++ b/net-mgmt/icingaweb2-module-cube/Makefile
@@ -0,0 +1,29 @@
+# $FreeBSD$
+
+PORTNAME= icingaweb2-module-cube
+DISTVERSIONPREFIX= v
+DISTVERSION= 1.0.0
+CATEGORIES= net-mgmt www
+
+MAINTAINER= lme@FreeBSD.org
+COMMENT= Drill-down view for Icinga web 2 based on custom variables
+
+LICENSE= GPLv2
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+RUN_DEPENDS= icingaweb2>=2.4.1:net-mgmt/icingaweb2
+
+USE_GITHUB= yes
+GH_ACCOUNT= icinga
+
+NO_BUILD= yes
+NO_ARCH= yes
+
+WWWDIR?= ${PREFIX}/www/icingaweb2/modules/${PORTNAME:C/^.*-//}
+
+do-install:
+ @${MKDIR} ${STAGEDIR}${WWWDIR}
+ (cd ${WRKSRC} && \
+ ${COPYTREE_SHARE} . ${STAGEDIR}${WWWDIR})
+
+.include <bsd.port.mk>
diff --git a/net-mgmt/icingaweb2-module-cube/distinfo b/net-mgmt/icingaweb2-module-cube/distinfo
new file mode 100644
index 000000000000..76e377b27d48
--- /dev/null
+++ b/net-mgmt/icingaweb2-module-cube/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1488968323
+SHA256 (icinga-icingaweb2-module-cube-v1.0.0_GH0.tar.gz) = 27eada4c9acb2ca7d26d3394f1959a4f2d3c149241c0dabfbc070a99ba971930
+SIZE (icinga-icingaweb2-module-cube-v1.0.0_GH0.tar.gz) = 259843
diff --git a/net-mgmt/icingaweb2-module-cube/pkg-descr b/net-mgmt/icingaweb2-module-cube/pkg-descr
new file mode 100644
index 000000000000..9288e8dc5b08
--- /dev/null
+++ b/net-mgmt/icingaweb2-module-cube/pkg-descr
@@ -0,0 +1,24 @@
+The Cube is a tiny but useful Icinga Web 2 module. It currently shows host
+statistics (total count, health) grouped by various custom variables in
+multiple dimensions.
+
+It will be your new best friend in case you are running a large environment and
+want to get a quick answers to questions like:
+
+- Which project uses how many servers per environment at which location/site?
+- Who occupies most servers?
+- How many of those are used in production?
+- Which project has only development and test boxes?
+- Which operating system is used for which project and in which environment?
+- Do we still have Debian Lenny?
+- Which projects are to blame for this?
+- Do we have applications where the operating systems used differ in staging
+ and production?
+- Which project uses which operating system version for which application
+- Which projects have homogeneous environments?
+- Which projects are at a consistent patch level?
+- How many RHEL 6 variants (6.1, 6.2, 6.3...) do we use?
+- Who is running the oldest ones? In production?
+- Which projects are still using physical servers in which environment?
+
+WWW: https://github.com/Icinga/icingaweb2-module-cube
diff --git a/net-mgmt/icingaweb2-module-cube/pkg-plist b/net-mgmt/icingaweb2-module-cube/pkg-plist
new file mode 100644
index 000000000000..9ac6d1b96321
--- /dev/null
+++ b/net-mgmt/icingaweb2-module-cube/pkg-plist
@@ -0,0 +1,38 @@
+%%WWWDIR%%/.gitignore
+%%WWWDIR%%/LICENSE
+%%WWWDIR%%/README.md
+%%WWWDIR%%/application/controllers/IndexController.php
+%%WWWDIR%%/application/forms/DimensionsForm.php
+%%WWWDIR%%/application/views/helpers/FormSimpleNote.php
+%%WWWDIR%%/application/views/scripts/index/details.phtml
+%%WWWDIR%%/application/views/scripts/index/index.phtml
+%%WWWDIR%%/configuration.php
+%%WWWDIR%%/doc/img/cube_action-links.png
+%%WWWDIR%%/doc/img/cube_configuration.png
+%%WWWDIR%%/doc/img/cube_director.png
+%%WWWDIR%%/doc/img/cube_move-up.png
+%%WWWDIR%%/doc/img/cube_simple.png
+%%WWWDIR%%/doc/img/cube_slice.png
+%%WWWDIR%%/library/Cube/Cube.php
+%%WWWDIR%%/library/Cube/CubeRenderer.php
+%%WWWDIR%%/library/Cube/DbCube.php
+%%WWWDIR%%/library/Cube/Dimension.php
+%%WWWDIR%%/library/Cube/Hook/ActionsHook.php
+%%WWWDIR%%/library/Cube/Ido/CustomVarDimension.php
+%%WWWDIR%%/library/Cube/Ido/IdoCube.php
+%%WWWDIR%%/library/Cube/Ido/IdoHostStatusCube.php
+%%WWWDIR%%/library/Cube/Ido/IdoHostStatusCubeRenderer.php
+%%WWWDIR%%/library/Cube/ProvidedHook/Cube/MonitoringActions.php
+%%WWWDIR%%/library/Cube/Web/ActionLink.php
+%%WWWDIR%%/library/Cube/Web/ActionLinks.php
+%%WWWDIR%%/library/Cube/Web/Controller.php
+%%WWWDIR%%/library/Cube/Web/Form/CsrfToken.php
+%%WWWDIR%%/library/Cube/Web/Form/Element/FormElement.php
+%%WWWDIR%%/library/Cube/Web/Form/Element/SimpleNote.php
+%%WWWDIR%%/library/Cube/Web/Form/FormLoader.php
+%%WWWDIR%%/library/Cube/Web/Form/QuickBaseForm.php
+%%WWWDIR%%/library/Cube/Web/Form/QuickForm.php
+%%WWWDIR%%/library/Cube/Web/IconHelper.php
+%%WWWDIR%%/module.info
+%%WWWDIR%%/public/css/module.less
+%%WWWDIR%%/run.php