aboutsummaryrefslogtreecommitdiffstats
path: root/net-mgmt/isic
diff options
context:
space:
mode:
authordinoex <dinoex@FreeBSD.org>2013-02-19 05:13:02 +0800
committerdinoex <dinoex@FreeBSD.org>2013-02-19 05:13:02 +0800
commita69af0eb7aa0e2adb4c41ab4d6405385397f3eea (patch)
tree6c12a9e824cf39ccd0922fe8c2e9a8017ad5fc34 /net-mgmt/isic
parentbe1d59b55171e62bfdf033d7120d3419cad24f73 (diff)
downloadfreebsd-ports-gnome-a69af0eb7aa0e2adb4c41ab4d6405385397f3eea.tar.gz
freebsd-ports-gnome-a69af0eb7aa0e2adb4c41ab4d6405385397f3eea.tar.zst
freebsd-ports-gnome-a69af0eb7aa0e2adb4c41ab4d6405385397f3eea.zip
- update libnet to 1.1.6
- build shared lib - fix dependend ports when libnet.so.8 was linked in - fix dependend ports when includes where missing
Diffstat (limited to 'net-mgmt/isic')
-rw-r--r--net-mgmt/isic/Makefile4
-rw-r--r--net-mgmt/isic/files/patch-isic.h18
2 files changed, 20 insertions, 2 deletions
diff --git a/net-mgmt/isic/Makefile b/net-mgmt/isic/Makefile
index 4c2aa318b085..354588719dad 100644
--- a/net-mgmt/isic/Makefile
+++ b/net-mgmt/isic/Makefile
@@ -7,7 +7,7 @@
PORTNAME= isic
PORTVERSION= 0.07
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= net-mgmt
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/ISIC%20v${PORTVERSION}
EXTRACT_SUFX= .tgz
@@ -15,7 +15,7 @@ EXTRACT_SUFX= .tgz
MAINTAINER= ports@FreeBSD.org
COMMENT= IP Stack Integrity Checker
-BUILD_DEPENDS= ${LIBNET_CONFIG}:${PORTSDIR}/net/libnet
+LIB_DEPENDS= net:${PORTSDIR}/net/libnet
GNU_CONFIGURE= yes
MAKE_JOBS_SAFE= yes
diff --git a/net-mgmt/isic/files/patch-isic.h b/net-mgmt/isic/files/patch-isic.h
new file mode 100644
index 000000000000..356c6831a37f
--- /dev/null
+++ b/net-mgmt/isic/files/patch-isic.h
@@ -0,0 +1,18 @@
+--- isic.h.orig 2006-12-16 01:08:44.000000000 +0100
++++ isic.h 2013-02-18 07:36:38.000000000 +0100
+@@ -5,11 +5,15 @@
+ #endif
+
+ #include <libnet.h>
++#include <libnet/libnet-headers.h>
+
++#include <netinet/ip.h>
+ #include <netinet/ip_icmp.h>
+ #include <netinet/icmp6.h>
+ #include <netinet/ip6.h>
+ #include <netinet/if_ether.h>
++#include <netinet/udp.h>
++#include <netinet/tcp.h>
+
+ #ifndef ETHER_FRAME_SIZE
+ #define ETHER_FRAME_SIZE 1500