aboutsummaryrefslogtreecommitdiffstats
path: root/net-mgmt/lldpd
diff options
context:
space:
mode:
authorjunovitch <junovitch@FreeBSD.org>2016-06-26 07:47:22 +0800
committerjunovitch <junovitch@FreeBSD.org>2016-06-26 07:47:22 +0800
commit4845e29219e3929dd02408da424c87ba2a309ab0 (patch)
tree41196e92f7f3985eaebade0e51f8ebe1b672e9ce /net-mgmt/lldpd
parent64958f32eba2c3291828263bf64b972509a0c3c1 (diff)
downloadfreebsd-ports-gnome-4845e29219e3929dd02408da424c87ba2a309ab0.tar.gz
freebsd-ports-gnome-4845e29219e3929dd02408da424c87ba2a309ab0.tar.zst
freebsd-ports-gnome-4845e29219e3929dd02408da424c87ba2a309ab0.zip
net-mgmt/lldpd: update 0.9.2 -> 0.9.4
- Fix lldpd(8) in post-patch to show correct lldpd config file/directory path. - Apply extra patches taken from upstream right after 0.9.4 was released: * Fix build issues with 9.3's older cpp not supporting mutiple files as input. (likely Tier 2 archs with GCC 4.2 too) * Fix a regression which was caused by importing/adding support for new OpenBSD ifmediareq changes* and the use of typeof in 0.9.4 lldpd (0.9.3) * Do not rely on support of constructors for liblldpctl. * Always log to stderr (even in addition to syslog). * `lldpcli watch` accepts a limit on the number of received events. * `lldpcli -f {xml,json} watch` should work now. * Consider `veth` interfaces as physical interfaces. lldpd (0.9.4) * Make lldpd accepts a `-p` option to specify the PID file. * Ability to change multicast MAC address to two additional values to reach customer bridges. * lldpcli will now display chassis TTL when detailed view is enabled. * Fix setting of local value for port ID. * Fix compilation with BSD make. * Ensure lldpcli returns an error code on invalid commands. PR: 210390 Submitted by: Mathieu Simon <freebsd@simweb.ch> (maintainer)
Diffstat (limited to 'net-mgmt/lldpd')
-rw-r--r--net-mgmt/lldpd/Makefile5
-rw-r--r--net-mgmt/lldpd/distinfo5
-rw-r--r--net-mgmt/lldpd/files/patch-configure.ac11
-rw-r--r--net-mgmt/lldpd/files/patch-src_daemon_interfaces-bsd.c14
-rw-r--r--net-mgmt/lldpd/files/patch-src_lib_Makefile.in25
5 files changed, 57 insertions, 3 deletions
diff --git a/net-mgmt/lldpd/Makefile b/net-mgmt/lldpd/Makefile
index 2c136051dd93..666db404d98f 100644
--- a/net-mgmt/lldpd/Makefile
+++ b/net-mgmt/lldpd/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= lldpd
-PORTVERSION= 0.9.2
+PORTVERSION= 0.9.4
CATEGORIES= net-mgmt
MASTER_SITES= http://media.luffy.cx/files/${PORTNAME}/ \
http://mirror.1labs.ch/${PORTNAME}/
@@ -54,6 +54,9 @@ JSON_USES= pkgconfig
SNMP_LIB_DEPENDS= libnetsnmp.so:net-mgmt/net-snmp
XML_LIB_DEPENDS= libxml2.so:textproc/libxml2
+post-patch:
+ @${REINPLACE_CMD} -e 's|/etc|${PREFIX}|g' ${WRKSRC}/src/daemon/lldpd.8.in
+
post-install:
${INSTALL_DATA} ${FILESDIR}/README.bsd ${STAGEDIR}${DOCSDIR}
diff --git a/net-mgmt/lldpd/distinfo b/net-mgmt/lldpd/distinfo
index 4e194d05f311..57c071165920 100644
--- a/net-mgmt/lldpd/distinfo
+++ b/net-mgmt/lldpd/distinfo
@@ -1,2 +1,3 @@
-SHA256 (lldpd-0.9.2.tar.gz) = 6054f29d41faf32186a22331853a299c87f4419b4332df4a564f76a139305a32
-SIZE (lldpd-0.9.2.tar.gz) = 1600648
+TIMESTAMP = 1466250111
+SHA256 (lldpd-0.9.4.tar.gz) = eb1f5beff2ff5c13c5e0342b5b9da815ed4a63866262445e1168a79ee65c9079
+SIZE (lldpd-0.9.4.tar.gz) = 1604103
diff --git a/net-mgmt/lldpd/files/patch-configure.ac b/net-mgmt/lldpd/files/patch-configure.ac
new file mode 100644
index 000000000000..43be3831b510
--- /dev/null
+++ b/net-mgmt/lldpd/files/patch-configure.ac
@@ -0,0 +1,11 @@
+--- configure.ac.orig 2016-06-10 06:11:26 UTC
++++ configure.ac
+@@ -90,6 +90,8 @@ AX_CFLAGS_GCC_OPTION([-Wno-sign-compare]
+ AX_LDFLAGS_OPTION([-Wl,-z,relro], [LLDP_LDFLAGS])
+ AX_LDFLAGS_OPTION([-Wl,-z,now], [LLDP_LDFLAGS])
+
++AC_C_TYPEOF
++
+ # Hardening
+ AC_ARG_ENABLE([hardening],
+ [AS_HELP_STRING([--enable-hardening],
diff --git a/net-mgmt/lldpd/files/patch-src_daemon_interfaces-bsd.c b/net-mgmt/lldpd/files/patch-src_daemon_interfaces-bsd.c
new file mode 100644
index 000000000000..16803d33afb3
--- /dev/null
+++ b/net-mgmt/lldpd/files/patch-src_daemon_interfaces-bsd.c
@@ -0,0 +1,14 @@
+--- src/daemon/interfaces-bsd.c.orig 2016-06-13 06:38:49 UTC
++++ src/daemon/interfaces-bsd.c
+@@ -470,7 +470,11 @@ ifbsd_macphy(struct lldpd *cfg,
+ {
+ #ifdef ENABLE_DOT3
+ struct ifmediareq ifmr = {};
++#ifdef HAVE_TYPEOF
+ typeof(ifmr.ifm_ulist[0]) media_list[32] = {};
++#else
++ int media_list[32] = {};
++#endif
+ ifmr.ifm_ulist = media_list;
+ ifmr.ifm_count = 32;
+ struct lldpd_port *port = &hardware->h_lport;
diff --git a/net-mgmt/lldpd/files/patch-src_lib_Makefile.in b/net-mgmt/lldpd/files/patch-src_lib_Makefile.in
new file mode 100644
index 000000000000..5b285c1dab63
--- /dev/null
+++ b/net-mgmt/lldpd/files/patch-src_lib_Makefile.in
@@ -0,0 +1,25 @@
+--- src/lib/Makefile.in.orig 2016-06-17 17:20:00 UTC
++++ src/lib/Makefile.in
+@@ -895,8 +895,9 @@ uninstall-am: uninstall-includeHEADERS u
+
+
+ atom-glue.c: $(ATOM_FILES) Makefile
+- $(AM_V_GEN)($(CPP) $(DEFS) $(DEFAULT_INCLUDES) $(INCLUDES) $(AM_CPPFLAGS) \
+- $(CPPFLAGS) $(AM_CFLAGS) $(CFLAGS) $(ATOM_FILES:%=$(srcdir)/%) | \
++ $(AM_V_GEN)(for f in $(ATOM_FILES:%=$(srcdir)/%); do \
++ $(CPP) $(DEFS) $(DEFAULT_INCLUDES) $(INCLUDES) $(AM_CPPFLAGS) \
++ $(CPPFLAGS) $(AM_CFLAGS) $(CFLAGS) $$f; done | \
+ $(SED) -n 's+^void init_atom_builder_\([^(]*\)().*, \([0-9]*\)).*+\2 \1+p' | \
+ sort | \
+ $(AWK) '{ atoms[$$2] = 1 } \
+@@ -905,8 +906,9 @@ atom-glue.c: $(ATOM_FILES) Makefile
+ print " static int init = 0; if (init) return; init++;"; \
+ for (atom in atoms) { print " init_atom_builder_"atom"();" } \
+ print "}"; }' && \
++ for f in $(ATOM_FILES:%=$(srcdir)/%); do \
+ $(CPP) $(DEFS) $(DEFAULT_INCLUDES) $(INCLUDES) $(AM_CPPFLAGS) \
+- $(CPPFLAGS) $(AM_CFLAGS) $(CFLAGS) $(ATOM_FILES:%=$(srcdir)/%) | \
++ $(CPPFLAGS) $(AM_CFLAGS) $(CFLAGS) $$f; done | \
+ $(SED) -n 's+^void init_atom_map_\([^(]*\)().*, \([0-9]*\)).*+\2 \1+p' | \
+ sort -n | \
+ $(AWK) '{ atoms[$$2] = 1 } \