aboutsummaryrefslogtreecommitdiffstats
path: root/net-mgmt/nagios-check_smartmon
diff options
context:
space:
mode:
authorsahil <sahil@FreeBSD.org>2010-04-26 07:22:03 +0800
committersahil <sahil@FreeBSD.org>2010-04-26 07:22:03 +0800
commit7aab19e76360813c0f201831217ac86ccd495f1c (patch)
treed11e196514849395caef7a2329d1b8371673c7eb /net-mgmt/nagios-check_smartmon
parent0b5978467ec355e036102df0d3658cc2bea98195 (diff)
downloadfreebsd-ports-gnome-7aab19e76360813c0f201831217ac86ccd495f1c.tar.gz
freebsd-ports-gnome-7aab19e76360813c0f201831217ac86ccd495f1c.tar.zst
freebsd-ports-gnome-7aab19e76360813c0f201831217ac86ccd495f1c.zip
- Add performance data to output for PNP graphing
- Bump PORTREVISION due to functionality enhancement PR: ports/146003 Submitted by: olli hauer <ohauer@gmx.de> Approved by: Krzysztof Stryjek (maintainer), wxs@ (mentor)
Diffstat (limited to 'net-mgmt/nagios-check_smartmon')
-rw-r--r--net-mgmt/nagios-check_smartmon/Makefile1
-rw-r--r--net-mgmt/nagios-check_smartmon/files/patch-check_smartmon20
2 files changed, 21 insertions, 0 deletions
diff --git a/net-mgmt/nagios-check_smartmon/Makefile b/net-mgmt/nagios-check_smartmon/Makefile
index e77760f47949..d650d55ba688 100644
--- a/net-mgmt/nagios-check_smartmon/Makefile
+++ b/net-mgmt/nagios-check_smartmon/Makefile
@@ -6,6 +6,7 @@
PORTNAME= check_smartmon
PORTVERSION= 20100318
+PORTREVISION= 1
CATEGORIES= net-mgmt
MASTER_SITES= http://nognu.de/s/FreeBSD/distfiles/
PKGNAMEPREFIX= nagios-
diff --git a/net-mgmt/nagios-check_smartmon/files/patch-check_smartmon b/net-mgmt/nagios-check_smartmon/files/patch-check_smartmon
new file mode 100644
index 000000000000..11fb9037f299
--- /dev/null
+++ b/net-mgmt/nagios-check_smartmon/files/patch-check_smartmon
@@ -0,0 +1,20 @@
+--- ./check_smartmon.orig 2010-03-18 18:56:53.000000000 +0100
++++ ./check_smartmon 2010-04-23 22:53:13.000000000 +0200
+@@ -229,11 +229,14 @@
+ # fi
+
+ if temperature > criticalThreshold:
+- return (2, "CRITICAL: device temperature (%d) exceeds critical temperature threshold (%s)" % (temperature, criticalThreshold))
++ return (2, "CRITICAL: device temperature (%d) exceeds critical temperature threshold (%s)|TEMP=%d;%d;%d;"
++ % (temperature, criticalThreshold, temperature, warningThreshold, criticalThreshold))
+ elif temperature > warningThreshold:
+- return (1, "WARNING: device temperature (%d) exceeds warning temperature threshold (%s)" % (temperature, warningThreshold))
++ return (1, "WARNING: device temperature (%d) exceeds warning temperature threshold (%s)|TEMP=%d;%d;%d;"
++ % (temperature, warningThreshold, temperature, warningThreshold, criticalThreshold))
+ else:
+- return (0, "OK: device is functional and stable (temperature: %d)" % temperature)
++ return (0, "OK: device is functional and stable (temperature: %d)|TEMP=%d;%d;%d;"
++ % (temperature, temperature, warningThreshold, criticalThreshold))
+ # fi
+ # end
+