aboutsummaryrefslogtreecommitdiffstats
path: root/net-mgmt/nagios-plugins
diff options
context:
space:
mode:
authormat <mat@FreeBSD.org>2014-04-14 23:29:16 +0800
committermat <mat@FreeBSD.org>2014-04-14 23:29:16 +0800
commit34ab1ec73221a2e94869e55f5f1f5bbf602ed043 (patch)
treee9df2a3031b2b9cc3acf8736de1db3519a1f95a7 /net-mgmt/nagios-plugins
parent804beedc8220f60c1ab47ea6dfb738c3d31127a5 (diff)
downloadfreebsd-ports-gnome-34ab1ec73221a2e94869e55f5f1f5bbf602ed043.tar.gz
freebsd-ports-gnome-34ab1ec73221a2e94869e55f5f1f5bbf602ed043.tar.zst
freebsd-ports-gnome-34ab1ec73221a2e94869e55f5f1f5bbf602ed043.zip
Update to 2.0
- Convert to options knobs - On FreeBSD >=10.0 install a hidden copy of dig/nslookup to help with check_dig, and add back check_dns. Changes: https://nagios-plugins.org/nagios-plugins-2-0-released/ Sponsored by: Absolight
Diffstat (limited to 'net-mgmt/nagios-plugins')
-rw-r--r--net-mgmt/nagios-plugins/Makefile129
-rw-r--r--net-mgmt/nagios-plugins/distinfo4
-rw-r--r--net-mgmt/nagios-plugins/files/extra-patch-dig-to-drill.diff11
-rw-r--r--net-mgmt/nagios-plugins/files/patch-configure.ac (renamed from net-mgmt/nagios-plugins/files/patch-configure.in)32
-rw-r--r--net-mgmt/nagios-plugins/files/patch-gl__m4__extensions.m424
-rw-r--r--net-mgmt/nagios-plugins/files/patch-plugins-scripts__check_ircd.pl4
-rw-r--r--net-mgmt/nagios-plugins/files/patch-plugins-scripts__check_ntp.pl8
-rw-r--r--net-mgmt/nagios-plugins/files/patch-plugins-scripts__subst.in4
-rw-r--r--net-mgmt/nagios-plugins/files/patch-plugins-scripts__utils.sh.in15
-rw-r--r--net-mgmt/nagios-plugins/files/patch-plugins__check_ssh.c (renamed from net-mgmt/nagios-plugins/files/patch-plugins-check_ssh.c)0
-rw-r--r--net-mgmt/nagios-plugins/pkg-help7
-rw-r--r--net-mgmt/nagios-plugins/pkg-plist28
12 files changed, 109 insertions, 157 deletions
diff --git a/net-mgmt/nagios-plugins/Makefile b/net-mgmt/nagios-plugins/Makefile
index 5bef6bdd7e39..73f2246c9ef9 100644
--- a/net-mgmt/nagios-plugins/Makefile
+++ b/net-mgmt/nagios-plugins/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= nagios-plugins
-PORTVERSION= 1.5
-PORTREVISION= 1
+PORTVERSION= 2.0
PORTEPOCH= 1
CATEGORIES= net-mgmt
MASTER_SITES= https://www.nagios-plugins.org/download/
@@ -20,6 +19,7 @@ AUTOMAKE_ARGS= --add-missing
OPTIONS_DEFINE= QSTAT FPING NETSNMP RADIUS MYSQL PGSQL LDAP IPV6 JAIL NLS DBI EXTRAOPTS
OPTIONS_DEFAULT=IPV6 EXTRAOPTS
+OPTIONS_SUB= yes
QSTAT_DESC= Game server query support (check_game)
FPING_DESC= Support for non-flooding fast ping (check_fping)
@@ -28,7 +28,7 @@ RADIUS_DESC= Radius support (check_radius)
MYSQL_DESC= MySQL support (check_mysql)
PGSQL_DESC= PostgreSQL support (check_pgsql)
LDAP_DESC= OpenLDAP support (check_ldap)
-JAIL_DESC= Compilation within jail(8) (see Makefile)
+JAIL_DESC= Compilation within jail(8) (see help)
DBI_DESC= Check database using DBI
EXTRAOPTS_DESC= Parsing of plugins ini config files for extra options
@@ -47,13 +47,13 @@ NAGIOSCGIURL?= ${NAGIOSHTMURL}/cgi-bin
NAGIOSPOLLIP?= 127.0.0.1
NAGIOSPOLLIP6?= ::1
-.include <bsd.port.options.mk>
+PLUGINS_DIR= ${PREFIX}/libexec/nagios
CONFIGURE_ARGS+=--with-nagios-user=${NAGIOSUSER} \
--with-nagios-group=${NAGIOSGROUP} \
--with-cgiurl=${NAGIOSCGIURL} \
--sbindir=${PREFIX}/${NAGIOSWWWDIR}/cgi-bin \
- --libexecdir=${PREFIX}/libexec/nagios \
+ --libexecdir=${PLUGINS_DIR} \
--datadir=${PREFIX}/share \
--sysconfdir=${PREFIX}/etc/nagios \
--localstatedir=${NAGIOSDIR} \
@@ -64,103 +64,57 @@ CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
CFLAGS+= -I${LOCALBASE}/include
-.if ${PORT_OPTIONS:MQSTAT}
-BUILD_DEPENDS+= qstat:${PORTSDIR}/games/qstat
-RUN_DEPENDS+= qstat:${PORTSDIR}/games/qstat
-CONFIGURE_ARGS+= --enable-qstat
-PLIST_SUB+= SUB_QSTAT=""
-.else
-PLIST_SUB+= SUB_QSTAT="@comment "
-.endif
+QSTAT_BUILD_DEPENDS= qstat:${PORTSDIR}/games/qstat
+QSTAT_RUN_DEPENDS= qstat:${PORTSDIR}/games/qstat
+QSTAT_CONFIGURE_ENABLE= qstat
-.if ${PORT_OPTIONS:MIPV6}
-CONFIGURE_ARGS+= --with-ipv6
-.else
-CONFIGURE_ARGS+= --without-ipv6
-.endif
+IPV6_CONFIGURE_WITH= ipv6
-.if ${PORT_OPTIONS:MFPING}
-BUILD_DEPENDS+= fping:${PORTSDIR}/net/fping
-RUN_DEPENDS+= fping:${PORTSDIR}/net/fping
-CONFIGURE_ARGS+= --enable-fping
-PLIST_SUB+= SUB_FPING=""
-.else
-PLIST_SUB+= SUB_FPING="@comment "
-.endif
+FPING_BUILD_DEPENDS= fping:${PORTSDIR}/net/fping
+FPING_RUN_DEPENDS= fping:${PORTSDIR}/net/fping
+FPING_CONFIGURE_ENABLE= fping
-.if ${PORT_OPTIONS:MNETSNMP}
-BUILD_DEPENDS+= snmpcheck:${PORTSDIR}/net-mgmt/net-snmp \
+NETSNMP_BUILD_DEPENDS= snmpcheck:${PORTSDIR}/net-mgmt/net-snmp \
p5-Net-SNMP>=0:${PORTSDIR}/net-mgmt/p5-Net-SNMP
-RUN_DEPENDS+= snmpcheck:${PORTSDIR}/net-mgmt/net-snmp \
+NETSNMP_RUN_DEPENDS= snmpcheck:${PORTSDIR}/net-mgmt/net-snmp \
p5-Net-SNMP>=0:${PORTSDIR}/net-mgmt/p5-Net-SNMP
-CONFIGURE_ARGS+= --enable-snmp
-PLIST_SUB+= SUB_SNMP=""
-.else
-PLIST_SUB+= SUB_SNMP="@comment "
-.endif
+NETSNMP_CONFIGURE_ENABLE= snmp
-.if ${PORT_OPTIONS:MRADIUS}
-LIB_DEPENDS+= libradiusclient-ng.so:${PORTSDIR}/net/radiusclient
-PLIST_SUB+= SUB_RADIUS=""
-.else
-CONFIGURE_ARGS+= --without-radius
-PLIST_SUB+= SUB_RADIUS="@comment "
-.endif
+RADIUS_LIB_DEPENDS= libradiusclient-ng.so:${PORTSDIR}/net/radiusclient
+RADIUS_CONFIGURE_WITH= radius
-.if ${PORT_OPTIONS:MMYSQL}
-USE_MYSQL= YES
-CONFIGURE_ARGS+= --with-mysql=${LOCALBASE}
-PLIST_SUB+= SUB_MYSQL=""
-.else
-CONFIGURE_ARGS+= --without-mysql
-PLIST_SUB+= SUB_MYSQL="@comment "
-.endif
+MYSQL_USE= mysql=yes
+MYSQL_CONFIGURE_ON= --with-mysql=${LOCALBASE}
+MYSQL_CONFIGURE_OFF= --without-mysql
-.if ${PORT_OPTIONS:MPGSQL}
-USE_PGSQL= YES
-CONFIGURE_ARGS+= --with-pgsql=${LOCALBASE}
-PLIST_SUB+= SUB_PGSQL=""
-.else
-CONFIGURE_ARGS+= --without-pgsql
-PLIST_SUB+= SUB_PGSQL="@comment "
-.endif
+PGSQL_USE= pgsql=yes
+PGSQL_CONFIGURE_ON= --with-pgsql=${LOCALBASE}
+PGSQL_CONFIGURE_OFF= --without-pgsql
-.if ${PORT_OPTIONS:MLDAP}
-USE_OPENLDAP= YES
-PLIST_SUB+= SUB_LDAP=""
-.else
-CONFIGURE_ARGS+= --without-ldap
-PLIST_SUB+= SUB_LDAP="@comment "
-.endif
+LDAP_USE= openldap=yes
+LDAP_CONFIGURE_WITH= ldap
-.if ${PORT_OPTIONS:MNLS}
-USES+= gettext
-PLIST_SUB+= NLS=""
-.else
-CONFIGURE_ARGS+= --disable-nls
-PLIST_SUB+= NLS="@comment "
-.endif
+NLS_USES= gettext
+NLS_CONFIGURE_ENABLE= nls
-.if ${PORT_OPTIONS:MDBI}
-PLIST_SUB+= SUB_DBI=""
-LIB_DEPENDS+= libdbi.so:${PORTSDIR}/databases/libdbi
-.else
-CONFIGURE_ARGS+= --without-dbi
-PLIST_SUB+= SUB_DBI="@comment "
-.endif
+DBI_LIB_DEPENDS= libdbi.so:${PORTSDIR}/databases/libdbi
+DBI_CONFIGURE_WITH= dbi
+
+.include <bsd.port.options.mk>
.if ${OSVERSION} > 1000055
-EXTRA_PATCHES+= ${FILESDIR}/extra-patch-dig-to-drill.diff
-CONFIGURE_ARGS+=--with-dig-command=/usr/bin/drill
-PLIST_SUB+= SUB_DNS="@comment "
+BUILD_DEPENDS+= ${LOCALBASE}/bin/dig:${PORTSDIR}/dns/bind-tools
+CONFIGURE_ARGS+= --with-dig-command=${PLUGINS_DIR}/nagios-dig \
+ --with-nslookup-command=${PLUGINS_DIR}/nagios-nslookup
+PLIST_SUB+= BIND=""
.else
-PLIST_SUB+= SUB_DNS=""
+PLIST_SUB+= BIND="@comment "
.endif
.if !exists(/usr/bin/ssh)
-PLIST_SUB+= SUB_SSH="@comment "
+PLIST_SUB+= SSH="@comment "
.else
-PLIST_SUB+= SUB_SSH=""
+PLIST_SUB+= SSH=""
.endif
post-patch:
@@ -176,4 +130,11 @@ post-patch:
@${REINPLACE_CMD} -e 's# ::1 # ${NAGIOSPOLLIP6} #g' ${WRKSRC}/configure.in
.endif
+.if ${OSVERSION} > 1000055
+post-install:
+.for f in dig nslookup
+ ${INSTALL_PROGRAM} ${LOCALBASE}/bin/${f} ${STAGEDIR}${PLUGINS_DIR}/nagios-${f}
+.endfor
+.endif
+
.include <bsd.port.mk>
diff --git a/net-mgmt/nagios-plugins/distinfo b/net-mgmt/nagios-plugins/distinfo
index d8b1eb3d87c6..f00b4d328d3c 100644
--- a/net-mgmt/nagios-plugins/distinfo
+++ b/net-mgmt/nagios-plugins/distinfo
@@ -1,2 +1,2 @@
-SHA256 (nagios-plugins-1.5.tar.gz) = fcc55e23bbf1c70bcf1a90749d30249955d4668a9b776b2521da023c5c2f2170
-SIZE (nagios-plugins-1.5.tar.gz) = 2428258
+SHA256 (nagios-plugins-2.0.tar.gz) = ba1080648abd912f55c18b248e7065db77a87d0c72611ab16c17af8b65da7684
+SIZE (nagios-plugins-2.0.tar.gz) = 2501847
diff --git a/net-mgmt/nagios-plugins/files/extra-patch-dig-to-drill.diff b/net-mgmt/nagios-plugins/files/extra-patch-dig-to-drill.diff
deleted file mode 100644
index 9aa7b7685b30..000000000000
--- a/net-mgmt/nagios-plugins/files/extra-patch-dig-to-drill.diff
+++ /dev/null
@@ -1,11 +0,0 @@
---- plugins/check_dig.c.orig 2013-10-02 19:22:21.000000000 +0400
-+++ plugins/check_dig.c 2013-12-15 16:55:26.000000000 +0400
-@@ -88,7 +88,7 @@ main (int argc, char **argv)
- usage_va(_("Could not parse arguments"));
-
- /* get the command to run */
-- xasprintf (&command_line, "%s @%s -p %d %s -t %s %s %s",
-+ xasprintf (&command_line, "%s @%s -z -p %d %s %s %s %s",
- PATH_TO_DIG, dns_server, server_port, query_address, record_type, dig_args, query_transport);
-
- alarm (timeout_interval);
diff --git a/net-mgmt/nagios-plugins/files/patch-configure.in b/net-mgmt/nagios-plugins/files/patch-configure.ac
index 4907be135750..aee53fed28ae 100644
--- a/net-mgmt/nagios-plugins/files/patch-configure.in
+++ b/net-mgmt/nagios-plugins/files/patch-configure.ac
@@ -1,6 +1,6 @@
---- configure.in.orig 2013-10-02 17:22:21.000000000 +0200
-+++ configure.in 2013-12-14 14:27:40.067139387 +0100
-@@ -12,8 +12,6 @@
+--- ./configure.ac.orig 2014-03-04 20:21:36.000000000 +0100
++++ ./configure.ac 2014-04-14 10:22:50.000000000 +0200
+@@ -13,8 +13,6 @@
RELEASE=1
AC_SUBST(RELEASE)
@@ -9,7 +9,7 @@
dnl Deprecated configure options
-@@ -44,6 +42,7 @@
+@@ -45,6 +43,7 @@
gl_EARLY
AC_PROG_GCC_TRADITIONAL
AC_PROG_LIBTOOL
@@ -17,7 +17,7 @@
AM_PROG_CC_C_O
-@@ -214,8 +213,8 @@
+@@ -215,8 +214,8 @@
AC_CHECK_LIB(crypt,main)
if test "$ac_cv_lib_crypt_main" = "yes" -a "x$PGSQL" != "xno"; then
if test -n "$PGSQL"; then
@@ -28,7 +28,7 @@
fi
AC_CHECK_LIB(pq,PQsetdbLogin,,,-lcrypt)
if test "$ac_cv_lib_pq_PQsetdbLogin" = "yes"; then
-@@ -259,10 +258,10 @@
+@@ -260,10 +259,10 @@
dnl Check for DBI libraries
AS_IF([test "x$with_dbi" != "xno"], [
_SAVEDLIBS="$LIBS"
@@ -41,7 +41,7 @@
AC_SUBST(DBILIBS)
else
AC_MSG_WARN([Skipping dbi plugin])
-@@ -276,22 +275,17 @@
+@@ -277,22 +276,17 @@
dnl Check for radius libraries
AS_IF([test "x$with_radius" != "xno"], [
_SAVEDLIBS="$LIBS"
@@ -68,7 +68,7 @@
LIBS="$_SAVEDLIBS"
])
-@@ -300,12 +294,13 @@
+@@ -301,12 +295,13 @@
dnl Check for LDAP libraries
AS_IF([test "x$with_ldap" != "xno"], [
_SAVEDLIBS="$LIBS"
@@ -86,7 +86,7 @@
AC_CHECK_FUNCS(ldap_set_option)
EXTRAS="$EXTRAS check_ldap"
AC_CHECK_FUNCS(ldap_init ldap_set_option ldap_get_option ldap_start_tls_s)
-@@ -729,22 +724,10 @@
+@@ -746,22 +741,10 @@
dnl ac_cv_ps_cols=8
dnl AC_MSG_RESULT([$ac_cv_ps_command])
@@ -112,7 +112,7 @@
then
ac_cv_ps_varlist="[procstat,&procuid,&procpid,&procppid,&procvsz,&procrss,&procpcpu,procprog,&pos]"
ac_cv_ps_command="$PATH_TO_PS -axwo 'stat uid pid ppid vsz rss pcpu comm args'"
-@@ -752,9 +735,8 @@
+@@ -769,9 +752,8 @@
ac_cv_ps_cols=9
AC_MSG_RESULT([$ac_cv_ps_command])
@@ -124,7 +124,7 @@
elif ps -axwo 'stat uid pid ppid vsz rss pcpu ucomm command' 2>/dev/null | \
egrep -i ["^ *STAT +UID +PID +PPID +VSZ +RSS +%CPU +UCOMM +COMMAND"] > /dev/null
then
-@@ -764,209 +746,6 @@
+@@ -781,209 +763,6 @@
ac_cv_ps_cols=9
AC_MSG_RESULT([$ac_cv_ps_command])
@@ -334,7 +334,7 @@
else
AC_MSG_WARN([unable to find usable ps syntax - check_procs and check_nagios will not be compiled])
fi
-@@ -1354,6 +1133,8 @@
+@@ -1371,6 +1150,8 @@
AC_MSG_WARN([Get smbclient from Samba.org to monitor SMB shares])
fi
@@ -343,7 +343,7 @@
AC_PATH_PROG(PATH_TO_SNMPGET,snmpget)
AC_ARG_WITH(snmpget_command,
ACX_HELP_STRING([--with-snmpget-command=PATH],
-@@ -1384,7 +1165,10 @@
+@@ -1401,7 +1182,10 @@
else
AC_MSG_WARN([Tried $PERL - install Net::SNMP perl module if you want to use the perl snmp plugins])
fi
@@ -354,7 +354,7 @@
AC_PATH_PROG(PATH_TO_QUAKESTAT,quakestat)
AC_PATH_PROG(PATH_TO_QSTAT,qstat)
AC_ARG_WITH(qstat_command,
-@@ -1409,7 +1193,10 @@
+@@ -1426,7 +1210,10 @@
AC_DEFINE_UNQUOTED(PATH_TO_QSTAT,"$ac_cv_path_to_qstat",
[path to qstat/quakestat])
fi
@@ -365,7 +365,7 @@
AC_PATH_PROG(PATH_TO_FPING,fping)
AC_PATH_PROG(PATH_TO_FPING6,fping6)
-@@ -1430,6 +1217,7 @@
+@@ -1447,6 +1234,7 @@
else
AC_MSG_WARN([Get fping from http://www.fping.com in order to make check_fping plugin])
fi
@@ -373,7 +373,7 @@
AC_PATH_PROG(PATH_TO_SSH,ssh)
AC_ARG_WITH(ssh_command,
-@@ -1497,32 +1285,12 @@
+@@ -1517,32 +1305,12 @@
dnl end if for PATH_TO_SWAP
fi
diff --git a/net-mgmt/nagios-plugins/files/patch-gl__m4__extensions.m4 b/net-mgmt/nagios-plugins/files/patch-gl__m4__extensions.m4
index 596b77bd1a45..f20bcdaa15d2 100644
--- a/net-mgmt/nagios-plugins/files/patch-gl__m4__extensions.m4
+++ b/net-mgmt/nagios-plugins/files/patch-gl__m4__extensions.m4
@@ -1,10 +1,18 @@
---- gl/m4/extensions.m4.orig 2007-01-24 22:47:25.000000000 +0000
-+++ gl/m4/extensions.m4 2008-07-14 15:04:08.000000000 +0000
-@@ -18,2 +18,3 @@
- # typically due to standards-conformance issues.
+--- ./gl/m4/extensions.m4.orig 2014-03-04 20:21:36.000000000 +0100
++++ ./gl/m4/extensions.m4 2014-04-14 10:22:50.000000000 +0200
+@@ -16,6 +16,7 @@
+ # warning: AC_COMPILE_IFELSE was called before AC_USE_SYSTEM_EXTENSIONS
+ # or warning: AC_RUN_IFELSE was called before AC_USE_SYSTEM_EXTENSIONS
+ # the fix is
+m4_ifndef([AC_USE_SYSTEM_EXTENSIONS],[
- AC_DEFUN([AC_USE_SYSTEM_EXTENSIONS],
-@@ -51,2 +52,3 @@
- ])
+ # 1) to ensure that AC_USE_SYSTEM_EXTENSIONS is never directly invoked
+ # but always AC_REQUIREd,
+ # 2) to ensure that for each occurrence of
+@@ -49,6 +50,7 @@
+ except with this defined.])
+ AC_DEFINE([_MINIX], [1],
+ [Define to 1 if on MINIX.])
+])
-
+ AC_DEFINE([_NETBSD_SOURCE], [1],
+ [Define to 1 to make NetBSD features available. MINIX 3 needs this.])
+ fi
diff --git a/net-mgmt/nagios-plugins/files/patch-plugins-scripts__check_ircd.pl b/net-mgmt/nagios-plugins/files/patch-plugins-scripts__check_ircd.pl
index 2efbf4867f9c..662ebe5efd8d 100644
--- a/net-mgmt/nagios-plugins/files/patch-plugins-scripts__check_ircd.pl
+++ b/net-mgmt/nagios-plugins/files/patch-plugins-scripts__check_ircd.pl
@@ -1,5 +1,5 @@
---- plugins-scripts/check_ircd.pl.orig 2012-06-27 12:32:47.000000000 -0500
-+++ plugins-scripts/check_ircd.pl 2012-11-14 20:58:01.479745211 -0600
+--- ./plugins-scripts/check_ircd.pl.orig 2014-03-04 20:21:36.000000000 +0100
++++ ./plugins-scripts/check_ircd.pl 2014-04-14 10:22:50.000000000 +0200
@@ -66,6 +66,7 @@
$ENV{PATH} = "";
$ENV{ENV} = "";
diff --git a/net-mgmt/nagios-plugins/files/patch-plugins-scripts__check_ntp.pl b/net-mgmt/nagios-plugins/files/patch-plugins-scripts__check_ntp.pl
index 1bf2557f831f..f3d08657ca5f 100644
--- a/net-mgmt/nagios-plugins/files/patch-plugins-scripts__check_ntp.pl
+++ b/net-mgmt/nagios-plugins/files/patch-plugins-scripts__check_ntp.pl
@@ -1,6 +1,6 @@
---- plugins-scripts/check_ntp.pl.orig Wed Nov 30 11:19:47 2005
-+++ plugins-scripts/check_ntp.pl Fri May 12 23:39:15 2006
-@@ -314,7 +314,6 @@
+--- ./plugins-scripts/check_ntp.pl.orig 2014-03-04 20:21:36.000000000 +0100
++++ ./plugins-scripts/check_ntp.pl 2014-04-14 10:22:50.000000000 +0200
+@@ -313,7 +313,6 @@
}
} else {
print "No match!\n" if $verbose;
@@ -8,7 +8,7 @@
}
}
-@@ -428,7 +427,7 @@
+@@ -427,7 +426,7 @@
foreach my $key (keys %ERRORS) {
if ($state==$ERRORS{$key}) {
# print ("NTP $key: $answer");
diff --git a/net-mgmt/nagios-plugins/files/patch-plugins-scripts__subst.in b/net-mgmt/nagios-plugins/files/patch-plugins-scripts__subst.in
index 35b676b95201..dacce592f3d0 100644
--- a/net-mgmt/nagios-plugins/files/patch-plugins-scripts__subst.in
+++ b/net-mgmt/nagios-plugins/files/patch-plugins-scripts__subst.in
@@ -1,5 +1,5 @@
---- plugins-scripts/subst.in.orig Wed Aug 31 07:41:42 2005
-+++ plugins-scripts/subst.in Sun Sep 30 18:16:42 2007
+--- ./plugins-scripts/subst.in.orig 2014-03-04 20:21:36.000000000 +0100
++++ ./plugins-scripts/subst.in 2014-04-14 10:22:50.000000000 +0200
@@ -1,7 +1,7 @@
#!/usr/bin/awk
diff --git a/net-mgmt/nagios-plugins/files/patch-plugins-scripts__utils.sh.in b/net-mgmt/nagios-plugins/files/patch-plugins-scripts__utils.sh.in
deleted file mode 100644
index 5e1abd7acbb4..000000000000
--- a/net-mgmt/nagios-plugins/files/patch-plugins-scripts__utils.sh.in
+++ /dev/null
@@ -1,15 +0,0 @@
---- plugins-scripts/utils.sh.in.orig Sat Jul 7 21:10:29 2007
-+++ plugins-scripts/utils.sh.in Sun Oct 14 12:33:54 2007
-@@ -14,10 +14,10 @@
-
- print_revision() {
- echo "$1 v$2 (@PACKAGE@ @VERSION@)"
-- $ECHO "@WARRANTY@" | sed -e 's/\n/ /g'
-+ $ECHO "@WARRANTY@" | /usr/bin/sed -e 's/\n/ /g'
- }
-
- support() {
-- $ECHO "@SUPPORT@" | sed -e 's/\n/ /g'
-+ $ECHO "@SUPPORT@" | /usr/bin/sed -e 's/\n/ /g'
- }
-
diff --git a/net-mgmt/nagios-plugins/files/patch-plugins-check_ssh.c b/net-mgmt/nagios-plugins/files/patch-plugins__check_ssh.c
index f68032e1640e..f68032e1640e 100644
--- a/net-mgmt/nagios-plugins/files/patch-plugins-check_ssh.c
+++ b/net-mgmt/nagios-plugins/files/patch-plugins__check_ssh.c
diff --git a/net-mgmt/nagios-plugins/pkg-help b/net-mgmt/nagios-plugins/pkg-help
new file mode 100644
index 000000000000..e39bffe55475
--- /dev/null
+++ b/net-mgmt/nagios-plugins/pkg-help
@@ -0,0 +1,7 @@
+
+ ** JAIL **
+If you are building nagios-plugins from within a jail that
+doesn't have 127.0.0.1 and ::1, and you want check_ping to
+be built, you have to set NAGIOSPOLLIP and NAGIOSPOLLIP6 to
+an IPV4 and an IPV6 address that can be pinged from the jail.
+
diff --git a/net-mgmt/nagios-plugins/pkg-plist b/net-mgmt/nagios-plugins/pkg-plist
index 9ed3fb8ddc7f..7fb865a30457 100644
--- a/net-mgmt/nagios-plugins/pkg-plist
+++ b/net-mgmt/nagios-plugins/pkg-plist
@@ -1,21 +1,21 @@
libexec/nagios/check_apt
libexec/nagios/check_breeze
-%%SUB_SSH%%libexec/nagios/check_by_ssh
+%%SSH%%libexec/nagios/check_by_ssh
libexec/nagios/check_clamd
libexec/nagios/check_cluster
-%%SUB_DBI%%libexec/nagios/check_dbi
+%%DBI%%libexec/nagios/check_dbi
libexec/nagios/check_dhcp
libexec/nagios/check_dig
libexec/nagios/check_disk
libexec/nagios/check_disk_smb
-%%SUB_DNS%%libexec/nagios/check_dns
+libexec/nagios/check_dns
libexec/nagios/check_dummy
libexec/nagios/check_file_age
libexec/nagios/check_flexlm
-%%SUB_FPING%%libexec/nagios/check_fping
+%%FPING%%libexec/nagios/check_fping
libexec/nagios/check_ftp
-%%SUB_QSTAT%%libexec/nagios/check_game
-%%SUB_SNMP%%libexec/nagios/check_hpjd
+%%QSTAT%%libexec/nagios/check_game
+%%NETSNMP%%libexec/nagios/check_hpjd
libexec/nagios/check_http
libexec/nagios/check_icmp
libexec/nagios/check_ifoperstatus
@@ -23,15 +23,15 @@ libexec/nagios/check_ifstatus
libexec/nagios/check_imap
libexec/nagios/check_ircd
libexec/nagios/check_jabber
-%%SUB_LDAP%%libexec/nagios/check_ldap
-%%SUB_LDAP%%libexec/nagios/check_ldaps
+%%LDAP%%libexec/nagios/check_ldap
+%%LDAP%%libexec/nagios/check_ldaps
libexec/nagios/check_load
libexec/nagios/check_log
libexec/nagios/check_mailq
libexec/nagios/check_mrtg
libexec/nagios/check_mrtgtraf
-%%SUB_MYSQL%%libexec/nagios/check_mysql
-%%SUB_MYSQL%%libexec/nagios/check_mysql_query
+%%MYSQL%%libexec/nagios/check_mysql
+%%MYSQL%%libexec/nagios/check_mysql_query
libexec/nagios/check_nagios
libexec/nagios/check_nntp
libexec/nagios/check_nntps
@@ -42,17 +42,17 @@ libexec/nagios/check_ntp_time
libexec/nagios/check_nwstat
libexec/nagios/check_oracle
libexec/nagios/check_overcr
-%%SUB_PGSQL%%libexec/nagios/check_pgsql
+%%PGSQL%%libexec/nagios/check_pgsql
libexec/nagios/check_ping
libexec/nagios/check_pop
libexec/nagios/check_procs
-%%SUB_RADIUS%%libexec/nagios/check_radius
+%%RADIUS%%libexec/nagios/check_radius
libexec/nagios/check_real
libexec/nagios/check_rpc
libexec/nagios/check_sensors
libexec/nagios/check_simap
libexec/nagios/check_smtp
-%%SUB_SNMP%%libexec/nagios/check_snmp
+%%NETSNMP%%libexec/nagios/check_snmp
libexec/nagios/check_spop
libexec/nagios/check_ssh
libexec/nagios/check_ssmtp
@@ -64,6 +64,8 @@ libexec/nagios/check_ups
libexec/nagios/check_users
libexec/nagios/check_wave
libexec/nagios/negate
+%%BIND%%libexec/nagios/nagios-dig
+%%BIND%%libexec/nagios/nagios-nslookup
libexec/nagios/urlize
libexec/nagios/utils.pm
libexec/nagios/utils.sh