aboutsummaryrefslogtreecommitdiffstats
path: root/net-mgmt/nagios-plugins
diff options
context:
space:
mode:
authormat <mat@FreeBSD.org>2015-03-10 19:39:17 +0800
committermat <mat@FreeBSD.org>2015-03-10 19:39:17 +0800
commit524288734c7d1e12b5f2af54ff70ff3a3c994b7a (patch)
tree17388dff7a0a728d5bf0d4c7ac25dddadb8efe7c /net-mgmt/nagios-plugins
parentd32edeb1d352c587544e42652424d583acf0784a (diff)
downloadfreebsd-ports-gnome-524288734c7d1e12b5f2af54ff70ff3a3c994b7a.tar.gz
freebsd-ports-gnome-524288734c7d1e12b5f2af54ff70ff3a3c994b7a.tar.zst
freebsd-ports-gnome-524288734c7d1e12b5f2af54ff70ff3a3c994b7a.zip
Fix a segfault in check_dhcp.
PR: 198318 Submitted by: Ian Pallfreeman Sponsored by: Absolight
Diffstat (limited to 'net-mgmt/nagios-plugins')
-rw-r--r--net-mgmt/nagios-plugins/Makefile2
-rw-r--r--net-mgmt/nagios-plugins/files/patch-plugins-root_check__dhcp.c9
2 files changed, 10 insertions, 1 deletions
diff --git a/net-mgmt/nagios-plugins/Makefile b/net-mgmt/nagios-plugins/Makefile
index 2b9a2b841ca5..e72e64133125 100644
--- a/net-mgmt/nagios-plugins/Makefile
+++ b/net-mgmt/nagios-plugins/Makefile
@@ -3,7 +3,7 @@
PORTNAME= nagios-plugins
PORTVERSION= 2.0.3
-PORTREVISION= 8
+PORTREVISION= 9
PORTEPOCH= 1
CATEGORIES= net-mgmt
MASTER_SITES= https://www.nagios-plugins.org/download/ \
diff --git a/net-mgmt/nagios-plugins/files/patch-plugins-root_check__dhcp.c b/net-mgmt/nagios-plugins/files/patch-plugins-root_check__dhcp.c
index 4ee277ab73c9..450dcf69d90e 100644
--- a/net-mgmt/nagios-plugins/files/patch-plugins-root_check__dhcp.c
+++ b/net-mgmt/nagios-plugins/files/patch-plugins-root_check__dhcp.c
@@ -10,3 +10,12 @@
char *buf;
unsigned char *ptr;
struct if_msghdr *ifm;
+@@ -1185,7 +1186,7 @@ int call_getopt(int argc, char **argv){
+ }
+ }
+
+- return i;
++ return i+1;
+ }
+
+