aboutsummaryrefslogtreecommitdiffstats
path: root/net-mgmt/nagios-plugins
diff options
context:
space:
mode:
authortimur <timur@FreeBSD.org>2008-09-04 23:22:59 +0800
committertimur <timur@FreeBSD.org>2008-09-04 23:22:59 +0800
commitbc32a74c023b8afd809e20147170f7532f26de97 (patch)
treeea658f0c74909609341848db6afaac82aa0cacfd /net-mgmt/nagios-plugins
parent2cfb3395027c5e569caaad4d47c0a475e9384716 (diff)
downloadfreebsd-ports-gnome-bc32a74c023b8afd809e20147170f7532f26de97.tar.gz
freebsd-ports-gnome-bc32a74c023b8afd809e20147170f7532f26de97.tar.zst
freebsd-ports-gnome-bc32a74c023b8afd809e20147170f7532f26de97.zip
* Add LOCALBASE to the CFLAGS, CPPFLAGS and LDFLAGS, so ldap(and other)
libraries and headers could be found. * Removed unnecesary USE_ICONV, as it is used only by GETTEXT and comes as it's dependency anyhow.
Diffstat (limited to 'net-mgmt/nagios-plugins')
-rw-r--r--net-mgmt/nagios-plugins/Makefile9
1 files changed, 4 insertions, 5 deletions
diff --git a/net-mgmt/nagios-plugins/Makefile b/net-mgmt/nagios-plugins/Makefile
index 73b70b565424..8d12759c9af1 100644
--- a/net-mgmt/nagios-plugins/Makefile
+++ b/net-mgmt/nagios-plugins/Makefile
@@ -7,6 +7,7 @@
PORTNAME= nagios-plugins
PORTVERSION= 1.4.12
+PORTREVISION= 1
PORTEPOCH= 1
CATEGORIES= net-mgmt
MASTER_SITES= SFE/nagiosplug
@@ -16,7 +17,6 @@ COMMENT= Plugins for Nagios
USE_SUBMAKE= yes
USE_GMAKE= yes
-USE_ICONV= yes
USE_PERL5= yes
USE_AUTOTOOLS= aclocal:19 automake:19 autoconf:262
ACLOCAL_ARGS= --acdir=${ACLOCAL_DIR} -I m4 -I gl/m4
@@ -52,10 +52,9 @@ CONFIGURE_ARGS= --with-nagios-user=${NAGIOSUSER} \
--localstatedir=${NAGIOSDIR} \
--prefix=${PREFIX}
-CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" \
- CFLAGS="${CFLAGS}" \
- LDFLAGS="${LDFLAGS}" \
- LIBS="-L${LOCALBASE}/lib" \
+CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS} -I${LOCALBASE}/include" \
+ CFLAGS="${CFLAGS} -I${LOCALBASE}/include" \
+ LDFLAGS="${LDFLAGS} -L${LOCALBASE}/lib" \
PERL=${PERL}
.if defined(WITH_QSTAT)