aboutsummaryrefslogtreecommitdiffstats
path: root/net-mgmt/nagios/Makefile
diff options
context:
space:
mode:
authormharo <mharo@FreeBSD.org>2001-01-13 07:36:31 +0800
committermharo <mharo@FreeBSD.org>2001-01-13 07:36:31 +0800
commit42663697151412685d9d0a162065f03c0b058730 (patch)
tree7a89f5b2fd75722a5c26644359c6b1f3cbb995f8 /net-mgmt/nagios/Makefile
parentfaa07e92f644c37505113caab2f78a10a071681f (diff)
downloadfreebsd-ports-gnome-42663697151412685d9d0a162065f03c0b058730.tar.gz
freebsd-ports-gnome-42663697151412685d9d0a162065f03c0b058730.tar.zst
freebsd-ports-gnome-42663697151412685d9d0a162065f03c0b058730.zip
update to 0.0.6
Diffstat (limited to 'net-mgmt/nagios/Makefile')
-rw-r--r--net-mgmt/nagios/Makefile19
1 files changed, 13 insertions, 6 deletions
diff --git a/net-mgmt/nagios/Makefile b/net-mgmt/nagios/Makefile
index 1f57b4c66bba..685bfb9dc6e5 100644
--- a/net-mgmt/nagios/Makefile
+++ b/net-mgmt/nagios/Makefile
@@ -6,19 +6,26 @@
#
PORTNAME= netsaint
-PORTVERSION= 0.0.5.2
+PORTVERSION= 0.0.6
CATEGORIES= net
-MASTER_SITES= http://www.netsaint.org/download/
-DISTNAME= ${PORTNAME}-0.0.5-2
+MASTER_SITES= http://netsaint.sourceforge.net/download/
MAINTAINER= ports@FreeBSD.org
-LIB_DEPENDS= gd.1:${PORTSDIR}/graphics/gd
+LIB_DEPENDS= gd.1:${PORTSDIR}/graphics/gd \
+ gnugetopt.1:${PORTSDIR}/devel/libgnugetopt
+# no run depends due to circular reference
+#RUN_DEPENDS= ${LOCALBASE}/libexec/netsaint/check_netsaint:${PORTSDIR}/net/netsaint-plugins
GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
- LIBS="-L${LOCALBASE}/lib -lgd"
-INSTALL_TARGET= install-all
+ CFLAGS="${CFLAGS} -I${LOCALBASE}/include" \
+ LIBS="-L${LOCALBASE}/lib -lgd -lgnugetopt"
+CONFIGURE_ARGS= --with-command-user=root \
+ --with-command-grp=wheel \
+ --with-netsaint-user=netsaint \
+ --with-netsaint-grp=netsaint
+INSTALL_TARGET= all install config install-config install-daemoninit
pre-fetch:
@${SH} ${SCRIPTDIR}/checkps