aboutsummaryrefslogtreecommitdiffstats
path: root/net-mgmt/nagvis/Makefile
diff options
context:
space:
mode:
authorohauer <ohauer@FreeBSD.org>2010-11-11 05:43:31 +0800
committerohauer <ohauer@FreeBSD.org>2010-11-11 05:43:31 +0800
commitaed3ab4278d07c4c5a4bfe3508375e93312e2da7 (patch)
tree6e1e1b4ad255904fb055da221136046e498057ec /net-mgmt/nagvis/Makefile
parent55fd9d97cea48d8ab36802891475d62849dd5839 (diff)
downloadfreebsd-ports-gnome-aed3ab4278d07c4c5a4bfe3508375e93312e2da7.tar.gz
freebsd-ports-gnome-aed3ab4278d07c4c5a4bfe3508375e93312e2da7.tar.zst
freebsd-ports-gnome-aed3ab4278d07c4c5a4bfe3508375e93312e2da7.zip
- update nagvis to version 1.5.5
- add OPIONS for ndb2dbo and mk-livestatus brokers - make mk-livestatus the default broker since it needs no database - add pkg-deinstall message Changelog for 1.5.5 =================== NagVis WUI: * Change backend_id field in WUI to dropdown select field for map options NagVis MKLivestatus Backend: * Recode MKLivestatus backend to use fsockopen instead of socket module NagVis Core * State of map objects was not refreshed correctly in 1.5.4 * Increase max username length limitation to sth. larger than 15 * The permission for controlling multisite access is missing List of all changes: http://sourceforge.net/apps/trac/nagvis/report/32 PR: 151999 Submitted by: ohauer Approved by: A.Sidorov <derfi _at_ vei.ru> (maintainer), glarkin (mentor, implicit)
Diffstat (limited to 'net-mgmt/nagvis/Makefile')
-rw-r--r--net-mgmt/nagvis/Makefile23
1 files changed, 18 insertions, 5 deletions
diff --git a/net-mgmt/nagvis/Makefile b/net-mgmt/nagvis/Makefile
index 671af8637c55..18607e2f75c1 100644
--- a/net-mgmt/nagvis/Makefile
+++ b/net-mgmt/nagvis/Makefile
@@ -6,18 +6,18 @@
#
PORTNAME= nagvis
-PORTVERSION= 1.5.4
+PORTVERSION= 1.5.5
CATEGORIES= net-mgmt
MASTER_SITES= SF/${PORTNAME}/NagVis%201.5/
MAINTAINER= derfi@vei.ru
COMMENT= NagVis is a visualization addon for Nagios
-RUN_DEPENDS= ndo2db-3x:${PORTSDIR}/net-mgmt/ndoutils
-
LICENSE= GPLv2
-OPTIONS= GRAPHVIZ "graphviz is needed for automaps" off
+OPTIONS= MKLIVESTATUS "depend on mk-livestatus broker (preferred)" on \
+ NDO2DB "depend on ndo2db broker" off \
+ GRAPHVIZ "graphviz is needed for automaps" off
NO_BUILD= yes
USE_PHP= gd gettext mbstring mysql session json pdo pdo_sqlite
@@ -29,12 +29,25 @@ DEFAULT_PHP_VER=5
WWW_OWNER?= ${WWWOWN}
WWW_GROUP?= ${WWWGRP}
SUB_LIST+= WWW_OWNER=${WWW_OWNER} WWW_GROUP=${WWW_GROUP}
-SUB_FILES+= pkg-install
+SUB_FILES+= pkg-install pkg-deinstall
+
+.if defined(WITH_NDO2DB)
+RUN_DEPENDS+= ndo2db-3x:${PORTSDIR}/net-mgmt/ndoutils
+.endif
+
+.if defined(WITH_MKLIVESTATUS)
+RUN_DEPENDS+= mk-livestatus>=0:${PORTSDIR}/net-mgmt/mk-livestatus
+.endif
.if defined(WITH_GRAPHVIZ)
RUN_DEPENDS+= dot:${PORTSDIR}/graphics/graphviz
.endif
+check-sanity:
+.if !defined(WITH_NDO2DB) && !defined(WITH_MKLIVESTATUS)
+IGNORE= please choose at least one nagios broker module
+.endif
+
post-extract:
@${RM} -f ${WRKSRC}/.gitignore ${WRKSRC}/install.sh ${WRKSRC}/INSTALL