aboutsummaryrefslogtreecommitdiffstats
path: root/net-mgmt/nedi
diff options
context:
space:
mode:
authorwxs <wxs@FreeBSD.org>2011-12-26 03:28:06 +0800
committerwxs <wxs@FreeBSD.org>2011-12-26 03:28:06 +0800
commit1b62f66cf21d6e89d5229aaccf05ef317121ee18 (patch)
tree5bbab0b93b0d178dca6087e50593388850793da7 /net-mgmt/nedi
parent44346fa91786dc4b97e799d45be509715d877998 (diff)
downloadfreebsd-ports-gnome-1b62f66cf21d6e89d5229aaccf05ef317121ee18.tar.gz
freebsd-ports-gnome-1b62f66cf21d6e89d5229aaccf05ef317121ee18.tar.zst
freebsd-ports-gnome-1b62f66cf21d6e89d5229aaccf05ef317121ee18.zip
Switch to using bsd.port.options.mk and remove unnecessary assignments.
While here, don't use 'find | xargs rm', when 'find -delete' will do. PR: ports/162754 Submitted by: Matthew Seaman <m.seaman@infracaninophile.co.uk>
Diffstat (limited to 'net-mgmt/nedi')
-rw-r--r--net-mgmt/nedi/Makefile12
1 files changed, 2 insertions, 10 deletions
diff --git a/net-mgmt/nedi/Makefile b/net-mgmt/nedi/Makefile
index ef72653f4ec0..5c16c60e53dc 100644
--- a/net-mgmt/nedi/Makefile
+++ b/net-mgmt/nedi/Makefile
@@ -24,19 +24,11 @@ WRKSRC= ${WRKDIR}/${PORTNAME}
NO_BUILD= yes
USE_PERL5= yes
-# The options part is copied from databases/phpmyadmin
-# and looks this way, because we have to USE_PHP
-# before pre.mk, however WITH_*, WITHOUT_* are set only
-# after pre.mk. The solution is to set them by ourselves.
OPTIONS= GD "Use GD" OFF
-PORT_DBDIR?= /var/db/ports
LATEST_LINK= ${PORTNAME}${PKGNAMESUFFIX}
-OPTIONSFILE?= ${PORT_DBDIR}/${LATEST_LINK}/options
-.if exists(${OPTIONSFILE})
-.include "${OPTIONSFILE}"
-.endif
+.include <bsd.port.options.mk>
USE_PHP= session snmp mysql
WANT_PHP_WEB= yes
@@ -53,7 +45,7 @@ SUB_LIST= NEDIDIR=${NEDIDIR}
post-patch:
@${REINPLACE_CMD} -e 's|/var/nedi|${NEDIDIR}|' ${WRKSRC}/html/inc/libgraph.php
@${REINPLACE_CMD} -e "s|'/etc|'${PREFIX}/etc|" ${WRKSRC}/html/inc/libmisc.php
- @${FIND} ${WRKSRC} -name *.bak -or -name *.orig | ${XARGS} ${RM}
+ @${FIND} ${WRKSRC} -name *.bak -or -name *.orig -delete
do-install:
@ ${MKDIR} -m 755 ${NEDIDIR}