aboutsummaryrefslogtreecommitdiffstats
path: root/net-mgmt/net-snmp-devel
diff options
context:
space:
mode:
authorasami <asami@FreeBSD.org>1998-11-14 17:43:39 +0800
committerasami <asami@FreeBSD.org>1998-11-14 17:43:39 +0800
commit521807d38becba50804a00710cfa1b51c759a4f4 (patch)
tree26cfeb8a991d32014f9a30277d2ade973f1a937f /net-mgmt/net-snmp-devel
parentf4c70db8f8fed4684d8013755f0d23c5da34733e (diff)
downloadfreebsd-ports-gnome-521807d38becba50804a00710cfa1b51c759a4f4.tar.gz
freebsd-ports-gnome-521807d38becba50804a00710cfa1b51c759a4f4.tar.zst
freebsd-ports-gnome-521807d38becba50804a00710cfa1b51c759a4f4.zip
Use bsd.port.{pre,post}.mk to move PORTOBJFORMAT to front, or change
shell loops to make loops. Use EXTRA_PKG_FLAGS to add install scripts instead of adding it to PKG_FLAGS after bsd.port.mk.
Diffstat (limited to 'net-mgmt/net-snmp-devel')
-rw-r--r--net-mgmt/net-snmp-devel/Makefile23
1 files changed, 13 insertions, 10 deletions
diff --git a/net-mgmt/net-snmp-devel/Makefile b/net-mgmt/net-snmp-devel/Makefile
index f9c8ac74ffc0..44acc26a7de0 100644
--- a/net-mgmt/net-snmp-devel/Makefile
+++ b/net-mgmt/net-snmp-devel/Makefile
@@ -3,7 +3,7 @@
# Date created: 26 June 1996
# Whom: gpalmer
#
-# $Id: Makefile,v 1.21 1998/08/30 15:51:13 steve Exp $
+# $Id: Makefile,v 1.22 1998/10/19 22:43:08 nectar Exp $
#
DISTNAME= ucd-snmp-3.5.3
@@ -36,6 +36,17 @@ SBIN= snmpd snmptrapd
STARTUP_FILE= ${PREFIX}/etc/rc.d/snmpd.sh.sample
+.include <bsd.port.pre.mk>
+
+
+.if ${PORTOBJFORMAT} == "aout"
+SHLIB_VERSION=3.5
+PATCHDIR=patches.aout
+.else
+SHLIB_VERSION=3
+.endif
+MAKE_ENV+= SHLIB_VERSION=${SHLIB_VERSION}
+
post-install:
( cd ${PREFIX}/bin && strip ${BIN} )
( cd ${PREFIX}/sbin && strip ${SBIN} )
@@ -51,12 +62,4 @@ post-install:
fi
${SETENV} OBJFORMAT="${PORTOBJFORMAT}" ${LDCONFIG} -m ${PREFIX}/lib
-.include <bsd.port.mk>
-
-.if (${PORTOBJFORMAT} == "aout")
-SHLIB_VERSION=3.5
-PATCHDIR=patches.aout
-.else
-SHLIB_VERSION=3
-.endif
-MAKE_ENV+= SHLIB_VERSION=${SHLIB_VERSION}
+.include <bsd.port.post.mk>