aboutsummaryrefslogtreecommitdiffstats
path: root/net-mgmt/net-snmp53/Makefile
diff options
context:
space:
mode:
authorkuriyama <kuriyama@FreeBSD.org>2005-01-26 07:49:30 +0800
committerkuriyama <kuriyama@FreeBSD.org>2005-01-26 07:49:30 +0800
commit3285db6c51d4e862eed00b3662d8eb5aad020243 (patch)
treebf7a5a7ca204359000d65744409178cbe2cac3ab /net-mgmt/net-snmp53/Makefile
parent750b710301243f4b892c05918b84a2d3794d9634 (diff)
downloadfreebsd-ports-gnome-3285db6c51d4e862eed00b3662d8eb5aad020243.tar.gz
freebsd-ports-gnome-3285db6c51d4e862eed00b3662d8eb5aad020243.tar.zst
freebsd-ports-gnome-3285db6c51d4e862eed00b3662d8eb5aad020243.zip
- Update to 5.2.1.
- Add a patch to fix memory leak (SF bugs #1103644). - Add WITH_DMALLOC knob (with a lot of patches to fix #include order).
Diffstat (limited to 'net-mgmt/net-snmp53/Makefile')
-rw-r--r--net-mgmt/net-snmp53/Makefile12
1 files changed, 9 insertions, 3 deletions
diff --git a/net-mgmt/net-snmp53/Makefile b/net-mgmt/net-snmp53/Makefile
index 83aec90bbd02..ec13bc7f3e2f 100644
--- a/net-mgmt/net-snmp53/Makefile
+++ b/net-mgmt/net-snmp53/Makefile
@@ -6,8 +6,8 @@
#
PORTNAME= snmp
-PORTVERSION= 5.2
-PORTREVISION= 1
+PORTVERSION= 5.2.1
+PORTREVISION= 0
PKGNAMEPREFIX= net-
CATEGORIES= net-mgmt ipv6
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
@@ -33,6 +33,7 @@ USE_REINPLACE= yes
USE_AUTOCONF_VER=259
USE_LIBTOOL_VER=15
USE_RC_SUBR= yes
+USE_OPENSSL= yes
INSTALLS_SHLIB= yes
LIBTOOLFLAGS= #empty
.if !defined(WITHOUT_PERL)
@@ -73,6 +74,11 @@ PLIST_SUB+= WITH_TKMIB=""
PLIST_SUB+= WITH_TKMIB="@comment "
.endif
+.if defined(WITH_DMALLOC)
+LIB_DEPEND+= dmalloc:${PORTSDIR}/devel/dmalloc
+CONFIGURE_ARGS+=--with-dmalloc=${LOCALBASE}
+.endif
+
.if ${OSVERSION} >= 400014 && !defined(WITHOUT_IPV6)
CONFIGURE_ARGS+=--enable-ipv6
# --with-transport="UDPIPv6 TCPIPv6" --with-modules=mibII/ipv6"
@@ -268,6 +274,6 @@ display-message:
# Maintainer's note:
# Don't forget to bump library version in these ports.
-# lang/php4,lang/php5,net-mgmt/braa,net-mgmt/docsis,net/ethereal,net-mgmt/mbrowse,net/quagga,net/tethereal,net-mgmt/zabbix,security/libfwbuilder,net-mgmt/p5-SNMP-Info,net-mgmt/nagios-snmp-plugins,french/plgrenouille
+# lang/php4,lang/php5,net-mgmt/braa,net-mgmt/docsis,net/ethereal,net-mgmt/mbrowse,net/quagga,net/tethereal,net-mgmt/zabbix,security/libfwbuilder,net-mgmt/p5-SNMP-Info,net-mgmt/nagios-snmp-plugins,french/plgrenouille,mail/cyrus-imapd22,net/ifstat,sysutils/jailadmin
.include <bsd.port.post.mk>