aboutsummaryrefslogtreecommitdiffstats
path: root/net-mgmt/net-snmp53
diff options
context:
space:
mode:
authorkuriyama <kuriyama@FreeBSD.org>2004-02-29 20:26:59 +0800
committerkuriyama <kuriyama@FreeBSD.org>2004-02-29 20:26:59 +0800
commit10a969fb73c59ee213f2fe351280155d3e7814ce (patch)
tree65ffd94f16f8d5f31b4911456ab6ac320ab90eb2 /net-mgmt/net-snmp53
parente453e7ce575baf85c89888e5d826b9911c74bdef (diff)
downloadfreebsd-ports-gnome-10a969fb73c59ee213f2fe351280155d3e7814ce.tar.gz
freebsd-ports-gnome-10a969fb73c59ee213f2fe351280155d3e7814ce.tar.zst
freebsd-ports-gnome-10a969fb73c59ee213f2fe351280155d3e7814ce.zip
Avoid "kvm_read: Bad address" error.
PR: ports/63026 Submitted by: Antoine Jacoutot <ajacoutot@lphp.org>
Diffstat (limited to 'net-mgmt/net-snmp53')
-rw-r--r--net-mgmt/net-snmp53/Makefile2
-rw-r--r--net-mgmt/net-snmp53/files/patch-auto_nlist.c10
2 files changed, 11 insertions, 1 deletions
diff --git a/net-mgmt/net-snmp53/Makefile b/net-mgmt/net-snmp53/Makefile
index 1809774e30a6..ba56db36fcf7 100644
--- a/net-mgmt/net-snmp53/Makefile
+++ b/net-mgmt/net-snmp53/Makefile
@@ -7,7 +7,7 @@
PORTNAME= net-snmp
PORTVERSION= 5.1
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= net-mgmt ipv6
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= net-snmp
diff --git a/net-mgmt/net-snmp53/files/patch-auto_nlist.c b/net-mgmt/net-snmp53/files/patch-auto_nlist.c
new file mode 100644
index 000000000000..79feff8f64ee
--- /dev/null
+++ b/net-mgmt/net-snmp53/files/patch-auto_nlist.c
@@ -0,0 +1,10 @@
+--- agent/auto_nlist.c.orig Sun Feb 29 21:24:25 2004
++++ agent/auto_nlist.c Sun Feb 29 21:24:43 2004
+@@ -57,6 +57,7 @@
+ }
+ if (*ptr == 0) {
+ *ptr = (struct autonlist *) malloc(sizeof(struct autonlist));
++ memset(*ptr, 0, sizeof(struct autonlist));
+ it = *ptr;
+ it->left = 0;
+ it->right = 0;