aboutsummaryrefslogtreecommitdiffstats
path: root/net-mgmt/netmask/Makefile
diff options
context:
space:
mode:
authorwill <will@FreeBSD.org>2000-12-19 18:29:26 +0800
committerwill <will@FreeBSD.org>2000-12-19 18:29:26 +0800
commit42ef999e3fd63ccbcd0b1f8eb13c43e6ae3f5407 (patch)
tree3a1ce54584077ab3550095da021911a640158225 /net-mgmt/netmask/Makefile
parent6ad46c5e4e3085ce54e63538bf29e9d09940cff4 (diff)
downloadfreebsd-ports-gnome-42ef999e3fd63ccbcd0b1f8eb13c43e6ae3f5407.tar.gz
freebsd-ports-gnome-42ef999e3fd63ccbcd0b1f8eb13c43e6ae3f5407.tar.zst
freebsd-ports-gnome-42ef999e3fd63ccbcd0b1f8eb13c43e6ae3f5407.zip
Add netmask 2.3.3, a tool for generating terse netmasks in several common
formats. PR: 23005 Submitted by: Mike Bristow <mike@urgle.com>
Diffstat (limited to 'net-mgmt/netmask/Makefile')
-rw-r--r--net-mgmt/netmask/Makefile25
1 files changed, 25 insertions, 0 deletions
diff --git a/net-mgmt/netmask/Makefile b/net-mgmt/netmask/Makefile
new file mode 100644
index 000000000000..1b21c29cb1e9
--- /dev/null
+++ b/net-mgmt/netmask/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: netmask
+# Date created: 19 Novemver 2000
+# Whom: Mike Bristow <mike@urgle.com>
+# $FreeBSD$
+
+PORTNAME= netmask
+PORTVERSION= 2.3.3
+CATEGORIES= net
+MASTER_SITES= http://ftp.debian.org/debian/dists/potato/main/source/net/
+DISTNAME= netmask_${PORTVERSION}
+
+MAINTAINER= mike@urgle.com
+
+LIB_DEPENDS= gnugetopt.1:${PORTSDIR}/devel/libgnugetopt
+
+WRKSRC= ${WRKDIR}/${DISTNAME:S/_/-/}
+USE_AUTOMAKE= yes
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib -lgnugetopt"
+
+USE_GMAKE= yes
+
+MAN1= netmask.1
+
+.include <bsd.port.mk>