aboutsummaryrefslogtreecommitdiffstats
path: root/net-mgmt/netwox/Makefile
diff options
context:
space:
mode:
authorsem <sem@FreeBSD.org>2004-08-01 17:39:38 +0800
committersem <sem@FreeBSD.org>2004-08-01 17:39:38 +0800
commit1aa341cac36be53284f98a50355ebd50ed3b2d4f (patch)
tree979e984cfeb1902451291028072d95746fe6a491 /net-mgmt/netwox/Makefile
parentfb93e5f1b0e1b5f3c21681caaca64ec64abec9f0 (diff)
downloadfreebsd-ports-gnome-1aa341cac36be53284f98a50355ebd50ed3b2d4f.tar.gz
freebsd-ports-gnome-1aa341cac36be53284f98a50355ebd50ed3b2d4f.tar.zst
freebsd-ports-gnome-1aa341cac36be53284f98a50355ebd50ed3b2d4f.zip
* lcrzoex tools was renamed to netwox
* update to 5.20.0 and move to net-mgmt category * new maintainer PR: ports/69609 Submitted by: Janos Mohacsi <janos.mohacsi@bsd.hu>
Diffstat (limited to 'net-mgmt/netwox/Makefile')
-rw-r--r--net-mgmt/netwox/Makefile45
1 files changed, 26 insertions, 19 deletions
diff --git a/net-mgmt/netwox/Makefile b/net-mgmt/netwox/Makefile
index c881d1b61b5a..b261fdced65c 100644
--- a/net-mgmt/netwox/Makefile
+++ b/net-mgmt/netwox/Makefile
@@ -1,31 +1,38 @@
-# New ports collection makefile for: lcrzoex
-# Date created: Wed Apr 10 02:42:20 CEST 2002
-# Whom: king@v2project.com
+# New ports collection makefile for: netwox
+# Date created: 26.07.2004
+# Whom: janos.mohacsi@bsd.hu
#
# $FreeBSD$
#
-PORTNAME= lcrzoex
-PORTVERSION= 4.17.0
-CATEGORIES= security
-MASTER_SITES= http://www.laurentconstantin.com/common/netw/netwib/download/v4/ \
- http://fresh.t-systems-sfr.com/unix/src/privat2/
-EXTRACT_SUFX= -src.tgz
+PORTNAME= netwox
+PORTVERSION= 5.20.0
+CATEGORIES= net-mgmt ipv6
+MASTER_SITES= http://www.laurentconstantin.com/common/netw/netwox/download/v5/ \
+ http://membres.lycos.fr/lauconstantin/common/netw/netwox/download/v5/ \
+ http://laurentconstantin.free.fr/common/netw/netwox/download/v5/
+DISTFILES= ${PORTNAME}-${PORTVERSION}-src.tgz ${PORTNAME}-${PORTVERSION}-doc_html.tgz
-MAINTAINER= king@v2project.com
-COMMENT= Lcrzoex contains over 300 functionnalities using network library lcrzo
+MAINTAINER= janos.mohacsi@bsd.hu
+COMMENT= Netwox a network testing toolbox
-BUILD_DEPENDS= ${LOCALBASE}/include/lcrzo_debugdefs.h:${PORTSDIR}/security/lcrzo
+BUILD_DEPENDS= ${LOCALBASE}/bin/netwib-config:${PORTSDIR}/net/netwib
-WRKSRC= ${WRKDIR}/${PKGNAME}-src/src
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}-src/src
+USE_REINPLACE= yes
+MAN1= netwox.1 netwox520.1
-MAN1= lcrzoex.1
-PLIST_FILES= bin/lcrzoex
-
-pre-configure:
- cd ${WRKSRC} && ${SH} ${WRKSRC}/genemake
+do-configure:
+ @${REINPLACE_CMD} \
+ -e 's|%%PREFIX%%|${PREFIX}|' \
+ ${WRKSRC}/config.dat
+ (cd ${WRKSRC} ; ${SH} ${WRKSRC}/genemake )
post-install:
- @${CAT} ${PKGMESSAGE}
+ strip ${PREFIX}/bin/${PORTNAME}
+.ifndef(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ @${CP} -R ${WRKSRC}/../../${PORTNAME}-${PORTVERSION}-doc_html/* ${DOCSDIR}
+.endif
.include <bsd.port.mk>