aboutsummaryrefslogtreecommitdiffstats
path: root/net-mgmt/nfdump-devel
diff options
context:
space:
mode:
authorrafan <rafan@FreeBSD.org>2008-08-21 14:18:49 +0800
committerrafan <rafan@FreeBSD.org>2008-08-21 14:18:49 +0800
commitc8007265d81e778bec43e1f7b073b196887b3604 (patch)
treea30fd3dc7b50670b88ce6f8cf28e0ccf2b1e599a /net-mgmt/nfdump-devel
parent9f3176cd391ec72812d7f37e93b881faa3648b45 (diff)
downloadfreebsd-ports-gnome-c8007265d81e778bec43e1f7b073b196887b3604.tar.gz
freebsd-ports-gnome-c8007265d81e778bec43e1f7b073b196887b3604.tar.zst
freebsd-ports-gnome-c8007265d81e778bec43e1f7b073b196887b3604.zip
Update CONFIGURE_ARGS for how we pass CONFIGURE_TARGET to configure script.
Specifically, newer autoconf (> 2.13) has different semantic of the configure target. In short, one should use --build=CONFIGURE_TARGET instead of CONFIGURE_TARGET directly. Otherwise, you will get a warning and the old semantic may be removed in later autoconf releases. To workaround this issue, many ports hack the CONFIGURE_TARGET variable so that it contains the ``--build='' prefix. To solve this issue, under the fact that some ports still have configure script generated by the old autoconf, we use runtime detection in the do-configure target so that the proper argument can be used. Changes to Mk/*: - Add runtime detection magic in bsd.port.mk - Remove CONFIGURE_TARGET hack in various bsd.*.mk - USE_GNOME=gnometarget is now an no-op Changes to individual ports, other than removing the CONFIGURE_TARGET hack: = pkg-plist changed (due to the ugly CONFIGURE_TARGET prefix in * executables) - comms/gnuradio - science/abinit - science/elmer-fem - science/elmer-matc - science/elmer-meshgen2d - science/elmerfront - science/elmerpost = use x86_64 as ARCH - devel/g-wrap = other changes - print/magicfilter GNU_CONFIGURE -> HAS_CONFIGURE since it's not generated by autoconf Total # of ports modified: 1,027 Total # of ports affected: ~7,000 (set GNU_CONFIGURE to yes) PR: 126524 (obsoletes 52917) Submitted by: rafan Tested on: two pointyhat 7-amd64 exp runs (by pav) Approved by: portmgr (pav)
Diffstat (limited to 'net-mgmt/nfdump-devel')
-rw-r--r--net-mgmt/nfdump-devel/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/net-mgmt/nfdump-devel/Makefile b/net-mgmt/nfdump-devel/Makefile
index 629ac748458d..9514904db29a 100644
--- a/net-mgmt/nfdump-devel/Makefile
+++ b/net-mgmt/nfdump-devel/Makefile
@@ -20,7 +20,7 @@ BUILD_DEPENDS= rrdtool:${PORTSDIR}/databases/rrdtool
RUN_DEPENDS= ${BUILD_DEPENDS}
GNU_CONFIGURE= yes
-CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL} --enable-nfprofile --with-rrdpath=${LOCALBASE}
+CONFIGURE_ARGS= --enable-nfprofile --with-rrdpath=${LOCALBASE}
#flow-tools support
OPTIONS= FT2NFDUMP "With Flow-tools to nfdump converter" off \
@@ -31,7 +31,7 @@ OPTIONS= FT2NFDUMP "With Flow-tools to nfdump converter" off \
#for compatibility
#
.ifndef(WITHOUT_NFDUMP14_SUPPORT)
-CONFIGURE_ARGS= --enable-compat14
+CONFIGURE_ARGS+= --enable-compat14
.endif
PLIST_FILES= bin/nfcapd bin/nfdump bin/nfreplay bin/nfexpire bin/nfprofile