aboutsummaryrefslogtreecommitdiffstats
path: root/net-mgmt/p0f/Makefile
diff options
context:
space:
mode:
authorsteve <steve@FreeBSD.org>2000-07-10 11:51:01 +0800
committersteve <steve@FreeBSD.org>2000-07-10 11:51:01 +0800
commit1c7f78711a77237686dbb3c7c187b042f2ba9964 (patch)
tree7fccf2b6c567be5876e758fae6e6f864f9df3ae9 /net-mgmt/p0f/Makefile
parentd06e130ac34cdf932d6f6db076fc2c29841b1bb5 (diff)
downloadfreebsd-ports-gnome-1c7f78711a77237686dbb3c7c187b042f2ba9964.tar.gz
freebsd-ports-gnome-1c7f78711a77237686dbb3c7c187b042f2ba9964.tar.zst
freebsd-ports-gnome-1c7f78711a77237686dbb3c7c187b042f2ba9964.zip
Adding p0f version 1.7.
A passive OS fingerprinting tool. PR: 19225 Submitted by: Trevor Johnson <trevor@jpj.net>
Diffstat (limited to 'net-mgmt/p0f/Makefile')
-rw-r--r--net-mgmt/p0f/Makefile33
1 files changed, 33 insertions, 0 deletions
diff --git a/net-mgmt/p0f/Makefile b/net-mgmt/p0f/Makefile
new file mode 100644
index 000000000000..797f990e4b19
--- /dev/null
+++ b/net-mgmt/p0f/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: p0f
+# Date created: 2000-06-12
+# Whom: Trevor Johnson
+#
+# $FreeBSD$
+#
+
+PORTNAME= p0f
+PORTVERSION= 1.7
+CATEGORIES= net
+MASTER_SITES= http://lcamtuf.hack.pl/
+DISTNAME= ${PORTNAME}
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= trevor@jpj.net
+
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
+
+post-patch:
+ @${PERL} -pi -e "s=/etc=${PREFIX}/etc=g" ${WRKSRC}/p0f.c
+ @${PERL} -pi -e "s=/etc=${PREFIX}/etc=g" ${WRKSRC}/README
+
+do-install:
+ @${INSTALL_PROGRAM} ${WRKSRC}/p0f ${PREFIX}/bin
+ @${INSTALL_DATA} ${WRKSRC}/p0f.fp ${PREFIX}/etc
+
+post-install:
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${PREFIX}/share/doc/p0f
+ @${INSTALL_DATA} ${WRKSRC}/README ${PREFIX}/share/doc/p0f
+.endif
+
+.include <bsd.port.mk>