aboutsummaryrefslogtreecommitdiffstats
path: root/net-mgmt/p5-BigIP-iControl/Makefile
diff options
context:
space:
mode:
authorjadawin <jadawin@FreeBSD.org>2012-11-27 17:03:26 +0800
committerjadawin <jadawin@FreeBSD.org>2012-11-27 17:03:26 +0800
commitf09a55bb4ec33b5df89fb86a869a2f41c97cecb4 (patch)
treee74008c66de8b5c7b73ef44f5b96cd7687987f46 /net-mgmt/p5-BigIP-iControl/Makefile
parent2663c0d2fa0f72be8d7b37a2d80a6fbf99e96b0c (diff)
downloadfreebsd-ports-gnome-f09a55bb4ec33b5df89fb86a869a2f41c97cecb4.tar.gz
freebsd-ports-gnome-f09a55bb4ec33b5df89fb86a869a2f41c97cecb4.tar.zst
freebsd-ports-gnome-f09a55bb4ec33b5df89fb86a869a2f41c97cecb4.zip
This package provides a Perl interface to the F5 BigIP iControl API.
The F5 BigIP iControl API is an open SOAP/XML for communicating with supported F5 BigIP products. WWW: http://search.cpan.org/dist/BigIP-iControl/ PR: ports/173395 Submitted by: snowfly@yuntech.edu.tw Feature safe: yes
Diffstat (limited to 'net-mgmt/p5-BigIP-iControl/Makefile')
-rw-r--r--net-mgmt/p5-BigIP-iControl/Makefile21
1 files changed, 21 insertions, 0 deletions
diff --git a/net-mgmt/p5-BigIP-iControl/Makefile b/net-mgmt/p5-BigIP-iControl/Makefile
new file mode 100644
index 000000000000..1466df7e6a91
--- /dev/null
+++ b/net-mgmt/p5-BigIP-iControl/Makefile
@@ -0,0 +1,21 @@
+# Created by: Tsung-Han Yeh <snowfly@yuntech.edu.tw>
+# $FreeBSD$
+
+PORTNAME= BigIP-iControl
+PORTVERSION= 0.095
+CATEGORIES= net-mgmt perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= snowfly@yuntech.edu.tw
+COMMENT= A Perl interface to the F5 iControl API
+
+RUN_DEPENDS= p5-SOAP-Lite>=0:${PORTSDIR}/net/p5-SOAP-Lite \
+ p5-MIME-Base64>=0:${PORTSDIR}/converters/p5-MIME-Base64
+BUILD_DEPENDS= ${RUN_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= BigIP::iControl.3
+
+.include <bsd.port.mk>