aboutsummaryrefslogtreecommitdiffstats
path: root/net-mgmt/p5-Data-Validate-IP
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2008-01-14 19:15:31 +0800
committermiwi <miwi@FreeBSD.org>2008-01-14 19:15:31 +0800
commit60a475140fa18a8dfdb543ebaa2f9c7920644f5c (patch)
tree759413418a78da9260d0f79ebd74fcf780c099ad /net-mgmt/p5-Data-Validate-IP
parent51b0254a0f694653c7e185b994281d79bbff6dab (diff)
downloadfreebsd-ports-gnome-60a475140fa18a8dfdb543ebaa2f9c7920644f5c.tar.gz
freebsd-ports-gnome-60a475140fa18a8dfdb543ebaa2f9c7920644f5c.tar.zst
freebsd-ports-gnome-60a475140fa18a8dfdb543ebaa2f9c7920644f5c.zip
This module collects ip validation routines to make input validation, and
untainting easier and more readable. All functions return an untainted value if the test passes, and undef if it fails. This means that you should always check for a defined status explicitly. Don't assume the return will be true. (e.g. is_username('0')) The value to test is always the first (and often only) argument. WWW: http://search.cpan.org/dist/Data-Validate-IP/ PR: ports/119264 Submitted by: Tuc <freebsd-ports at t-b-o-h.net>
Diffstat (limited to 'net-mgmt/p5-Data-Validate-IP')
-rw-r--r--net-mgmt/p5-Data-Validate-IP/Makefile25
-rw-r--r--net-mgmt/p5-Data-Validate-IP/distinfo3
-rw-r--r--net-mgmt/p5-Data-Validate-IP/pkg-descr10
-rw-r--r--net-mgmt/p5-Data-Validate-IP/pkg-plist20
4 files changed, 58 insertions, 0 deletions
diff --git a/net-mgmt/p5-Data-Validate-IP/Makefile b/net-mgmt/p5-Data-Validate-IP/Makefile
new file mode 100644
index 000000000000..e28fe3b36722
--- /dev/null
+++ b/net-mgmt/p5-Data-Validate-IP/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: net-mgmt/p5-Data-Validate-IP
+# Date created: 02 January 2008
+# Whom: Tuc <freebsd-ports@t-b-o-h.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Data-Validate-IP
+PORTVERSION= 0.08
+CATEGORIES= net-mgmt perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= Data
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= freebsd-ports@t-b-o-h.net
+COMMENT= Common data validation methods for IPs
+
+BUILD_DEPENDS= ${SITE_PERL}/Net/Netmask.pm:${PORTSDIR}/net-mgmt/p5-Net-Netmask
+RUN_DEPENDS= ${SITE_PERL}/Net/Netmask.pm:${PORTSDIR}/net-mgmt/p5-Net-Netmask
+
+PERL_CONFIGURE= yes
+
+MAN3= Data::Validate::IP.3
+
+.include <bsd.port.mk>
diff --git a/net-mgmt/p5-Data-Validate-IP/distinfo b/net-mgmt/p5-Data-Validate-IP/distinfo
new file mode 100644
index 000000000000..ce5e9c35ec16
--- /dev/null
+++ b/net-mgmt/p5-Data-Validate-IP/distinfo
@@ -0,0 +1,3 @@
+MD5 (Data-Validate-IP-0.08.tar.gz) = 42c9313f2efe300e940916d440db7510
+SHA256 (Data-Validate-IP-0.08.tar.gz) = c2dafe09ab292b95a9eb2863507eafd7aa52b054d4fbdafd713bcb9bb320b83d
+SIZE (Data-Validate-IP-0.08.tar.gz) = 6299
diff --git a/net-mgmt/p5-Data-Validate-IP/pkg-descr b/net-mgmt/p5-Data-Validate-IP/pkg-descr
new file mode 100644
index 000000000000..3528b0111f00
--- /dev/null
+++ b/net-mgmt/p5-Data-Validate-IP/pkg-descr
@@ -0,0 +1,10 @@
+This module collects ip validation routines to make input validation, and
+untainting easier and more readable.
+
+All functions return an untainted value if the test passes, and undef if it
+fails. This means that you should always check for a defined status
+explicitly. Don't assume the return will be true. (e.g. is_username('0'))
+
+The value to test is always the first (and often only) argument.
+
+WWW: http://search.cpan.org/dist/Data-Validate-IP/
diff --git a/net-mgmt/p5-Data-Validate-IP/pkg-plist b/net-mgmt/p5-Data-Validate-IP/pkg-plist
new file mode 100644
index 000000000000..ab6137c3e997
--- /dev/null
+++ b/net-mgmt/p5-Data-Validate-IP/pkg-plist
@@ -0,0 +1,20 @@
+%%SITE_PERL%%/Data/Validate/IP.pm
+%%SITE_PERL%%/auto/Data/Validate/IP/_mask.al
+%%SITE_PERL%%/auto/Data/Validate/IP/autosplit.ix
+%%SITE_PERL%%/auto/Data/Validate/IP/is_ipv4.al
+%%SITE_PERL%%/auto/Data/Validate/IP/is_linklocal_ipv4.al
+%%SITE_PERL%%/auto/Data/Validate/IP/is_loopback_ipv4.al
+%%SITE_PERL%%/auto/Data/Validate/IP/is_multicast_ipv4.al
+%%SITE_PERL%%/auto/Data/Validate/IP/is_private_ipv4.al
+%%SITE_PERL%%/auto/Data/Validate/IP/is_public_ipv4.al
+%%SITE_PERL%%/auto/Data/Validate/IP/is_testnet_ipv4.al
+%%SITE_PERL%%/auto/Data/Validate/IP/new.al
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Data/Validate/IP/.packlist
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Data/Validate/IP
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Data/Validate
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Data
+@dirrmtry %%SITE_PERL%%/auto/Data/Validate/IP
+@dirrmtry %%SITE_PERL%%/auto/Data/Validate
+@dirrmtry %%SITE_PERL%%/auto/Data
+@dirrmtry %%SITE_PERL%%/Data/Validate
+@dirrmtry %%SITE_PERL%%/Data