aboutsummaryrefslogtreecommitdiffstats
path: root/net-mgmt/p5-Net-IP/Makefile
diff options
context:
space:
mode:
authortobez <tobez@FreeBSD.org>2002-06-13 18:42:49 +0800
committertobez <tobez@FreeBSD.org>2002-06-13 18:42:49 +0800
commit29571aedaaaeda195c3b59d97831a252fc305668 (patch)
treeeb6d06c5a284b3bc2a964ff72309a8a9851b12f2 /net-mgmt/p5-Net-IP/Makefile
parent63653a2ce440d6eb240be526673149b9a0ed82ea (diff)
downloadfreebsd-ports-gnome-29571aedaaaeda195c3b59d97831a252fc305668.tar.gz
freebsd-ports-gnome-29571aedaaaeda195c3b59d97831a252fc305668.tar.zst
freebsd-ports-gnome-29571aedaaaeda195c3b59d97831a252fc305668.zip
Add p5-Net-IP 1.11, a perl extension for manipulating IPv4/IPv6
addresses. PR: 38738 Submitted by: Kimura Fuyuki <fuyuki@hadaly.org>
Diffstat (limited to 'net-mgmt/p5-Net-IP/Makefile')
-rw-r--r--net-mgmt/p5-Net-IP/Makefile26
1 files changed, 26 insertions, 0 deletions
diff --git a/net-mgmt/p5-Net-IP/Makefile b/net-mgmt/p5-Net-IP/Makefile
new file mode 100644
index 000000000000..514fa74016e0
--- /dev/null
+++ b/net-mgmt/p5-Net-IP/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: p5-Net-IP
+# Date created: 30 May 2002
+# Whom: Kimura Fuyuki <fuyuki@hadaly.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Net-IP
+PORTVERSION= 1.11
+CATEGORIES= net perl5 ipv6
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Net
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= fuyuki@hadaly.org
+
+PERL_CONFIGURE= yes
+
+MAN3PREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+MAN3= Net::IP.3
+
+post-patch:
+ ${PERL} -pi -e 's,/usr/local/ncc/bin,${PREFIX}/bin,' ${WRKSRC}/Makefile.PL
+ ${PERL} -pi -e 's,/usr/local/bin/perl5.6.0,${PERL},' ${WRKSRC}/ipcount
+
+.include <bsd.port.mk>