aboutsummaryrefslogtreecommitdiffstats
path: root/net-mgmt/p5-Net-IPAddress
diff options
context:
space:
mode:
authorlippe <lippe@FreeBSD.org>2013-06-25 02:23:04 +0800
committerlippe <lippe@FreeBSD.org>2013-06-25 02:23:04 +0800
commit8686ac7e6bb683c2dc97b686827253ed60a3e48b (patch)
tree66d18790e131b85f8d637532e452da67de371de4 /net-mgmt/p5-Net-IPAddress
parent079ff7ddbf4df70a5db49f3af87f28ba6055c3b0 (diff)
downloadfreebsd-ports-gnome-8686ac7e6bb683c2dc97b686827253ed60a3e48b.tar.gz
freebsd-ports-gnome-8686ac7e6bb683c2dc97b686827253ed60a3e48b.tar.zst
freebsd-ports-gnome-8686ac7e6bb683c2dc97b686827253ed60a3e48b.zip
Net::IPAddr is a collection of helpful functions used to convert
IP addresses to/from 32-bit integers, applying subnet masks to IP addresses, validating IP address strings, and splitting a FQDN into its host and domain parts. No rocket science here, but I have found these functions to very, very handy. For example, have you ever tried to sort a list of IP addresses only to find out that they don't sort the way you expected? Here is the solution! If you convert the IP addresses to 32-bit integer addresses, they will sort in correct order. WWW: http://search.cpan.org/dist/Net-IPAddress/ PR: ports/179817 Submitted by: Alexandre Biancalana <ale@biancalanas.net>
Diffstat (limited to 'net-mgmt/p5-Net-IPAddress')
-rw-r--r--net-mgmt/p5-Net-IPAddress/Makefile18
-rw-r--r--net-mgmt/p5-Net-IPAddress/distinfo2
-rw-r--r--net-mgmt/p5-Net-IPAddress/pkg-descr12
-rw-r--r--net-mgmt/p5-Net-IPAddress/pkg-plist7
4 files changed, 39 insertions, 0 deletions
diff --git a/net-mgmt/p5-Net-IPAddress/Makefile b/net-mgmt/p5-Net-IPAddress/Makefile
new file mode 100644
index 000000000000..2a11a17ee64c
--- /dev/null
+++ b/net-mgmt/p5-Net-IPAddress/Makefile
@@ -0,0 +1,18 @@
+# Created by: Alexandre Biancalana <ale@biancalanas.net>
+# $FreeBSD$
+
+PORTNAME= Net-IPAddress
+PORTVERSION= 1.10
+CATEGORIES= net-mgmt perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= CPAN:SARENNER
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= ale@biancalanas.net
+COMMENT= Perl functions used to manipulate IP addresses, masks and FQDN's
+
+PERL_CONFIGURE= yes
+
+MAN3= Net::IPAddress.3
+
+.include <bsd.port.mk>
diff --git a/net-mgmt/p5-Net-IPAddress/distinfo b/net-mgmt/p5-Net-IPAddress/distinfo
new file mode 100644
index 000000000000..47ab532b2e15
--- /dev/null
+++ b/net-mgmt/p5-Net-IPAddress/distinfo
@@ -0,0 +1,2 @@
+SHA256 (Net-IPAddress-1.10.tar.gz) = 881308d2db0dc0f94434816d5e23b15e2da43c999283dc24e9ef55eb515b7b5e
+SIZE (Net-IPAddress-1.10.tar.gz) = 3024
diff --git a/net-mgmt/p5-Net-IPAddress/pkg-descr b/net-mgmt/p5-Net-IPAddress/pkg-descr
new file mode 100644
index 000000000000..21fed1437fdc
--- /dev/null
+++ b/net-mgmt/p5-Net-IPAddress/pkg-descr
@@ -0,0 +1,12 @@
+Net::IPAddr is a collection of helpful functions used to convert
+IP addresses to/from 32-bit integers, applying subnet masks to
+IP addresses, validating IP address strings, and splitting a FQDN
+into its host and domain parts.
+
+No rocket science here, but I have found these functions to very,
+very handy. For example, have you ever tried to sort a list of IP
+addresses only to find out that they don't sort the way you expected?
+Here is the solution! If you convert the IP addresses to 32-bit integer
+addresses, they will sort in correct order.
+
+WWW: http://search.cpan.org/dist/Net-IPAddress/
diff --git a/net-mgmt/p5-Net-IPAddress/pkg-plist b/net-mgmt/p5-Net-IPAddress/pkg-plist
new file mode 100644
index 000000000000..33c60e17e265
--- /dev/null
+++ b/net-mgmt/p5-Net-IPAddress/pkg-plist
@@ -0,0 +1,7 @@
+%%SITE_PERL%%/Net/IPAddress.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/IPAddress/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/IPAddress
+@dirrm %%SITE_PERL%%/auto/Net/IPAddress
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Net
+@dirrmtry %%SITE_PERL%%/auto/Net
+@dirrmtry %%SITE_PERL%%/Net