aboutsummaryrefslogtreecommitdiffstats
path: root/net-mgmt/p5-NetAddr-IP/Makefile
diff options
context:
space:
mode:
authortobez <tobez@FreeBSD.org>2006-08-22 18:48:30 +0800
committertobez <tobez@FreeBSD.org>2006-08-22 18:48:30 +0800
commitbed5a016c9bfcbdc47a660764ccae9a27de85b12 (patch)
treeccb829bd9396800f4e0d4e4d78b08cb22cb9dae3 /net-mgmt/p5-NetAddr-IP/Makefile
parent74bac082654fcdd77eb69ede81049d80ede4239a (diff)
downloadfreebsd-ports-gnome-bed5a016c9bfcbdc47a660764ccae9a27de85b12.tar.gz
freebsd-ports-gnome-bed5a016c9bfcbdc47a660764ccae9a27de85b12.tar.zst
freebsd-ports-gnome-bed5a016c9bfcbdc47a660764ccae9a27de85b12.zip
Update to 4.00.4.
PR: 102175 Submitted by: Jin-Shan Tseng <tjs@cdpa.nsysu.edu.tw>
Diffstat (limited to 'net-mgmt/p5-NetAddr-IP/Makefile')
-rw-r--r--net-mgmt/p5-NetAddr-IP/Makefile18
1 files changed, 11 insertions, 7 deletions
diff --git a/net-mgmt/p5-NetAddr-IP/Makefile b/net-mgmt/p5-NetAddr-IP/Makefile
index 87af2ed04cb4..7f97bca0dbf8 100644
--- a/net-mgmt/p5-NetAddr-IP/Makefile
+++ b/net-mgmt/p5-NetAddr-IP/Makefile
@@ -6,26 +6,30 @@
#
PORTNAME= NetAddr-IP
-PORTVERSION= 3.33
+PORTVERSION= 4.00.4
CATEGORIES= net-mgmt perl5
MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
MASTER_SITE_SUBDIR= ../../authors/id/L/LU/LUISMUNOZ
PKGNAMEPREFIX= p5-
+DISTNAME= ${PORTNAME}-${PORTVERSION:C/.([0-9])$/\1/}
MAINTAINER= tobez@FreeBSD.org
COMMENT= Perl module for working with IP addresses and blocks thereof
PERL_CONFIGURE= yes
-MAN3= NetAddr::IP.3
+MAN3= NetAddr::IP.3 \
+ NetAddr::IP::Lite.3 \
+ NetAddr::IP::Util.3 \
+ NetAddr::IP::UtilPP.3
.include <bsd.port.pre.mk>
-.if ${PERL_LEVEL} < 500601
-IGNORE= This port requires perl 5.6.x or later version
-.elif ${PERL_LEVEL} < 500800
-BUILD_DEPENDS= ${SITE_PERL}/Math/BigInt.pm:${PORTSDIR}/math/p5-Math-BigInt \
- ${SITE_PERL}/${PERL_ARCH}/Storable.pm:${PORTSDIR}/devel/p5-Storable
+post-patch:
+ ${PERL} -ni -e 'print unless /^=head1/../^=cut/' ${WRKSRC}/Lite/Util/Makefile.PL
+
+.if ${PERL_LEVEL} < 500700
+BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Storable.pm:${PORTSDIR}/devel/p5-Storable
RUN_DEPENDS= ${BUILD_DEPENDS}
.endif