aboutsummaryrefslogtreecommitdiffstats
path: root/net-mgmt/p5-NetAddr-IP/Makefile
diff options
context:
space:
mode:
authortobez <tobez@FreeBSD.org>2005-04-03 19:21:27 +0800
committertobez <tobez@FreeBSD.org>2005-04-03 19:21:27 +0800
commitfceeaa6ece94893f2c6897ea8c8abedb0a0e95c2 (patch)
tree56fbb15b6db8abcfbdfd3ddbadc44e8082de47f7 /net-mgmt/p5-NetAddr-IP/Makefile
parent5a79d8a9c6369557e33688988e1dd10ac285b0df (diff)
downloadfreebsd-ports-gnome-fceeaa6ece94893f2c6897ea8c8abedb0a0e95c2.tar.gz
freebsd-ports-gnome-fceeaa6ece94893f2c6897ea8c8abedb0a0e95c2.tar.zst
freebsd-ports-gnome-fceeaa6ece94893f2c6897ea8c8abedb0a0e95c2.zip
Update to 3.24. This port now requires perl >= 5.6.X.
Diffstat (limited to 'net-mgmt/p5-NetAddr-IP/Makefile')
-rw-r--r--net-mgmt/p5-NetAddr-IP/Makefile24
1 files changed, 10 insertions, 14 deletions
diff --git a/net-mgmt/p5-NetAddr-IP/Makefile b/net-mgmt/p5-NetAddr-IP/Makefile
index 92c98bfa4178..e3fdae13937e 100644
--- a/net-mgmt/p5-NetAddr-IP/Makefile
+++ b/net-mgmt/p5-NetAddr-IP/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= NetAddr-IP
-PORTVERSION= 3.21
+PORTVERSION= 3.24
CATEGORIES= net-mgmt perl5
MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
MASTER_SITE_SUBDIR= NetAddr
@@ -15,22 +15,18 @@ PKGNAMEPREFIX= p5-
MAINTAINER= tobez@FreeBSD.org
COMMENT= Perl module for working with IP addresses and blocks thereof
+BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Storable.pm:${PORTSDIR}/devel/p5-Storable \
+ ${SITE_PERL}/Math/BigInt.pm:${PORTSDIR}/math/p5-Math-BigInt
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
PERL_CONFIGURE= yes
-MAN3PREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
MAN3= NetAddr::IP.3
-post-patch:
- ${PERL} -pi -e 's/\r//;' \
- -e 's/^our\s+([\$$\@\%]\w+)/use vars qw($$1);\n$$1/;' \
- -e '$$_="" if /require 5/;' \
- -e '$$_="" if /use warnings/;' \
- ${WRKSRC}/IP.pm ${WRKSRC}/t/v4-badnm.t ${WRKSRC}/t/v4-new.t \
- ${WRKSRC}/t/v6-base.t
+.include <bsd.port.pre.mk>
-post-build:
- @${PERL} -M5.6.0 -e '' >/dev/null 2>&1 || \
- ( ${ECHO_MSG} "===> Please note that this module provides more functionality when" && \
- ${ECHO_MSG} "===> used with perl 5.6.1 or perl 5.8.1 (both in the ports collection)." )
+.if ${PERL_LEVEL} < 500601
+IGNORE= This port requires perl 5.6.x or later version
+.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>