aboutsummaryrefslogtreecommitdiffstats
path: root/net-mgmt/p5-Tie-NetAddr-IP/Makefile
diff options
context:
space:
mode:
authorasmodai <asmodai@FreeBSD.org>2001-04-03 04:02:38 +0800
committerasmodai <asmodai@FreeBSD.org>2001-04-03 04:02:38 +0800
commit27c3259963fdb2c45d532c7f2a817f9169d8c507 (patch)
tree5c5586951acc538b86df1e0262caec464326c39a /net-mgmt/p5-Tie-NetAddr-IP/Makefile
parentf39f63210ffab40ba533aece2991e391c17e87f8 (diff)
downloadfreebsd-ports-gnome-27c3259963fdb2c45d532c7f2a817f9169d8c507.tar.gz
freebsd-ports-gnome-27c3259963fdb2c45d532c7f2a817f9169d8c507.tar.zst
freebsd-ports-gnome-27c3259963fdb2c45d532c7f2a817f9169d8c507.zip
Add p5-Tie-NetAddr-IP:
This module overloads hashes so that the key can be a subnet as in NetAddr::IP. When looking values up, an interpretation will be made to find the given key within the subnets specified in the hash. Care must be taken, as only strings that can be parsed as an IP address by NetAddr::IP can be used as keys for this hash.
Diffstat (limited to 'net-mgmt/p5-Tie-NetAddr-IP/Makefile')
-rw-r--r--net-mgmt/p5-Tie-NetAddr-IP/Makefile25
1 files changed, 25 insertions, 0 deletions
diff --git a/net-mgmt/p5-Tie-NetAddr-IP/Makefile b/net-mgmt/p5-Tie-NetAddr-IP/Makefile
new file mode 100644
index 000000000000..f8d9557bd401
--- /dev/null
+++ b/net-mgmt/p5-Tie-NetAddr-IP/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: net/p5-Tie-NetAddr-IP
+# Date created: 29 March 2001
+# Whom: Anton Berezin <tobez@tobez.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Tie-NetAddr-IP
+PORTVERSION= 1.00
+CATEGORIES= net perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Tie
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= tobez@tobez.org
+
+BUILD_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/NetAddr/IP.pm:${PORTSDIR}/net/p5-NetAddr-IP
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Tie::NetAddr::IP.3
+MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+
+.include <bsd.port.mk>