aboutsummaryrefslogtreecommitdiffstats
path: root/net-mgmt/pmacct/Makefile
diff options
context:
space:
mode:
authordaichi <daichi@FreeBSD.org>2003-07-02 20:04:18 +0800
committerdaichi <daichi@FreeBSD.org>2003-07-02 20:04:18 +0800
commit69d1d7b773c5e2609b1ecdd12897d169df4e6a97 (patch)
tree1064f759a405e4624ff8a272bc3833d46c4c1742 /net-mgmt/pmacct/Makefile
parenta8bb42f23b52eb3e1a6657ee97b9be7abe3076b3 (diff)
downloadfreebsd-ports-gnome-69d1d7b773c5e2609b1ecdd12897d169df4e6a97.tar.gz
freebsd-ports-gnome-69d1d7b773c5e2609b1ecdd12897d169df4e6a97.tar.zst
freebsd-ports-gnome-69d1d7b773c5e2609b1ecdd12897d169df4e6a97.zip
update net/pmacct: 0.4.1 --> 0.4.2
PR: 53637 Submitted by: Kirill Ponomarew <ponomarew@oberon.net> (maintainer)
Diffstat (limited to 'net-mgmt/pmacct/Makefile')
-rw-r--r--net-mgmt/pmacct/Makefile28
1 files changed, 18 insertions, 10 deletions
diff --git a/net-mgmt/pmacct/Makefile b/net-mgmt/pmacct/Makefile
index 984d3376956f..cbf187eb5a6c 100644
--- a/net-mgmt/pmacct/Makefile
+++ b/net-mgmt/pmacct/Makefile
@@ -6,31 +6,39 @@
#
PORTNAME= pmacct
-PORTVERSION= 0.4.1
+PORTVERSION= 0.4.2
CATEGORIES= net
MASTER_SITES= http://www.ba.cnr.it/~paolo/pmacct/
MAINTAINER= ponomarew@oberon.net
COMMENT= Network tool to gather IP traffic information
+.if defined(WITH_MYSQL)
+LIB_DEPENDS+= mysqlclient.10:${PORTSDIR}/databases/mysql323-client
+CONFIGURE_ARGS+=--with-mysql-lib=${LOCALBASE}/lib/mysql \
+ --with-mysql-includes=${LOCALBASE}/include/mysql \
+ --enable-mysql
+.else
+CONFIGURE_ARGS+= --disable-mysql
+.endif
+
GNU_CONFIGURE= yes
USE_GETOPT_LONG=yes
USE_REINPLACE= yes
-
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
CFLAGS="${CFLAGS} -I${LOCALBASE}/include" \
pre-patch:
- @${REINPLACE_CMD} -e 's,<mysql/mysql.h>,<mysql.h>,' \
+ @${REINPLACE_CMD} -e \
+ 's,<mysql/mysql.h>,<mysql.h>,' \
${WRKSRC}/mysql_plugin.h
-.if defined(WITH_MYSQL)
-LIB_DEPENDS+= mysqlclient.10:${PORTSDIR}/databases/mysql323-client
-CONFIGURE_ARGS+=--with-mysql-lib=${LOCALBASE}/lib/mysql \
- --with-mysql-includes=${LOCALBASE}/include/mysql \
- --enable-mysql
-.else
-CONFIGURE_ARGS+= --disable-mysql
+post-install:
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+.for i in README EXAMPLES INTERNALS PLUGINS
+ ${INSTALL_DATA} ${WRKSRC}/${i} ${DOCSDIR}
+.endfor
.endif
.include <bsd.port.mk>