aboutsummaryrefslogtreecommitdiffstats
path: root/net-mgmt/pmacct/Makefile
diff options
context:
space:
mode:
authorpetef <petef@FreeBSD.org>2003-05-19 10:05:45 +0800
committerpetef <petef@FreeBSD.org>2003-05-19 10:05:45 +0800
commit85de0ae3a102b0ca8c8b0cba633d0db5e0a422c1 (patch)
tree23945cf6dfe4a5392129441b33c3188b077be230 /net-mgmt/pmacct/Makefile
parentfeac023b42e93e3580d5b7748d545590b8b3a021 (diff)
downloadfreebsd-ports-gnome-85de0ae3a102b0ca8c8b0cba633d0db5e0a422c1.tar.gz
freebsd-ports-gnome-85de0ae3a102b0ca8c8b0cba633d0db5e0a422c1.tar.zst
freebsd-ports-gnome-85de0ae3a102b0ca8c8b0cba633d0db5e0a422c1.zip
- use USE_GETOPT_LONG
- fix WITH_MYSQL build PR: 52152, 52150 Submitted by: maintainer
Diffstat (limited to 'net-mgmt/pmacct/Makefile')
-rw-r--r--net-mgmt/pmacct/Makefile8
1 files changed, 6 insertions, 2 deletions
diff --git a/net-mgmt/pmacct/Makefile b/net-mgmt/pmacct/Makefile
index a5b2e19aea4c..984d3376956f 100644
--- a/net-mgmt/pmacct/Makefile
+++ b/net-mgmt/pmacct/Makefile
@@ -13,13 +13,17 @@ MASTER_SITES= http://www.ba.cnr.it/~paolo/pmacct/
MAINTAINER= ponomarew@oberon.net
COMMENT= Network tool to gather IP traffic information
-WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
-
GNU_CONFIGURE= yes
+USE_GETOPT_LONG=yes
+USE_REINPLACE= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
CFLAGS="${CFLAGS} -I${LOCALBASE}/include" \
+pre-patch:
+ @${REINPLACE_CMD} -e 's,<mysql/mysql.h>,<mysql.h>,' \
+ ${WRKSRC}/mysql_plugin.h
+
.if defined(WITH_MYSQL)
LIB_DEPENDS+= mysqlclient.10:${PORTSDIR}/databases/mysql323-client
CONFIGURE_ARGS+=--with-mysql-lib=${LOCALBASE}/lib/mysql \