aboutsummaryrefslogtreecommitdiffstats
path: root/net-mgmt/pmacct/Makefile
diff options
context:
space:
mode:
authorkrion <krion@FreeBSD.org>2004-01-27 23:51:34 +0800
committerkrion <krion@FreeBSD.org>2004-01-27 23:51:34 +0800
commit9933774fcf2cffe951f6a9ee1684998199cb1f4e (patch)
tree7bc68ef55a479ea2932bed9a11cabaa7dc4c70e7 /net-mgmt/pmacct/Makefile
parent1ba8a8a49eec0bf6dcac54850816bbf19e814b66 (diff)
downloadfreebsd-ports-gnome-9933774fcf2cffe951f6a9ee1684998199cb1f4e.tar.gz
freebsd-ports-gnome-9933774fcf2cffe951f6a9ee1684998199cb1f4e.tar.zst
freebsd-ports-gnome-9933774fcf2cffe951f6a9ee1684998199cb1f4e.zip
- Update to version 0.6.0
* Add PostgreSQL support
Diffstat (limited to 'net-mgmt/pmacct/Makefile')
-rw-r--r--net-mgmt/pmacct/Makefile16
1 files changed, 14 insertions, 2 deletions
diff --git a/net-mgmt/pmacct/Makefile b/net-mgmt/pmacct/Makefile
index 378912cc403c..bb17cbbd293c 100644
--- a/net-mgmt/pmacct/Makefile
+++ b/net-mgmt/pmacct/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= pmacct
-PORTVERSION= 0.5.4
+PORTVERSION= 0.6.0
CATEGORIES= net
MASTER_SITES= http://www.ba.cnr.it/~paolo/pmacct/
@@ -18,8 +18,20 @@ USE_MYSQL= yes
CONFIGURE_ARGS+=--with-mysql-lib=${LOCALBASE}/lib/mysql \
--with-mysql-includes=${LOCALBASE}/include/mysql \
--enable-mysql
+CFLAGS+= "-I${LOCALBASE}/include"
+PLIST_SUB+= WITH_MYSQL=""
.else
CONFIGURE_ARGS+= --disable-mysql
+PLIST_SUB+= WITH_MYSQL="@comment "
+.endif
+
+.if defined(WITH_PGSQL)
+LIB_DEPENDS+= pq.3:${PORTSDIR}/databases/postgresql7
+CONFIGURE_ARGS+=--enable-pgsql
+PLIST_SUB+= WITH_PGSQL=""
+.else
+CONFIGURE_ARGS+= --disable-pgsql
+PLIST_SUB+= WITH_PGSQL="@comment "
.endif
GNU_CONFIGURE= yes
@@ -33,7 +45,7 @@ pre-patch:
's,<mysql/mysql.h>,<mysql.h>,' \
${WRKSRC}/mysql_plugin.h
@${REINPLACE_CMD} -e \
- 's|-O2|${CFLAGS}|g' ${WRKSRC}/configure
+ 's|-O2||g' ${WRKSRC}/configure
post-install:
.if !defined(NOPORTDOCS)