aboutsummaryrefslogtreecommitdiffstats
path: root/net-mgmt/pmacct/Makefile
diff options
context:
space:
mode:
authorkrion <krion@FreeBSD.org>2005-12-10 17:45:32 +0800
committerkrion <krion@FreeBSD.org>2005-12-10 17:45:32 +0800
commitc83a0ea697b7a785fdf679ce61bcc7853c603dfd (patch)
treefa37dc96ba45dfa3f3b173631f8754a24ab33438 /net-mgmt/pmacct/Makefile
parent180e7df9c4ca6c642de019a64d522dfbc24e69aa (diff)
downloadfreebsd-ports-gnome-c83a0ea697b7a785fdf679ce61bcc7853c603dfd.tar.gz
freebsd-ports-gnome-c83a0ea697b7a785fdf679ce61bcc7853c603dfd.tar.zst
freebsd-ports-gnome-c83a0ea697b7a785fdf679ce61bcc7853c603dfd.zip
Update to 0.9.5
Diffstat (limited to 'net-mgmt/pmacct/Makefile')
-rw-r--r--net-mgmt/pmacct/Makefile12
1 files changed, 10 insertions, 2 deletions
diff --git a/net-mgmt/pmacct/Makefile b/net-mgmt/pmacct/Makefile
index e00196f7ae9b..7f34939069a3 100644
--- a/net-mgmt/pmacct/Makefile
+++ b/net-mgmt/pmacct/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= pmacct
-PORTVERSION= 0.9.4p1
+PORTVERSION= 0.9.5
CATEGORIES= net-mgmt
MASTER_SITES= http://www.ba.cnr.it/~paolo/pmacct/
@@ -17,12 +17,12 @@ GNU_CONFIGURE= yes
GNUCONFIGURE_TARGET=--build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
-WRKSRC= ${WRKDIR}/${PORTNAME}-0.9.4
USE_GETOPT_LONG=yes
USE_REINPLACE= yes
OPTIONS= MYSQL "Enable MySQL support." Off \
PGSQL "Enable PostgreSQL support." Off \
+ SQLITE "Enable SQLite support." Off \
MMAP "Enable mmap(2) support." On \
LAYER2 "Enable Layer-2 support: MAC Adresses and VLANs" On
@@ -50,6 +50,14 @@ CONFIGURE_ARGS+= --disable-pgsql
PLIST_SUB+= WITH_PGSQL="@comment "
.endif
+.if defined(WITH_SQLITE)
+LIB_DEPENDS+= sqlite3.8:${PORTSDIR}/databases/sqlite3
+CONFIGURE_ARGS+=--enable-sqlite3 \
+ --with-sqlite3-includes=${LOCALBASE}/include
+.else
+CONFIGURE_ARGS+=--disable-sqlite3
+.endif
+
.if defined(WITHOUT_MMAP)
CONFIGURE_ARGS+=--disable-mmap
.else