aboutsummaryrefslogtreecommitdiffstats
path: root/net-mgmt/pmacct/Makefile
diff options
context:
space:
mode:
authorfjoe <fjoe@FreeBSD.org>2003-05-13 00:17:50 +0800
committerfjoe <fjoe@FreeBSD.org>2003-05-13 00:17:50 +0800
commite630c4f1006dfa7fa1e0a68280fa79af68a8d5fc (patch)
tree65daae4a8434a4a4d2563635b17d546ee3a37646 /net-mgmt/pmacct/Makefile
parentf9d382a5833299cb6d7ade6fe33469fa47acd650 (diff)
downloadfreebsd-ports-gnome-e630c4f1006dfa7fa1e0a68280fa79af68a8d5fc.tar.gz
freebsd-ports-gnome-e630c4f1006dfa7fa1e0a68280fa79af68a8d5fc.tar.zst
freebsd-ports-gnome-e630c4f1006dfa7fa1e0a68280fa79af68a8d5fc.zip
New port: pmacct
Network tool to gather IP traffic information. PR: 51979 Submitted by: Kirill Ponomarew
Diffstat (limited to 'net-mgmt/pmacct/Makefile')
-rw-r--r--net-mgmt/pmacct/Makefile32
1 files changed, 32 insertions, 0 deletions
diff --git a/net-mgmt/pmacct/Makefile b/net-mgmt/pmacct/Makefile
new file mode 100644
index 000000000000..a5b2e19aea4c
--- /dev/null
+++ b/net-mgmt/pmacct/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: pmacct
+# Date created: Thu May 8 16:03:11 CEST 2003
+# Whom: Kirill Ponomarew <ponomarew@oberon.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= pmacct
+PORTVERSION= 0.4.1
+CATEGORIES= net
+MASTER_SITES= http://www.ba.cnr.it/~paolo/pmacct/
+
+MAINTAINER= ponomarew@oberon.net
+COMMENT= Network tool to gather IP traffic information
+
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
+
+GNU_CONFIGURE= yes
+
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ CFLAGS="${CFLAGS} -I${LOCALBASE}/include" \
+
+.if defined(WITH_MYSQL)
+LIB_DEPENDS+= mysqlclient.10:${PORTSDIR}/databases/mysql323-client
+CONFIGURE_ARGS+=--with-mysql-lib=${LOCALBASE}/lib/mysql \
+ --with-mysql-includes=${LOCALBASE}/include/mysql \
+ --enable-mysql
+.else
+CONFIGURE_ARGS+= --disable-mysql
+.endif
+
+.include <bsd.port.mk>