aboutsummaryrefslogtreecommitdiffstats
path: root/net-mgmt/prometheus2/Makefile
diff options
context:
space:
mode:
authorjrm <jrm@FreeBSD.org>2018-04-11 04:31:57 +0800
committerjrm <jrm@FreeBSD.org>2018-04-11 04:31:57 +0800
commit58bf6203d55b1b4ba267af21428c315ef3e68300 (patch)
treeb609da7629ebbd4f1717ce06657b6d3457f9480a /net-mgmt/prometheus2/Makefile
parent9670831faec127a00503c33c74afb48409ce75b8 (diff)
downloadfreebsd-ports-gnome-58bf6203d55b1b4ba267af21428c315ef3e68300.tar.gz
freebsd-ports-gnome-58bf6203d55b1b4ba267af21428c315ef3e68300.tar.zst
freebsd-ports-gnome-58bf6203d55b1b4ba267af21428c315ef3e68300.zip
net-mgmt/prometheus2: Update to version 2.2.1 [1]
Also, tweaks to conform to Porter's Handbook: - Set DISTVERSION instead of PORTVERSION directly - Update order of blocks/variables Submitted by: dor.bsd@xm0.uk (maintainer) [1] Differential Revision: https://reviews.freebsd.org/D14657
Diffstat (limited to 'net-mgmt/prometheus2/Makefile')
-rw-r--r--net-mgmt/prometheus2/Makefile10
1 files changed, 2 insertions, 8 deletions
diff --git a/net-mgmt/prometheus2/Makefile b/net-mgmt/prometheus2/Makefile
index a749cf7f4ace..21e8d85b903b 100644
--- a/net-mgmt/prometheus2/Makefile
+++ b/net-mgmt/prometheus2/Makefile
@@ -1,8 +1,8 @@
# $FreeBSD$
PORTNAME= prometheus
-PORTVERSION= 2.1.0
DISTVERSIONPREFIX= v
+DISTVERSION= 2.2.1
CATEGORIES= net-mgmt
MAINTAINER= dor.bsd@xm0.uk
@@ -12,12 +12,8 @@ LICENSE= APACHE20
LICENSE_FILE= ${WRKSRC}/LICENSE
USES= go gmake
-USE_GITHUB= yes
-GH_ACCOUNT= prometheus
-GH_PROJECT= prometheus
-
GO_PKGNAME= github.com/${GH_ACCOUNT}/${GH_PROJECT}
-
+USE_GITHUB= yes
USE_RC_SUBR= prometheus
USERS= prometheus
@@ -30,7 +26,6 @@ LD_FLAG_STRING= -s \
${LD_FLAG_X_PREFIX}.Revision=${PORTREVISION} \
${LD_FLAG_X_PREFIX}.Branch=release-${PORTVERSION:R} \
${LD_FLAG_X_PREFIX}.BuildUser=${BUILD_USER}
-
PROMETHEUS_BINARIES= prometheus promtool
do-build:
@@ -43,7 +38,6 @@ do-install:
.for bin in ${PROMETHEUS_BINARIES}
${INSTALL_PROGRAM} ${GO_WRKDIR_BIN}/${bin} ${STAGEDIR}${PREFIX}/bin
.endfor
-
${INSTALL_DATA} \
${WRKSRC}/documentation/examples/prometheus.yml \
${STAGEDIR}${LOCALBASE}/etc/prometheus.yml.sample