aboutsummaryrefslogtreecommitdiffstats
path: root/net-mgmt/rancid-devel/Makefile
diff options
context:
space:
mode:
authorkevlo <kevlo@FreeBSD.org>2002-09-10 11:06:30 +0800
committerkevlo <kevlo@FreeBSD.org>2002-09-10 11:06:30 +0800
commitdf0dcc484d964d538b914e5357e5839c36225245 (patch)
treea59b05f37a2a342006f36273277f258ca97b483b /net-mgmt/rancid-devel/Makefile
parenta4b9e626ce99ed8c0b8757b5aeea81480e6f8561 (diff)
downloadfreebsd-ports-gnome-df0dcc484d964d538b914e5357e5839c36225245.tar.gz
freebsd-ports-gnome-df0dcc484d964d538b914e5357e5839c36225245.tar.zst
freebsd-ports-gnome-df0dcc484d964d538b914e5357e5839c36225245.zip
Update to version 2.2.2
PR: 42583 Submitted by: MAINTAINER
Diffstat (limited to 'net-mgmt/rancid-devel/Makefile')
-rw-r--r--net-mgmt/rancid-devel/Makefile14
1 files changed, 11 insertions, 3 deletions
diff --git a/net-mgmt/rancid-devel/Makefile b/net-mgmt/rancid-devel/Makefile
index 563d24772d28..319d10e672bf 100644
--- a/net-mgmt/rancid-devel/Makefile
+++ b/net-mgmt/rancid-devel/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= rancid
-PORTVERSION= 2.2.1
+PORTVERSION= 2.2.2
CATEGORIES= net
MASTER_SITES= ftp://ftp.shrubbery.net/pub/rancid/
@@ -25,15 +25,17 @@ HAS_CONFIGURE= yes
CONFIGURE_ARGS= \
--prefix=${PREFIX}/rancid
-MANPREFIX= ${PREFIX}/rancid
+MANPREFIX= ${PREFIX}/rancid
-MAN1= lg_intro.1 par.1 do-diffs.1 alogin.1 blogin.1 clogin.1 \
+MAN1= lg_intro.1 par.1 do-diffs.1 alogin.1 blogin.1 clogin.1 \
control_rancid.1 create_cvs.1 rancid.1 rancid_intro.1 \
elogin.1 f10rancid.1 flogin.1 hlogin.1 hrancid.1 jlogin.1 \
jrancid.1 francid.1 cat5rancid.1 erancid.1 mrancid.1 xrancid.1
MAN5= env.5 lg.conf.5 cloginrc.5 router.db.5
+CONFIG_FILES= bin/env util/lg/lg.conf
+
post-install:
@ ${SED} -e "s:%%INSTDIR%%:${PREFIX}/rancid:g" pkg-message >${PKGMESSAGE}
.if !defined(BATCH)
@@ -41,5 +43,11 @@ post-install:
@ ${CAT} ${PKGMESSAGE}
@ ${ECHO}
.endif
+.for file in ${CONFIG_FILES}
+ @ if [ -f ${PREFIX}/rancid/${file}.new ] ; then \
+ ${ECHO} "WARNING: *** new ${file} file is installed as ${PREFIX}/rancid/${file}.new"; \
+ ${ECHO} " : *** review ${file} for new/deprecated switches"; \
+ fi
+.endfor
.include <bsd.port.mk>