aboutsummaryrefslogtreecommitdiffstats
path: root/net-mgmt/rancid-devel/Makefile
diff options
context:
space:
mode:
authorwill <will@FreeBSD.org>2002-06-23 16:17:32 +0800
committerwill <will@FreeBSD.org>2002-06-23 16:17:32 +0800
commitf22f9811136961bf58b7431cbef892151b9a42ff (patch)
tree3cf88d02f426191e19a747764e52c037ad1debef /net-mgmt/rancid-devel/Makefile
parentaabecebf552996b004bbabb54af17a90d95b3253 (diff)
downloadfreebsd-ports-gnome-f22f9811136961bf58b7431cbef892151b9a42ff.tar.gz
freebsd-ports-gnome-f22f9811136961bf58b7431cbef892151b9a42ff.tar.zst
freebsd-ports-gnome-f22f9811136961bf58b7431cbef892151b9a42ff.zip
Add rancid 2.2.1, Really Awesome New Cisco confIg Differ.
PR: 38856 Submitted by: Janos.Mohacsi@bsd.hu
Diffstat (limited to 'net-mgmt/rancid-devel/Makefile')
-rw-r--r--net-mgmt/rancid-devel/Makefile45
1 files changed, 45 insertions, 0 deletions
diff --git a/net-mgmt/rancid-devel/Makefile b/net-mgmt/rancid-devel/Makefile
new file mode 100644
index 000000000000..563d24772d28
--- /dev/null
+++ b/net-mgmt/rancid-devel/Makefile
@@ -0,0 +1,45 @@
+# New ports collection makefile for: rancid
+# Date created: 3 June 2002
+# Whom: Janos.Mohacsi@bsd.hu
+#
+# $FreeBSD$
+#
+
+PORTNAME= rancid
+PORTVERSION= 2.2.1
+CATEGORIES= net
+MASTER_SITES= ftp://ftp.shrubbery.net/pub/rancid/
+
+MAINTAINER= janos.mohacsi@bsd.hu
+
+BUILD_DEPENDS= expect:${PORTSDIR}/lang/expect
+RUN_DEPENDS= expect:${PORTSDIR}/lang/expect \
+ ${SITE_PERL}/CGI.pm:${PORTSDIR}/www/p5-CGI.pm \
+ ${SITE_PERL}/LockFile/Simple.pm:${PORTSDIR}/devel/p5-LockFile-Simple
+
+SITE_PERL= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}
+USE_PERL5= yes
+PKGMESSAGE= ${WRKDIR}/pkg-message
+USE_GMAKE= yes
+HAS_CONFIGURE= yes
+CONFIGURE_ARGS= \
+ --prefix=${PREFIX}/rancid
+
+MANPREFIX= ${PREFIX}/rancid
+
+MAN1= lg_intro.1 par.1 do-diffs.1 alogin.1 blogin.1 clogin.1 \
+ control_rancid.1 create_cvs.1 rancid.1 rancid_intro.1 \
+ elogin.1 f10rancid.1 flogin.1 hlogin.1 hrancid.1 jlogin.1 \
+ jrancid.1 francid.1 cat5rancid.1 erancid.1 mrancid.1 xrancid.1
+
+MAN5= env.5 lg.conf.5 cloginrc.5 router.db.5
+
+post-install:
+ @ ${SED} -e "s:%%INSTDIR%%:${PREFIX}/rancid:g" pkg-message >${PKGMESSAGE}
+.if !defined(BATCH)
+ @ ${ECHO}
+ @ ${CAT} ${PKGMESSAGE}
+ @ ${ECHO}
+.endif
+
+.include <bsd.port.mk>