aboutsummaryrefslogtreecommitdiffstats
path: root/net-mgmt/spectools
diff options
context:
space:
mode:
authorrafan <rafan@FreeBSD.org>2007-06-22 19:44:28 +0800
committerrafan <rafan@FreeBSD.org>2007-06-22 19:44:28 +0800
commit059ab4037d81be76d4b0592441b452ed2ca66eb6 (patch)
tree1c13df7482373480130b4441cab99caf2216a624 /net-mgmt/spectools
parent3726b6e4a3671e91fb78c8a2b040c821330b1f6c (diff)
downloadfreebsd-ports-gnome-059ab4037d81be76d4b0592441b452ed2ca66eb6.tar.gz
freebsd-ports-gnome-059ab4037d81be76d4b0592441b452ed2ca66eb6.tar.zst
freebsd-ports-gnome-059ab4037d81be76d4b0592441b452ed2ca66eb6.zip
- Don't overload WITH_GTK in PLIST_SUB, use GTK instead.
- Use ALL_TARGET, so we don't need to have our own do-build target - Fix typo for NOPORTDOCS and typo in pkg-message PR: ports/113938 Submitted by: Henrik Brix Andersen <henrik at brixandersen.dk> (maintainer)
Diffstat (limited to 'net-mgmt/spectools')
-rw-r--r--net-mgmt/spectools/Makefile15
-rw-r--r--net-mgmt/spectools/pkg-message2
-rw-r--r--net-mgmt/spectools/pkg-plist2
3 files changed, 9 insertions, 10 deletions
diff --git a/net-mgmt/spectools/Makefile b/net-mgmt/spectools/Makefile
index a8ca91ed1671..e96485b1384e 100644
--- a/net-mgmt/spectools/Makefile
+++ b/net-mgmt/spectools/Makefile
@@ -34,17 +34,16 @@ IGNORE= is unsupported on systems prior to FreeBSD v602101
IGNORE= is unsupported on systems prior to FreeBSD v700027
.endif
+ALL_TARGET= wispy_curses wispy_log wispy_raw
.if defined(WITH_GTK)
-LIB_DEPENDS+= gtk:${PORTSDIR}/x11-toolkits/gtk20
-PLIST_SUB= WITH_GTK=""
-.else
-PLIST_SUB= WITH_GTK="@comment "
+ALL_TARGET+= wispy_gtk
.endif
-do-build:
- cd ${WRKSRC} && ${GMAKE} wispy_curses wispy_log wispy_raw
.if defined(WITH_GTK)
- cd ${WRKSRC} && ${GMAKE} wispy_gtk
+LIB_DEPENDS+= gtk:${PORTSDIR}/x11-toolkits/gtk20
+PLIST_SUB= GTK=""
+.else
+PLIST_SUB= GTK="@comment "
.endif
do-install:
@@ -56,7 +55,7 @@ do-install:
.endif
post-install:
-.ifndef(NOPORTDOC)
+.ifndef(NOPORTDOCS)
${MKDIR} ${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
.endif
diff --git a/net-mgmt/spectools/pkg-message b/net-mgmt/spectools/pkg-message
index 37cc221c0389..4845df27dcb4 100644
--- a/net-mgmt/spectools/pkg-message
+++ b/net-mgmt/spectools/pkg-message
@@ -1,4 +1,4 @@
====
In order to use the tools you need read/write access to the ugen(4)
-device node corresponding to your your Wi-Spy device.
+device node corresponding to the Wi-Spy device.
====
diff --git a/net-mgmt/spectools/pkg-plist b/net-mgmt/spectools/pkg-plist
index 4d80d344346b..9d17d8dbc686 100644
--- a/net-mgmt/spectools/pkg-plist
+++ b/net-mgmt/spectools/pkg-plist
@@ -1,4 +1,4 @@
bin/wispy_curses
-%%WITH_GTK%%bin/wispy_gtk
+%%GTK%%bin/wispy_gtk
bin/wispy_log
bin/wispy_raw