aboutsummaryrefslogtreecommitdiffstats
path: root/net-mgmt/tcpreplay/files
diff options
context:
space:
mode:
authormsmith <msmith@FreeBSD.org>2000-11-29 10:29:03 +0800
committermsmith <msmith@FreeBSD.org>2000-11-29 10:29:03 +0800
commit222e66b472ea274452a3c0648df80dbb5fa88c00 (patch)
treefa03f28c54aad125431716be952f5c4596061e0e /net-mgmt/tcpreplay/files
parentb34217a18a7ca458433e2c5ec634bf600caa0ec5 (diff)
downloadfreebsd-ports-gnome-222e66b472ea274452a3c0648df80dbb5fa88c00.tar.gz
freebsd-ports-gnome-222e66b472ea274452a3c0648df80dbb5fa88c00.tar.zst
freebsd-ports-gnome-222e66b472ea274452a3c0648df80dbb5fa88c00.zip
tcpreplay - a *working* libpcap trace file replay tool
Submitted by: "Christopher N. Harrell" <cnh@ivmg.net>
Diffstat (limited to 'net-mgmt/tcpreplay/files')
-rw-r--r--net-mgmt/tcpreplay/files/patch-Makefile.in34
-rw-r--r--net-mgmt/tcpreplay/files/patch-configure.in10
-rw-r--r--net-mgmt/tcpreplay/files/patch-tcpreplay.c31
3 files changed, 75 insertions, 0 deletions
diff --git a/net-mgmt/tcpreplay/files/patch-Makefile.in b/net-mgmt/tcpreplay/files/patch-Makefile.in
new file mode 100644
index 000000000000..4a4c01002a10
--- /dev/null
+++ b/net-mgmt/tcpreplay/files/patch-Makefile.in
@@ -0,0 +1,34 @@
+--- Makefile.in.orig Thu Nov 2 18:01:53 2000
++++ Makefile.in Thu Nov 2 18:04:49 2000
+@@ -9,22 +9,22 @@
+ CC = @CC@
+ CFLAGS = @CFLAGS@
+ LDFLAGS = @LDFLAGS@
+-DEFS = @DEFS@
++DEFS = @DEFS@ `libnet-config --defines`
+ INCS = $(LNETINCS) $(PCAPINCS)
+ LIBS = @LIBS@ $(LNETLIBS) $(PCAPLIBS)
+
+ INSTALL = @INSTALL@
+ INSTALL_PROGRAM = @INSTALL_PROGRAM@
+
+-PCAPDIR = libpcap-0.4
+-PCAPINCS = -I$(PCAPDIR)
+-PCAPLIBS = -L$(PCAPDIR) -lpcap
+-PCAPDEP = $(PCAPDIR)/pcap.h $(PCAPDIR)/libpcap.a
++# PCAPDIR = libpcap-0.4
++# PCAPINCS = -I$(PCAPDIR)
++PCAPLIBS = -lpcap
++# PCAPDEP = $(PCAPDIR)/pcap.h $(PCAPDIR)/libpcap.a
+
+-LNETDIR = Libnet-0.99
+-LNETINCS = -I$(LNETDIR)/include
+-LNETLIBS = -L$(LNETDIR)/lib -lnet
+-LNETDEP = $(LNETDIR)/include/libnet.h $(LNETDIR)/libnet.a
++# LNETDIR = Libnet-0.99
++LNETINCS = -I$(PREFIX)/include
++LNETLIBS = -L$(PREFIX)/lib `libnet-config --libs`
++# LNETDEP = $(LNETDIR)/include/libnet.h $(LNETDIR)/libnet.a
+
+ PROGRAMS = tcpreplay
+
diff --git a/net-mgmt/tcpreplay/files/patch-configure.in b/net-mgmt/tcpreplay/files/patch-configure.in
new file mode 100644
index 000000000000..91888f2fb4a2
--- /dev/null
+++ b/net-mgmt/tcpreplay/files/patch-configure.in
@@ -0,0 +1,10 @@
+--- configure.in.orig Thu Nov 2 16:18:38 2000
++++ configure.in Thu Nov 2 16:18:52 2000
+@@ -29,7 +29,5 @@
+ dnl Checks for library functions.
+ AC_CHECK_FUNCS(gettimeofday)
+
+-AC_CONFIG_SUBDIRS(Libnet-0.99 libpcap-0.4)
+-
+ AC_CONFIG_HEADER(config.h)
+ AC_OUTPUT(Makefile)
diff --git a/net-mgmt/tcpreplay/files/patch-tcpreplay.c b/net-mgmt/tcpreplay/files/patch-tcpreplay.c
new file mode 100644
index 000000000000..1b49c631bfaf
--- /dev/null
+++ b/net-mgmt/tcpreplay/files/patch-tcpreplay.c
@@ -0,0 +1,31 @@
+--- tcpreplay.c.orig Wed May 19 13:00:35 1999
++++ tcpreplay.c Thu Nov 2 17:58:27 2000
+@@ -229,8 +229,8 @@
+ }
+
+ while (write_status < 0) {
+- write_status = write_link_layer((struct link_int *)user, interface,
+- data,pcap_hdr->caplen);
++ write_status = libnet_write_link_layer((struct libnet_link_int *)user,
++ interface,data,pcap_hdr->caplen);
+ #ifdef DEBUG
+ if (debug > 1) {
+ fprintf(stderr, "write_status = %i\n", write_status);
+@@ -255,7 +255,7 @@
+ int main(int argc, char * argv[])
+ {
+ pcap_t * in_file;
+- struct link_int * write_if;
++ struct libnet_link_int * write_if;
+ float Mrate = 0;
+ double starttime_local, startusec;
+ char ebuf[256];
+@@ -327,7 +327,7 @@
+ failed_writes = 0;
+ pkts_sent = 0;
+ bytes_sent = 0;
+- write_if = open_link_interface(interface,ebuf);
++ write_if = libnet_open_link_interface(interface,ebuf);
+ if (write_if <= 0) {
+ fprintf(stderr, "output i/f: %s\n",ebuf);
+ exit(1);