aboutsummaryrefslogtreecommitdiffstats
path: root/net-mgmt/tcpreplay
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2007-01-31 22:09:55 +0800
committerpav <pav@FreeBSD.org>2007-01-31 22:09:55 +0800
commitccd12ccd577604add511aad4ea4e71c32b3e2f06 (patch)
tree25b833c135dd7f2323045f819dc7121e621103fc /net-mgmt/tcpreplay
parente2f15954f8960a944e8d5b2c28982257d8c6e91f (diff)
downloadfreebsd-ports-gnome-ccd12ccd577604add511aad4ea4e71c32b3e2f06.tar.gz
freebsd-ports-gnome-ccd12ccd577604add511aad4ea4e71c32b3e2f06.tar.zst
freebsd-ports-gnome-ccd12ccd577604add511aad4ea4e71c32b3e2f06.zip
- Patch net/libnet* to versioned libraries and header files, so they can
coexist PR: ports/103861 Submitted by: alepulver Tested by: pointyhat With hat: portmgr
Diffstat (limited to 'net-mgmt/tcpreplay')
-rw-r--r--net-mgmt/tcpreplay/Makefile16
1 files changed, 13 insertions, 3 deletions
diff --git a/net-mgmt/tcpreplay/Makefile b/net-mgmt/tcpreplay/Makefile
index 36d1b830796f..fce858982c9c 100644
--- a/net-mgmt/tcpreplay/Makefile
+++ b/net-mgmt/tcpreplay/Makefile
@@ -7,6 +7,7 @@
PORTNAME= tcpreplay
PORTVERSION= 2.3.5
+PORTREVISION= 1
CATEGORIES= net-mgmt
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -14,18 +15,27 @@ MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= laszlof@FreeBSD.org
COMMENT= A tool to replay saved packet capture files
-BUILD_DEPENDS= libnet*>=1.1.2,1:${PORTSDIR}/net/libnet \
+BUILD_DEPENDS= ${LIBNET_CONFIG}:${PORTSDIR}/net/libnet \
${LOCALBASE}/lib/libpcap.a:${PORTSDIR}/net/libpcap
GNU_CONFIGURE= yes
-# Pickup correct pcap.h; CFLAGS gets overwritten
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include"
CONFIGURE_ARGS= --with-libpcap=${LOCALBASE} \
--without-pcapnav-config
+CFLAGS+= `${LIBNET_CONFIG} --cflags` -I${LOCALBASE}/include
MAN1= capinfo.1 tcpprep.1 pcapmerge.1 flowreplay.1
MAN8= tcpreplay.8
PLIST_FILES= bin/capinfo bin/pcapmerge bin/tcpprep sbin/tcpreplay bin/flowreplay
+LIBNET_CONFIG?= ${LOCALBASE}/bin/libnet11-config
+
+post-patch:
+ @${REINPLACE_CMD} -Ee \
+ 's|-pipe -Wall|$$CFLAGS &|; \
+ s|^(foundnet=)no|\1yes|; \
+ s|\$$LNETLIB|`${LIBNET_CONFIG} --libs`|; \
+ s|\$$LNETINCDIR/||' \
+ ${CONFIGURE_WRKSRC}/${CONFIGURE_SCRIPT}
+
.include <bsd.port.mk>