aboutsummaryrefslogtreecommitdiffstats
path: root/net-mgmt/tcpreplay
diff options
context:
space:
mode:
authordvl <dvl@FreeBSD.org>2017-08-31 03:32:00 +0800
committerdvl <dvl@FreeBSD.org>2017-08-31 03:32:00 +0800
commit70c31557335f9b1a247f34395bfc2320001a0064 (patch)
treea89f696883c6e940461113e617673de48a31cc14 /net-mgmt/tcpreplay
parent941c9bd6b4157f67679fe12851ebd98194543e9c (diff)
downloadfreebsd-ports-gnome-70c31557335f9b1a247f34395bfc2320001a0064.tar.gz
freebsd-ports-gnome-70c31557335f9b1a247f34395bfc2320001a0064.tar.zst
freebsd-ports-gnome-70c31557335f9b1a247f34395bfc2320001a0064.zip
Add base/port options for libpcap
PR: 221923 Approved by: ehaupt (maintainer)
Diffstat (limited to 'net-mgmt/tcpreplay')
-rw-r--r--net-mgmt/tcpreplay/Makefile13
1 files changed, 13 insertions, 0 deletions
diff --git a/net-mgmt/tcpreplay/Makefile b/net-mgmt/tcpreplay/Makefile
index f0d1cbe3fc95..63a1bb8debba 100644
--- a/net-mgmt/tcpreplay/Makefile
+++ b/net-mgmt/tcpreplay/Makefile
@@ -4,6 +4,7 @@
PORTNAME= tcpreplay
PORTVERSION= 4.2.6
DISTVERSIONPREFIX= v
+PORTREVISION= 1
CATEGORIES= net-mgmt
MAINTAINER= ehaupt@FreeBSD.org
@@ -27,6 +28,18 @@ CONFIGURE_ARGS= --program-transform-name='s|.*\(tcp.*\)|\1|' \
# required when using autogen
CONFIGURE_ARGS+= --disable-local-libopts --disable-libopts-install
+OPTIONS_DEFINE= LIBPCAP_BASE LIBPCAP_PORTS
+LIBPCAP_BASE= Build with libpcap from the base OS
+LIBPCAP_PORTS= Build with net/libpcap
+
+OPTIONS_SINGLE= SG1
+OPTIONS_SINGLE= LIBPCAP_BASE LIBPCAP_PORTS
+
+OPTIONS_DEFAULT= LIBPCAP_BASE
+
+LIBPCAP_PORTS_BUILD_DEPENDS= ${LOCALBASE}/lib/libpcap.a:net/libpcap
+LIBPCAP_PORTS_LIB_DEPENDS= libpcap.so:net/libpcap
+
post-patch:
@${REINPLACE_CMD} -e 's|-Wall -O3||' ${WRKSRC}/${CONFIGURE_SCRIPT}.ac