aboutsummaryrefslogtreecommitdiffstats
path: root/net-mgmt/yaf/Makefile
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2009-07-01 18:48:16 +0800
committermiwi <miwi@FreeBSD.org>2009-07-01 18:48:16 +0800
commit3550687d237ad8970f00705034ae5f1d007d7e50 (patch)
tree15bc673fa755b6e9fd92b21d0a05672a8b9ee3d4 /net-mgmt/yaf/Makefile
parentd038baa7b95e1514ea46ea365aac62a70c6afd55 (diff)
downloadfreebsd-ports-gnome-3550687d237ad8970f00705034ae5f1d007d7e50.tar.gz
freebsd-ports-gnome-3550687d237ad8970f00705034ae5f1d007d7e50.tar.zst
freebsd-ports-gnome-3550687d237ad8970f00705034ae5f1d007d7e50.zip
YAF is Yet Another Flowmeter. It processes packet data from pcap(3)
dumpfiles as generated by tcpdump(1) or via live capture from an interface using pcap(3) into bidirectional flows, then exports those flows to IPFIX Collecting Processes or in an IPFIX-based file format. YAF's output can be used with the SiLK flow analysis tools and any other IPFIX compliant toolchain. WWW: http://tools.netsa.cert.org/yaf/index.html PR: ports/136118 Submitted by: Dikshie <dikshie at sfc.wide.ad.jp>
Diffstat (limited to 'net-mgmt/yaf/Makefile')
-rw-r--r--net-mgmt/yaf/Makefile33
1 files changed, 33 insertions, 0 deletions
diff --git a/net-mgmt/yaf/Makefile b/net-mgmt/yaf/Makefile
new file mode 100644
index 000000000000..bfa61de4f313
--- /dev/null
+++ b/net-mgmt/yaf/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: yaf
+# Date created: 2009-06-29
+# Whom: Dikshie <dikshie@sfc.wide.ad.jp>
+#
+# $FreeBSD$
+
+PORTNAME= yaf
+PORTVERSION= 1.0.0.2
+CATEGORIES= net-mgmt
+MASTER_SITES= http://tools.netsa.cert.org/releases/
+
+MAINTAINER= dikshie@sfc.wide.ad.jp
+COMMENT= YAF is Yet Another Flowmeter
+
+LIB_DEPENDS= fixbuf:${PORTSDIR}/net/libfixbuf \
+ pcre.0:${PORTSDIR}/devel/pcre
+
+GNU_CONFIGURE= yes
+USE_GNOME= glib20 gnomehack
+USE_LDCONFIG= yes
+
+MAN1= airdaemon.1 filedaemon.1 yaf.1 yafscii.1
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|echo aout|echo elf|' ${WRKSRC}/configure
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 700042
+BROKEN= does not build on 6.x.
+.endif
+
+.include <bsd.port.post.mk>